• Welcome to Simple Machines Community Forum. Please login or sign up.

Simple ImageShack (latest release: v3.1.3)

Started by Rik©, June 03, 2005, 02:50:34 PM

Previous topic - Next topic

winky100


gezog

May 29, 2010, 01:15:41 PM #721 Last Edit: May 29, 2010, 01:20:26 PM by gezog
Sorry for my English, is a translator.
I have the same problem a little above, attached capture, I have translated it but do not know how I can fix it.
Thanks

amcapt89

Many thanks for your help Rik, that fixed my problem!

Rik©

@wink100:
Thanks for testing. Too bad it didn't work.
I'll have to create special cURL 7.20.0 editions....

@gezog:
Do you have cURL 7.20.0? (you can check it with check_curl.zip)
If you do you need BWJM's fix, i will release special editions for those who have cURL 7.20.0 soon.

@amcapt89:
Which cURL version do you have?

-Rik©

winky100

rik,

Does bwjm's fix work for all versions of curl?

Rik©

May 30, 2010, 10:11:21 AM #725 Last Edit: May 30, 2010, 10:35:41 AM by Rik©
Quote from: winky100 on May 30, 2010, 08:16:43 AM
rik,

Does bwjm's fix work for all versions of curl?
No, it has been reported not to work in all versions.
Quote7.18.2 : Does not work
7.20.0 : Works just fine
So i assume it only works with 7.20.0 and up.
Maybe BWJM's fix will also work with cURL 7.19 but it has not been tested yet.
You can check your version with check_curl.zip (instructions inside) which can be found at the SIS download page.

-Rik©

tbk22

=)

Rik©

May 30, 2010, 02:27:15 PM #727 Last Edit: May 30, 2010, 02:33:05 PM by Rik©
Maybe a conflict with another mod.
You can manually edit /Sources/admin.php after install (make a back-up first eg admin.php~).

-Rik©

ps let me know if you need more precise instructions.

tbk22

Quote from: Rik© on May 30, 2010, 02:27:15 PM
Maybe a conflict with another mod.
You can manually edit /Sources/admin.php after install (make a back-up first eg admin.php~).

-Rik©

ps let me know if you need more precise instructions.

I know I can edit manually thats no problem at all for me

I just thought this could be some kind of error in the mod code (bug)

Thanks
=)

Rik©

Quote from: tbk22 on May 30, 2010, 02:41:41 PM
Quote from: Rik© on May 30, 2010, 02:27:15 PM
Maybe a conflict with another mod.
You can manually edit /Sources/admin.php after install (make a back-up first eg admin.php~).

-Rik©

ps let me know if you need more precise instructions.

I know I can edit manually thats no problem at all for me

I just thought this could be some kind of error in the mod code (bug)

Thanks
Well, you're the first who had this 'search and add' error on install, so i assume it's caused by another mod that added some code near the code the installer is looking for (or changed it).
I try to keep the mod-package/install instructions as clean and unique as possible to avoid these errors.

-Rik©

vroum

May 30, 2010, 04:19:51 PM #730 Last Edit: May 30, 2010, 05:19:36 PM by vroum
Bad news :( none of the sis versions are working on what was the working server.

from phpinfo
cURL support enabled
cURL Information libcurl/7.19.5 zlib/1.2.3 libidn/0.6.5


from what i see nothing changed in the config, the mod just stopped working. tested sis from v3.0.1 to v3.0.5

Computers are usually predictible but now i'm disappointed.

EDIT:
sis v3.0.5 outputs: (image path not set)
uninstalled & deleted sis 3.0.5 & wanted to reupload the package but i couldn't & smf says please check directory permissions, is this the permissions bug ?
i'm facing this on what was the working test server.

Regards,
Vroum.

rostamiani

Thanks a lot
I installed the 313 version ,But it did not worked !!!

I see this error instead of MOD upload form :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@ariapedia.ir and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


I checked the error log of my Host and founf this error :

SoftException in Application.cpp:256: File "/home/*********/public_html/forum/sis/SISiframe.php" is writeable by group

I checked the permissions of "SISiframe.php" and that was 0666. But I couldn't change it because the owner of all of SIS files is "99"

What can I do ?
Thanks  :D

Rik©

June 01, 2010, 03:16:35 AM #732 Last Edit: June 01, 2010, 06:13:40 AM by Rik©
@vroum:
Quoteuninstalled & deleted sis 3.0.5 & wanted to reupload the package but i couldn't & smf says please check directory permissions, is this the permissions bug ?
No (if you refer to the 'SIS permissions' error).
Does the error you get from SMF look like this?
QuoteYou cannot download or install new packages because the Packages directory or one of the files in it are not writable!
If so, try this...
- Create a /temp directory in the /Packages folder (./Packages/temp), using FTP or your Server's File Manager.
- chmod both the Packages and temp directories to 0777 and attempt to install the package.



@rostamiani:
The files are owned by the server.
So you can't do anything with them using ftp (delete, rename, chmod etc.).

Here's a tutorial how to change the owner and fix it yourself with cPanel...
Quote from: http://www.dialme.com/m/articles/view/Reset-or-Restore-Files-Owned-99-By-The-Server
To reset and change the 99'd file back to owner (your-account) using cpanel:

-First download the file to your local pc with your ftp client.

-Then login to your host "cpanel" and navigate to the file manager. In cpanel 11 you will find both "file Manager" and "Legacy File Manager". You can use either one. I prefer the Legacy File Manger because it is faster and doesn't mess up, freeze, or time out like the other one does sometimes.

-So click on Legacy File Manger.

-Go button in the pop-up.

-Navigate to the location where the file you just downloaded with your ftp client was. Then click on upload.

-Simply re-upload over-writing it back to the original location using cpanel's file manager. Be sure to check "overwrite existing files".
Now refresh your ftp client screen and the file should change from 99 to the name of your account in the owner/group column.

That's it.
Now you must be able to chmod the folder/files to 755 with ftp.

You can also ask your host to change the owner of the file for you.

-Rik©

vroum

Quote from: Rik© on June 01, 2010, 03:16:35 AMDoes the error you get from SMF look like this?

No, and now it vanished just as it came  ???

One more thing, you should change your code because it is displaying critical information ( I think it's the "or die" that is responsible for this) check this out:
Database Error: MySQL server has gone away
File: /home/my-username/public_html/Forum/Sources/Load.php
Line: 2020


This was in lower left corner of your mod v3.0.5 after a "504 Gateway Time-out The server didn't respond in time." error...my ftp user name was displayed to the world to see  :o

Thanks !
Vroum.

tbk22

June 01, 2010, 02:06:02 PM #734 Last Edit: June 01, 2010, 02:15:22 PM by tbk22
I get this

QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@silkroadportugal.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

When trying to use it on posts... How can I fix it?

And I dont have any sis directory on my FTP server... is that normal?
=)

vroum

June 01, 2010, 04:36:21 PM #735 Last Edit: June 01, 2010, 08:12:09 PM by vroum
SIS3.0.5 restarted working the same way it stopped, with no apparent reason on what was the working server  ???

EDIT: output of my non working server : Wrong file type detected for file 44lsg01.gif:application/octet-stream

Thanks !
Vroum.

amcapt89

Quote from: Rik© on May 30, 2010, 02:32:22 AM

@amcapt89:
Which cURL version do you have?

-Rik©


cURL is installed
curl version: 7.15.5

curl_init: Enabled
curl_setopt: Enabled
curl_exec: Enabled
curl_close: Enabled

I hope that helped!

amcapt89

PS: for me it's still working fine!

PPS: I wil be happy to do a translation in Italian if you want!

tbk22

Welll this mode is not installing properly at all...

At first I was having Internal server Error and I checked and there was no Sis directory in the FTP (public_html)

Now 2 days later there is a Sis directory but I had to make these changes http://www.simplemachines.org/community/index.php?topic=37683.msg2622689;topicseen#msg2622689 to the code for it to work...

Now it works but languages didn't install properly, in particular Portuguese_utf8 language, so I still have the mode in english




I am now using it and seems great thanks, but an official fix to some of these install errors would be even better
=)

Rik©

The sis folder is located in the SMF folder (where you installed SMF).

The fix you had to make only works with cURL 7.20.0, it will be added to the next release.

Could you be more precise about the languages?
Only English and Dutch are 100% supported (front-end and ACP).

-Rik©

tbk22

Portuguese language is not working , it didnt install properly and I think I already know why


I searched the code  and I only found the language with the "format" portuguese-utf8 but according to smf language pack it should be portuguese_pt-utf8

And If you need any help to translate any other part of the mod to portuguese just tell me
=)

Advertisement: