• Welcome to Simple Machines Community Forum. Please login or sign up.
January 20, 2022, 03:50:15 PM

News:

Follow SMF on Twitter.


SMF 1.0.4 released

Started by Grudge, June 05, 2005, 09:34:16 AM

Previous topic - Next topic

xtremecruiser

How about a list of Mods that are ok or not ok for the Update.
I have updated for the last year and never had any issues with mods ( and I Like Mods )
This upgrade makes me uneasy.

[Unknown]

Quote from: bloodlust on June 07, 2005, 09:13:22 PM
I upgraded like I always do.  Downloaded the 'smf_1-0-4_update.zip', uploaded the unpacked files to my webserver, and ran upgrade.php

That way removes *all* of your installled mods.  You'll need to fix your theme files now, or reinstall the mod.

DDT, try uninstalling it, uninstalling Spam-me-not, reinstalling it, and then trying to install Spam-me-not again.

Mods that are not okay:
Faster Parsecode
Spam-me-not
Any mod that adds custom bbc (possibly okay, possibly not.)

Mods that are okay:
Everything else.

-[Unknown]

apnakohat

I m upgrading form 1.03 hope it will work fine... :D

ShawnX

I got it fixed!!

Good thing I'm a digital packrat lol.

I fixed it by downgrading to 1.0.3

I was able to do this because I moved my forums from my home webserver to a hosted webserver a few weeks ago.  Well I never deleted the old forum on my web server. 

I just uploaded everything from my home webserver overwritting the files on my hosted server. Ran 'repair_settings.php' and it works like a charm!

I'll try upgrading to 1.0.4 again after uninstalling all my mods.

DDT

Big Problem
No "Uninstaller" for Spam-me-not so all I could do is delete all the files, restore a 1.03 from backup, then try the upgrade again. Same results. I have no idea how to get rid of Spam-Me-Not, it had a file labeled uninstaller but when tried through unuinstall packages it gave message no uninstaller for this mod...
Any ideas what to try now?

Ashly

Updated!

Went through without a hitch!

~ Ashly

dtm.exe

Quote from: Ashly on June 07, 2005, 10:22:28 PM
Updated!

Went through without a hitch!

Glad to hear it :).

-Dan The Man

pure



Yes, I ran into some permissions problems - do all directories need to be writable?

Quote

same for me i would like to know which need to be writable so i can chmod them?
thanks

DDT

Noticed that the author of Spam Me Not hasn't been on the forums since March so if anybody has any ideas on how to cleanly remove it I would really appreciate it.

Kindred

damn.....   I installed this cleanly on two forums... the third has the [ img] problem though...   DO we have any idea what's causing that problem?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

[Unknown]

How do I use chmod?
Why chmod 777 is NOT a security risk

If in doubt, Sources and the main directory of the forum.

Quote from: DDT on June 07, 2005, 11:07:13 PM
Noticed that the author of Spam Me Not hasn't been on the forums since March so if anybody has any ideas on how to cleanly remove it I would really appreciate it.

You can upload all of the files from the "upgrade" zip file, and then reinstall your old mods.

Quote from: Kindred on June 07, 2005, 11:08:44 PM
damn.....   I installed this cleanly on two forums... the third has the [ img] problem though...   DO we have any idea what's causing that problem?

What mods?

-[Unknown]

Kindred

a bunch...  none of which SHOULD have affected the upgrade...   except for spam-me-not...   and I worked around that in the other forums too...
(one line, the email change in subs.php is the spam-me-not failure. The upgrade works if you have everything except for that one line changed.)

Quote
  Mod Name Version   
1. Visual Warning / Post Moderation 1.21   [ Uninstall ] [ List Files ] [ Delete ] 
2. The Bar Of Experience 1.1   [ Uninstall ] [ List Files ] [ Delete ] 
3. Buddy List 1.21   [ Uninstall ] [ List Files ] [ Delete ] 
4. Gender Specific Membergroups 1.2   [ Uninstall ] [ List Files ] [ Delete ] 
5. Report PM to Administrator 0.2   [ Uninstall ] [ List Files ] [ Delete ] 
6. Enhanced Quick Reply 1.0   [ Uninstall ] [ List Files ] [ Delete ] 
7. Member Specific Permissions 1.3   [ Uninstall ] [ List Files ] [ Delete ] 
8. G&S_Sticky 1.0   [ Uninstall ] [ List Files ] [ Delete ] 
9. Topic Ratings 1.02   [ Uninstall ] [ List Files ] [ Delete ] 
10. Manage Holidays MOD 1.02   [ Uninstall ] [ List Files ] [ Delete ] 
11. Unreplied Topics 1.02   [ Uninstall ] [ List Files ] [ Delete ] 
12. Pie Chart Mod 1.2   [ Uninstall ] [ List Files ] [ Delete ] 
13. SMFShop 1.0  [ List Files ] [ Delete ] 
14. SMF 1.0.2 Update Package 1.0.2b   [ List Files ] [ Delete ] 
15. Jack's Phat Calendar Pack 1.0   [ Uninstall ] [ List Files ] [ Delete ] 
16. Ultimate Shoutbox 1.22   [ Uninstall ] [ List Files ] [ Delete ] 
17. SMF 1.0.3 Update Package 1.0.3   [ List Files ] [ Delete ] 
18. Location Mod 1.1.1   [ List Files ] [ Delete ] 
19. Location Mod - Additional Maps 1.1.1   [ List Files ] [ Delete ] 
20. Location Mod - Who Flags 1.1.1   [ List Files ] [ Delete ] 
21. Hide Tag 1.0   [ Uninstall ] [ List Files ] [ Delete ] 
22. SMF Arcade 1.1.3   [ Uninstall ] [ List Files ] [ Delete ] 
23. Integrated Chat 2.3   [ Uninstall ] [ List Files ] [ Delete ] 
24. Spam-me-not 1.0.1   [ List Files ] [ Delete ] 
25. Characters Remaining 1.2   [ Uninstall ] [ List Files ] [ Delete ] 
26. SMFShop 1.1   [ List Files ] [ Delete ] 
27. SMF 1.0.4 Update Package 1.0.4   [ List Files ] [ Delete ] 


I'm not exactly sure which line was causing the problem...  but I went through subs.php by hand and confirmed all the code changes in that file by repasting the code that needed to be in there... (except for the spam-me-not line, which I left as is)

This appears to have fixed the [ img] problem...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

[Unknown]

Spam-me-not has been identified as causing problems.

-[Unknown]

Kindred

yeah... unfortunately, Spam-me-not does not uninstall easily...

but I have the spam-me-not line in subs.php unchanged and the forum now works properly... so I am assuming that at leats one other piece of code failed to install correctly....  probably the bit that moved the [img ] call up to the top of the function rather than after the quote section...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

groovie

June 07, 2005, 11:49:53 PM #74 Last Edit: June 08, 2005, 08:40:55 AM by groovie
hello,

well i've JUST got:

- smf bridged to mambo
- coppermine gallery bridged to smf

so i'm a bit nervous about doing the upgrade. 

are there any foreseeable problems when upgrading in these circumstances?

the only smf mod i am using is the login mod i guess.

any responses appreciated, thanks :)


edit: to make things easier to follow groovie's probs are now in the bridge area here - http://www.simplemachines.org/community/index.php?topic=38154.msg279041#msg279041

[Unknown]

This should not affect the bridge in any way...

-[Unknown]

Kindred

the smf-mambo bridge does not modify anything that is checked/updated in this upgrade.

As alwasy... backup your site...  but there should be no trouble at all doing this...
(although you may want to drop out of the bridge into the forum alone to do the updgrade, since mambo still has some issues with directory and file permissions)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

DDT

Quote from: Kindred on June 07, 2005, 11:31:08 PM
yeah... unfortunately, Spam-me-not does not uninstall easily...

but I have the spam-me-not line in subs.php unchanged and the forum now works properly... so I am assuming that at leats one other piece of code failed to install correctly....  probably the bit that moved the [img ] call up to the top of the function rather than after the quote section...

Sorry to be so dumb but there are several subs files and I've looked until I'm cross-eyed. Can you narrow down where to find that line a little bit.
If I understand you I can save it, upgrade, find the changed line and replace with the original, and all will work?
Thanks for the help...I need it...4+ hours & counting.

pure

both the forum dir and sources are 777 but i still get "Some of the files this package needs to modify are not writable. This needs to be changed by logging into FTP and chmoding the files."

[Unknown]

Are the actual files it needs to modify also 777?

It should list them all for you.

-[Unknown]

Advertisement: