• Welcome to Simple Machines Community Forum. Please login or sign up.
January 20, 2022, 12:48:15 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


SMF 1.0.4 released

Started by Grudge, June 05, 2005, 09:34:16 AM

Previous topic - Next topic

Kindred

spam me not changes one line in subs.php

(nothing else...  just plain subs.php)

verify that the modifications were actually applied as described in the .mod file by hand to subs.php


Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

DDT

Now I'm really confused. So I should make sure the subs.php is the new file from the upgrade & that will solve the problem, or do I have to upgrade then replace the one line you are talking about that spam me not modifies?
If the first is the case I can handle that by just uploading that file manually with overwrite after running the upgrade from package manager I guess.
But if I need to change 1 line there are only about 10 thousand in there, could you point me close to the one that needs changing? :-X

pure

June 08, 2005, 12:28:30 AM #82 Last Edit: June 08, 2005, 12:35:17 AM by pure
manually changing listed files to 777 had mixed success

got some error statements but the admin center displays version 1.0.4 now

2: /Themes/default/Admin.template.php~): failed to open stream: Permission denied
File: /Sources/Subs-Package.php
Line: 1307

Kindred

DDT...  no, you misunderstood...

If you have NO other mods installed that edit subs.php, that emthod may work for you...

However, if you do have other mods that hace modified subs.php what you do is this:

Apply the patch in the package manager.
ignore the failure notice for subs.php.
then list the files in the package and view the .mod file.
find the section for subs.php
go through and verify that each of the lines (with the exception of the spam-me-not line) was changed according to the patch information.

this is not for the impatient...   if you don't know what I'm talking about now, I would say download the full upgrade pack, apply it (losing any mods) and then re-apply any mods that you want.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

[Unknown]

Quote from: pure on June 08, 2005, 12:28:30 AM
manually changing listed files to 777 had mixed success

got some error statements but the admin center displays version 1.0.4 now

2: /Themes/default/Admin.template.php~): failed to open stream: Permission denied
File: /Sources/Subs-Package.php
Line: 1307

This error means the package manager is trying to create the file named, and it can't because Themes/default is not writable.

-[Unknown]

pure

i think its just a backup file it wants to create so i wont sweat it...thanks

DDT

June 08, 2005, 12:49:11 AM #86 Last Edit: June 08, 2005, 12:52:43 AM by DDT
Quote from: Kindred on June 08, 2005, 12:29:08 AM
this is not for the impatient...   if you don't know what I'm talking about now, I would say download the full upgrade pack, apply it (losing any mods) and then re-apply any mods that you want.
Thank you, I do this for free for a friend with a very active forum but no clue and I'm no PHP "coder" or "guru" as you obviously are. He has lots of mods that are simple (like the map and banner manager) that would require hundreds of users to re-pin their locations and him get me to re-do his banners. It could be done but the locations & maps would be useless, all those people won't do that again.
I didn't think it was being "impatient" to ask for a clue like "about 2/3 of the way down after the lines that say..." or whatever but because you can sort through all that PHP and it makes sense I'm unworthy of doing anything except spending hours looking and still probably not finding one line, the whole time my friends forum has lost all it's images. Since I am 100% disabled and can only stay at a keyboard at the most an hour at a time without lying down a while and since my only income is from that precious few minutes at the keyboard I really can't afford that many hours trying to help a friend even though he's a good friend.
Sorry if I insulted your skill level by seeming impatient and asking for some help. Usually here people are glad to help when they can.

If anybody can just figure out how to get rid of spam me not that would be great. Then I guess I could upgrade as normal.
If I had known it would be this much trouble I would have never installed it. His users don't understand "harvesting" programs so I thought I was doing them a favor when I installed it.

Kindred

DDT...   didn't mean I thought you were impatient...  I meant that applying the patch package in this way needs to be done carefully and can not be rushed through...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

forumite

DDT

The Spam-me-not package comes with an uninstall file. Have you tried uninstalling it through the Package Manager? If it won't uninstall, either look at the Uninstall-Spam-me-not.xml file in a text editor and make the changes manually, or look at the Install-Spam-me-not.xml file and work backwards. You could also look at which files are being changed by the install file and merely replace them from your backup copies.

BTW to write this reply, I searched for spam me not, found the link to the package, downloaded the package and unzipped it to read the files. Took only a few minutes.

Kindred

the spam-me-not might comes with an uninstall xml...  but it does not process automatically in the package manager (there is no uninstall option. See my post above with the list of mods...)

I have to say, I hate SMF install/uninstall XMLs... they are very hard to read (much more so than .mod files)

I didn't read the uninstall.xml file too carefully, but, personally, I would read the INSTALL file and work backwards...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

DDT

The uninstall file doesn't work with newer versions of SMF. That was discussed by several others early on in the thread.
Perhaps after a few hours sleep I'll try to figure out what you are talking about (I don't have a backup from before spam me not) but I did find a few lines of code the other person was talking about somewhere close to halfway through the over 2,300 lines of code in that file. I have no idea what they mean but it's something to do with Spam me not.
Thanks for the ideas. The developers should put up a "dummies" forum for folks like me who aren't like you guys and used to coding PHP or backwards reading XML. Or just put big warnings on the download packages that cannot be uninstalled using the regular software so people like me would leave them alone.
I have probably recommended these forums to 30-50 people since I installed his and just sent a guy an e-mail this morning about how easy he could do a forum site, probably by himself,  using SMF because the support community and developers were so great. I guess my previous "one click" upgrades and the easy answers people here had provided left me expecting too much.
Maybe while I sleep 3 or 4 hours somebody will find an easy fix to this mess.

Thanks for your efforts at help. After becoming disabled at 48 and losing my business of 20 years to bankers and lawyers (and being ineligible for ANY government benefits and broke) I had hoped to get some grant money to go to college and learn some of what you people know so I might make a few dollars but nobody will pay for the disabled to take courses on-line and the nearest college is almost an hour away (and I don't think they have much on computer stuff there)
...want some irony in your life, pay your taxes from 15-48 (33 years) then find an illegal immigrant can get money from the government but you can't and THEN find that they will help pay for the disabled get more education but only if they go to school like the healthy, not on-line...now how backwards is that?

[Unknown]

Why not just upload the Subs.php file from the upgrade package, after making a backup of the current one?

-[Unknown]

forumite

DDT

Sounds like you didn't back up any files before installing the mod. Everything I've read here says repeadly to back up your files before installing mods or packages. Even the Package Manager warns you of that. But, I've also learned the hard way and had to manually back out of something when I hadn't backed up my files.

I don't know who "you guys" are, but I haven't received any formal education or training in PHP, XML or HTML. I've tried to learn what I can by reading and doing. Sometimes I just learn by experimentation. There are numerous free tutorials online, including some very good ones here. Just search the forum or search using Google.

One word of advice I can give you - take note of what [Unknown] writes. [Unknown] is the guru around here and does an excellent job of explaining things in words that even I can understand. If you don't understand an answer, politely ask for a better explanation and be patient. As you see from the number of messages and questions, these folks are very busy trying to help everyone.

Sorry I wasn't of much help.

erockza

Sorry if i missed somthing in this thread, but could someone please list the files that are actually upgraded in this 1.0.4 package?

Thanks  ;)

Owdy

Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

ディン1031

Hi there,
could you please add the Version 1.0.4. in the mod part of this site :).
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

forumite

DDT

Here's the first in an easy-to-follow series of tutorials on PHP:

http://www.simplemachines.org/community/index.php?topic=1063.msg12454#msg12454

If you search this forum for "PHP lesson" you'll see the rest of the tutorials in this series.

Dannii

QuoteThe package manager currently allows only these file types: zip, tar.gz.

I'm wondering whats the point of having it to download if we can't install it as a .bz2
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Grudge

The files on the download page CANNOT be installed with the package manager. The package manager update is available through a message in the Package Manager on your current install. The files on the download page here need to be uploaded manually to your forum - so it doesn't matter which file type you download.
I'm only a half geek really...

groovie

June 08, 2005, 07:57:23 AM #99 Last Edit: June 08, 2005, 08:42:53 AM by groovie
Quote from: groovie on June 07, 2005, 11:49:53 PM
hello,

well i've JUST got:

- smf bridged to mambo
- coppermine gallery bridged to smf

so i'm a bit nervous about doing the upgrade. 

are there any foreseeable problems when upgrading in these circumstances?

the only smf mod i am using is the login mod i guess.

any responses appreciated, thanks :)


just tried to upgrade in the circumstances quoted above, using the package manager, and eventually ran into this error:

An Error Has Occurred!
2: fopen(/home/*****/public_html/forum/changelog.txt): failed to open stream: Permission denied
File: /home/*****/public_html/forum/Sources/Subs-Package.php
Line: 1476

um, help!

edit: to make things easier to follow groovie's probs are now in the bridge area here - http://www.simplemachines.org/community/index.php?topic=38154.msg279041#msg279041


Advertisement: