News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

nwswAdminAttachAnything

Started by nwsw, February 10, 2006, 08:51:36 AM

Previous topic - Next topic

nwsw

Link to Mod

This is a source code only modification. This mod does not make any changes to the database.

After applying this mod, Admins can attach anything to a post, regardless of file size or extension.

diegolyanky

Uhmmm  ???

I don´t understand what is the function of this mod.

Regards !  ;)
SMF ... SimpleMachines ... Simple, but complete if you want it ;)

nwsw


RBH

i installed this mod on 1.1rc2 and it will not let admins post attachments. under the post field it says 0k allowed for attachments. this only effects the admins. i uninstall the mod and it is back to normal allowing admins to attach same as normal users. is there a setting within the admin panel i needed to adjust or should it allow anything just being installed?

nwsw

An empty setting for attachmentSizeLimit is normal for Admins when this mod is installed. This is part of what enables admins to attach without size restriction.

Skipdawg

So like for a few other setting options in SMF it sets a 0 (zero) for unlimited? Am I understanding that correctly?
Very cool idea. I remember seeing it before but forgot about it.  ;)
Skipdawg's Community

Powered by SMF 1.1.3

RBH

thanks for the reply. i dont have a problem with it listing a 0 for allowed attachments, but my problem is that i try and attach something and it says i cannot. once i removed this mod i was able to attach again.

nwsw

You haven't given any details on the error, so I can only guess as to your problem. Perhaps you have a mod, integration, or template that does not handle the attachmentPostLimit, attachmentCheckExtensions, and attachmentSizeLimit settings in the same manner as standard 1.1 RC2/3.

JohnnyMcKinney

Ok here is my error

"Your attachment couldn't be saved. This might happen because it took too long to upload or the file is bigger than the server will allow.

Please consult your server administrator for more information."

Its really getting me mad cause I would love this mod. If it worked....

NEMINI

Quote from: JohnnyMcKinney on February 12, 2007, 05:55:59 AM

"Your attachment couldn't be saved. This might happen because it took too long to upload or the file is bigger than the server will allow.


see the bolded part of your error above.
signatures are boring.

JohnnyMcKinney

That doesn't make since, it's a simple audio file. It's only 4 megabytes. I have the maximum file and maximum folder set to 2739938 and the attachments size is 1 megabyte so that the users can only post that much. I've uploaded bigger files to my server....

nwsw

As hinted by NEMINI, this mod only deals with SMF attachment limitations. You are still limited by PHP constraints on file upload size and CPU utilization (and possibly other server imposed limits).

See also:

PHP: Handling file uploads - Manual
http://www.php.net/features.file-upload

JohnnyMcKinney

Well can you tell me how to make it so that the files can be bigger? Cause if I change the Max size per attachment: to a higher number then I can actually upload the sound file I wanted to upload.

JohnnyMcKinney

No I figured out the problem. many people should enjoy this mod A LOT MORE NOW THAT IT WORKS. Thank god I love this mod. Ok I found the problem

Open your source/Load.php in some type of file editor and find this line

$modSettings['attachmentSizeLimit'] = [color=red]0[/red];

Now you see the red number^^? Zero right? Yea thats why. LOL when you go to post it says zero it doesn't mean unlimited. Thats why when you remove this mod you can post huge attachments again. Anyway. Change that number to the MAXIMUM you want your admins to be able to upload.

Now change this setting as high as possible

"Max attachment folder space:"

This is so that the attachment folder can hold a REALLY huge amount

Now change these settings to the users settings.

"Max attachment size per post:"
"Max size per attachment:"

Say you are aloud to upload 4 files at 1 megabyte each. Then make the "Max attachment size per post:" 4 megabytes cause you are only aloud to upload 4 files at 1 megabyte. I would put it a little bit higher cause the server may allow a little more amount to the users. So about 5 MB for this setting. Now set "Max size per attachment:" to w/e you want your users uploading per attachment.

YAY hope you enjoy :D

ApplianceJunk

This mod works great for me and all I did was download it and install.

I was worried about having to make the changes as stated in the above post, but I did not have to make any changes.

Under my attachment box is now say's.

QuoteMaximum attachment size allowed: 0 KB, per post: 6

I can attach large .mov file and everthing now, awesome!

Thank you,

pothead

this crashed my site and now i have no forum...
i dont understand how this could have done this..

DeMar

How is it when I have custom theme and language?

[embed-flash(width,height)]

rumfa

I have 1.1.4 and stiil get an error that the I exceeded the time etc...

Jade Elizabeth

Is there anything comparable to this for 2.0?
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Advertisement: