• Welcome to Simple Machines Community Forum. Please login or sign up.

Грешка при парсирању модификације (pomoc, sledi nagrada :)

Started by Zurka, May 03, 2010, 02:53:49 PM

Previous topic - Next topic

Zurka

Morao sam ponovo da instaliram nov forum, javlja mi se greska prilikom instalacije bilo kog moda, Грешка при парсирању модификације...

Probao sam da:

1.Ceo folder Packages chmod-ujem na 777 kao i sve fajlove u nutra...

2. Da napravim novi folder temp i njega stavim na 777...

3. Da prepakujem Rar fajlove u TaR....

Probao sam jos 1000 stvari ali nista od ovoga nije uspelo....

Prilikom downloada modova sve prodje ok, ali kad treba da se raspakuju za svaki se javlja ta greska.

Pa evo dok ja rucno instaliram sve modove, a smorio sam se  :),  ako neko ima resenje ili ideju sta bi moglo da bude, dobice Rapidshare premium nalog od mene.




Cola-Coca

Dali mi mozes prevest cirilicu na latinicu (mislim na gresku koju ti izbacuje) ?
I LOVE SMF

Zurka

Quote from: steven80 on May 03, 2010, 08:01:48 PM
Dali mi mozes prevest cirilicu na latinicu (mislim na gresku koju ti izbacuje) ?

Greska pri parsiranju modifikacije

Modification parse error

Dzonny

Quote from: steven80 on May 03, 2010, 08:01:48 PM
Dali mi mozes prevest cirilicu na latinicu (mislim na gresku koju ti izbacuje) ?
"Greška pri parsiranju modifikacije"

@Zurka - Jesi li možda nešto menjao u kodu smfa pre nego si primetio ovu grešku? Jesi li možda selio forum na drugi host ili server? Imaš li nešto u error logu? Koja je verzija smfa?

Zurka

Quote from: Dzonny on May 04, 2010, 07:00:33 AM
Quote from: steven80 on May 03, 2010, 08:01:48 PM
Dali mi mozes prevest cirilicu na latinicu (mislim na gresku koju ti izbacuje) ?
"Greška pri parsiranju modifikacije"

@Zurka - Jesi li možda nešto menjao u kodu smfa pre nego si primetio ovu grešku? Jesi li možda selio forum na drugi host ili server? Imaš li nešto u error logu? Koja je verzija smfa?

U kodu nista nisam menjao i gresku sam primetio , instalirao sam sve nove fajlove samo sam bazu uvezao staru. Nemam nista u error logu. Verzija 1.1.11...

Dzonny

Ok. Direktorijumu "Packages" kao i "backups" unutar njega, stavi dozvole 755 (ili probaj 777).
Upoaduj nove fajlove .htaccess i index.php u direktorijum Packages.
Koju temu koristiš?
Uploaduj nov fajl Packages.template.php u dir Themes/default/ (i Themes/tvoja_tema/ ako fajl postoji po defaultu uzmi ga iz instalacionog paketa teme)
Uploaduj nov fajl PackageGet.php i Packages.php u fodler Sources.
Javi rezultate.

Masterd

Stavi packages na 777 i unatar njega kreiraj folder "temp", također na 777. To bi trebalo pomoći.

manix

proveri da li ti je dobra putanja za upload modova ako si vec importovao neku drugu bazu ...
mozda je putanja ka nekom nepostojecem folderu pa ti nista ne vredi sto si za te stavio chmod 777

Zurka

@Dzonny
Koristim Default Modern temu.
Probao sam sve to i sad pise You cannot download or install new packages because the Packages directory or one of the files in it are not writable! Probao sam i sve na 777 i folder ali i fajl po fajl, nesto ftp zeza izgleda.


@Masterd
To sam vec probao napisao sam gore, citaj malo  :)

@manix
Putanja je je dobra, upload lepo radi, al instalacija nece.

manix

pa palo mi je na pamet nesto drugo, ako to sve radi... proveri u modu koji se fajlovi modifikuju jer verovatno je neki od njih 'zatvoren' za pisanje... Tebi je folder za upload modova ok ali nece da se izvrsi nesto u procesu modifikacije pa mi je nekako logicno da je u pitanju neki od fajlova koje taj mod menja...

Masterd

QuoteYou cannot download or install new packages because the Packages directory or one of the files in it are not writable! Probao sam i sve na 777 i folder ali i fajl po fajl, nesto ftp zeza izgleda.

Imao sam točno taj problem i pomoglo mi je ono što sam napisao prije.

Dzonny

Quote from: manix on May 04, 2010, 11:34:59 AM
pa palo mi je na pamet nesto drugo, ako to sve radi... proveri u modu koji se fajlovi modifikuju jer verovatno je neki od njih 'zatvoren' za pisanje... Tebi je folder za upload modova ok ali nece da se izvrsi nesto u procesu modifikacije pa mi je nekako logicno da je u pitanju neki od fajlova koje taj mod menja...
+1
I pogledaj da li ti se modovi nalaze u Packages direktorijumu, u zip ili rar formatu.

Zurka

Sad nece ni upload modova, probao sam preko ftp-da ubacim modove u packages ali se i dalje nece instalirati. Stavio sam opciju otvori sve datoteke za pisanje i nece, nece i nece...
Nemam vise ideje stvarno , sve samo zivo probao...

manix


Dzonny

I dalje nemaš ništa u error logu?
Ako prebaciš na default temu da li i dalje ne možeš da instliraš ni jedan mod?

Zurka

i dalje nista , evo sad sam probao da prebacim na default temu i opet isto, kad sam napravio folder temp u Packages i dodelio mu 777 onda kad probam da instaliram modove sve ok prodje ali mod se ne instalira i kad probam deinstalaciju tog moda onda javlja greske. Nemam vise ideja. Vervovatno putanja za ftp nesto zeza.

Dzonny

Proveri za svaki slučaj putanje.
Najbolje da preuzmeš repair_settings.php i pokreneš ga da vidiš da li tu možda ima nešto što se može popraviti, i da li ti preporučuje nešto drugačije od trenutnih postavki.

Bob Marley

Mozes i da napravis (npr) info.php sa sledecim kodom

<?
     phpinfo();
?>


Pa upload na host i pokreni ga, pa proveri putanje.


Zurka

Quote from: Dzonny on May 05, 2010, 10:21:34 AM
Proveri za svaki slučaj putanje.
Najbolje da preuzmeš repair_settings.php i pokreneš ga da vidiš da li tu možda ima nešto što se može popraviti, i da li ti preporučuje nešto drugačije od trenutnih postavki.

Ma to sam odmah uradio, sve putanje su u ok...

Dzonny

U tom slučaju, obrati se hosti putaj da nisu oni slučajno nešto radili na serveru što bi moglo da uzrokuje ovaj problem.
Pogledaj:
http://www.simplemachines.org/community/index.php?topic=28393.0

Bob Marley

Koristis li neki localhost? :D tj. Virtuelni server na svojoj masini? Ako da digni svoj forum i bazu i probaj u lokalu da instaliras modifikaciju, ako radi onda je definitivno problem do hostinga :)

Zurka

Quote from: Bob Marley on May 06, 2010, 12:38:59 PM
Koristis li neki localhost? :D tj. Virtuelni server na svojoj masini? Ako da digni svoj forum i bazu i probaj u lokalu da instaliras modifikaciju, ako radi onda je definitivno problem do hostinga :)

Pa normalno da bi radilo  :)

Jel ima jo neko neku bolju ideju ???

HuanPablo

Resenje za tvoj problem se sastoji u  ISKLJUCIVANJU SAFE MOD-a

Dakle,treba da SAFE MOD podesis na OFF

Nazovi tvog host provajdera i reci mu da iskljuci safe mod.

Tada vise neces dobijati greske pri parsiranju

Bob Marley

Quote from: Zurka on May 21, 2010, 07:59:29 AM
Quote from: Bob Marley on May 06, 2010, 12:38:59 PM
Koristis li neki localhost? :D tj. Virtuelni server na svojoj masini? Ako da digni svoj forum i bazu i probaj u lokalu da instaliras modifikaciju, ako radi onda je definitivno problem do hostinga :)

Pa normalno da bi radilo  :)

Jel ima jo neko neku bolju ideju ???

Pa mozgu ako znas da je problem do hosta, zasto ga sa hostom i ne resis? :D lol


Zurka

Quote from: Bob Marley on May 21, 2010, 06:52:25 PM
Quote from: Zurka on May 21, 2010, 07:59:29 AM
Quote from: Bob Marley on May 06, 2010, 12:38:59 PM
Koristis li neki localhost? :D tj. Virtuelni server na svojoj masini? Ako da digni svoj forum i bazu i probaj u lokalu da instaliras modifikaciju, ako radi onda je definitivno problem do hostinga :)

Pa normalno da bi radilo  :)

Jel ima jo neko neku bolju ideju ???

Pa mozgu ako znas da je problem do hosta, zasto ga sa hostom i ne resis? :D lol

Zbog sira i vojne muzike, genije.. Nemam besplatnu tehnicku podrsku.

rocknroller

nisam uopće gledao temu ispred, zato što se nisi potrudio napisati naslov tako da ga može pročitati i tko ne zna ćirilicu.

Vidim ovaj tvoj zadnji post i vidim onaj dio gdje si voljan platiti za pomoć i nije mi jasno ko tu koga?

Nemaš besplatnu teh. podršku, plati njima za pomoć ako si već to htio.

Zurka

Quote from: HuanPablo on May 21, 2010, 02:58:15 PM
Resenje za tvoj problem se sastoji u  ISKLJUCIVANJU SAFE MOD-a

Dakle,treba da SAFE MOD podesis na OFF

Nazovi tvog host provajdera i reci mu da iskljuci safe mod.

Tada vise neces dobijati greske pri parsiranju
Hvala puno za ovo.
Iskljucio sam tom, i ne dobijam vise Грешка при парсирању модификације, ali i dalje onaj isti problem oko direktorijuma koji nije otvoren za pisanje.

Bob Marley

Nemoj pogresno da shvatis ono sto sam gore napisao, ali cinjenica da ako sve u lokalu radi ok a na serveru ne ukazuje na prostu stvar da je problem da hostinga... Sto mu dodje da verovatno ti tu nista ne mozes sam da uradis, vec oni. I otkud to da se tehnicka podrska placa zasebno?

Zurka

Resio sam problem, nema nista dok sam ne zagrejes fotelju i dok ti oci ne ispadnu...

Hvala svima na savetima.

Cola-Coca

Quote from: Zurka on July 22, 2010, 09:34:52 AM
Resio sam problem, nema nista dok sam ne zagrejes fotelju i dok ti oci ne ispadnu...

Hvala svima na savetima.

Odlicno , bas mi je drago da si rjesio nakon toliko vremena problem samo ako bi mogao ovde ostavit kako si ga rjesio jer u buduce ako se netko nadje s istim ili slicnim problemom pa da moze nac i odgovor.

Pozzz  :)
I LOVE SMF



Advertisement: