Advertisement:

Author Topic: SMF tutorials: How to setup a localhost for testing  (Read 40318 times)

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: SMF tutorials: How to setup a localhost for testing
« Reply #40 on: October 10, 2010, 03:09:15 PM »
Well, dropping tables that are part of the installation wouldn't be a good idea now, would it?

Did you try clearing your cache after truncating the ban tables?
"Insanity: doing the same thing over and over again and expecting different results."

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: SMF tutorials: How to setup a localhost for testing
« Reply #41 on: October 10, 2010, 03:19:10 PM »
I just figured I'd give it a test to see if it would work LOL. But nothing.

I did clear everything with ATFcleaner and nope, still says "sorry guest you are banned" if I try to login with my info says the same thing...

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: SMF tutorials: How to setup a localhost for testing
« Reply #42 on: October 10, 2010, 03:22:49 PM »
Odd.. Can you see what's logged in the smf_log_bans table? Just sort by id from high to low.
"Insanity: doing the same thing over and over again and expecting different results."

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: SMF tutorials: How to setup a localhost for testing
« Reply #43 on: October 10, 2010, 03:31:16 PM »
This is what I see in that table



Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: SMF tutorials: How to setup a localhost for testing
« Reply #44 on: October 10, 2010, 03:32:57 PM »
Click browse to see the content. This is the structure ;)
"Insanity: doing the same thing over and over again and expecting different results."

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: SMF tutorials: How to setup a localhost for testing
« Reply #45 on: October 10, 2010, 03:35:12 PM »
Hahaha, oopsy. Nope, if I try to click on that I get an X and can't see it

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: SMF tutorials: How to setup a localhost for testing
« Reply #46 on: October 10, 2010, 03:40:09 PM »
So, you see a message you're banned, yet no trigger is logged?

Can you see the latest errors added to the smf_log_errors board?
"Insanity: doing the same thing over and over again and expecting different results."

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: SMF tutorials: How to setup a localhost for testing
« Reply #47 on: October 10, 2010, 03:48:11 PM »
Yup, I can see the latest. Just says the same thing, that "Sorry Guest, you are banned from using this forum!" and the localhost IP 127.0.0.1 and the session number

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: SMF tutorials: How to setup a localhost for testing
« Reply #48 on: October 10, 2010, 03:52:52 PM »
Hey, what's the table fc_bans doing? Anything in there perhaps?
"Insanity: doing the same thing over and over again and expecting different results."

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: SMF tutorials: How to setup a localhost for testing
« Reply #49 on: October 10, 2010, 04:10:33 PM »
Can't browse that one so I'm not sure. But that should just be flashchat

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: SMF tutorials: How to setup a localhost for testing
« Reply #50 on: October 10, 2010, 06:07:13 PM »
Ok, so, I went into my live site. Browsed the ban triggers. Someone had banned the IP of the localhost and it was a migrated ban from yrs ago when we used phpBB. So I unbanned it. Exported the database again, and imported it and reran repair_settings.php

Most of it seems to be fine, except some small template issues which I have no idea why they'd look different...for example, I have the random quote mod installed, and the background color for it is wrong. Also, the whole forum should be in a table, and its not...these are the #1 reasons I wanted to have a local forum so I could test how mods would look being that its in a table and some mods don't work well with it.

So, I need to figure these things out. I figured maybe it had something to do with the theme settings. So I went into the admin panel for that, and switched everything to the localhost (thought repair settings should have done that) but it still didn't fix it. 

I was going to attach two pics, but now there are no options to do that...so maybe its not allowed now...weird

EDIT: Ok, all fixed! I had to go into Themes & Settings and click on "attempt to reset" thank you SO much for sticking with me and helping me out! Much much appreciated
« Last Edit: October 10, 2010, 06:36:32 PM by Kat9119 »

Offline ɔɔɔɔɔɔuɥoɾ

  • SMF Hero
  • ******
  • Posts: 2,742
  • Gender: Male
  • Community Support Helper SMF forums ftw!
Re: SMF tutorials: How to setup a localhost for testing
« Reply #51 on: October 11, 2010, 01:23:33 PM »
I get here all late, but welldone :)
Now you can do all your testing :)

SMF 2.0 RC5

   
Webhost to New Webhost file transfer service, PM me - Fast transfers