News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Simple Audio Video Embedder

Started by SMFHacks.com Team, August 09, 2010, 10:42:47 PM

Previous topic - Next topic

vbgamer45

1. First time seen that one occur not sure what casues that.

2. You place it manually in the root of your forum then run it via browser.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

fullmetalgirl

1. i simply downloaded your zip file,
extracted it and placed the .php in the correct folder...
so guess im not doing anything wrong so im a bit curious wether anybody else seen it?

$mediaProCache = \'' . serialize($mediaProItems)  . '\';
?>';

// Write the cache to the file
$fp = fopen($boarddir . "/cache/mediaprocache.php", 'w');
if ($fp)
{
fwrite($fp, $data);
}

fclose($fp);

// Return the items in the array
return $mediaProItems;

}

function MediaProFetchRemoteData()
{

}

?>


i think here is the problem, 2 slashes are maybe the wrong way?? and { and } are those ok??
(though i don't know how to find line numbers,, so im guessing here.)

2. thnx, ill try that


青山 素子

On the first line, try changing \'' to '\'

Remove the second line.

Hopefully, that should sort it.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


fullmetalgirl

Quote from: 青山 素子 on December 12, 2010, 01:13:32 PM
On the first line, try changing \'' to '\'

Remove the second line.

Hopefully, that should sort it.

I sorted out the line 166 problem:
$mediaProCache = serialize($mediaProItems)  . '\';
?>';


This solves that problem... (simple removing the . \'' thats infront, doing what you suggested didnt work.)

but i can't sort out the line 181 problem:


} (this is line 181)

function MediaProFetchRemoteData()
{

}

?>


if i remove it, including function mediaprfetch etc...  i get another error..
saying theres an error in my source/subs.php line 2040

vbgamer45

The quotes are there for a reason to store the serialized data in the cache file without an error.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

fullmetalgirl

could you post how you think it could be fixed?
simply changing \'' in '\' is not enough...

deleting the } on line 181 resolves in an .source/subs error.

stevemci

There seems to be a problem with embedding clips from LiveLeak with version 1.0.9 and 1.0.10 of this mod. No matter what video url I try to embed from LiveLeak I get a video of guys skiing. It's always the same video. Youtube embedding works fine so it must be a problem with LiveLeak. Is there some way to resolve this problem?

Thanks!

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro


DaleM

Quote from: stevemci on December 14, 2010, 01:28:47 PM
There seems to be a problem with embedding clips from LiveLeak with version 1.0.9 and 1.0.10 of this mod. No matter what video url I try to embed from LiveLeak I get a video of guys skiing. It's always the same video. Youtube embedding works fine so it must be a problem with LiveLeak. Is there some way to resolve this problem?

It appears there is a hardcoded link in the embedcode for the LiveLeak entry:

This
embed src="http://www.liveleak.com/e/8ee_1281467692"

should be changed to this
embed src="http://www.liveleak.com/e/$1"

If you are comfortable with making a change in the database, you can edit the record for LiveLeak in the mediapro_sites table.

stevemci

I edited the record in the mediapro_sites table and now nothing's embedding at all when I post the url for the drunken midget video. Here's the code as it exists now in the mediapro_sites table:

<object width="450" height="370"><param name="movie" value="http://www.liveleak.com/e/$1"></param><param name="wmode" value="transparent"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.liveleak.com/e/$1" type="application/x-shockwave-flash" wmode="transparent" allowscriptaccess="always" width="450" height="370"></embed></object>

DaleM

Quote from: stevemci on December 14, 2010, 09:05:51 PM
I edited the record in the mediapro_sites table and now nothing's embedding at all when I post the url for the drunken midget video. Here's the code as it exists now in the mediapro_sites table:

<object width="450" height="370"><param name="movie" value="http://www.liveleak.com/e/$1"></param><param name="wmode" value="transparent"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.liveleak.com/e/$1" type="application/x-shockwave-flash" wmode="transparent" allowscriptaccess="always" width="450" height="370"></embed></object>

<object width="450" height="370"><param name="movie" value="http://www.liveleak.com/e/$1"></param><param name="wmode" value="transparent"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.liveleak.com/e/$1" type="application/x-shockwave-flash" wmode="transparent" allowscriptaccess="always" width="450" height="370"></embed></object>

That is mine, and it looks like we match character-for-character - and mine works. Under your forum directory, there should be a folder named cache, and in that folder a file named mediaprocache.php . Delete that file and try again.

stevemci


lordg

I cant get this to work :(

I have downloaded and installed the file, is there anything I am missing. I could not get Aeva to work either ?

Any help appreciated.

Thanks

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

david090366

I'm running a 1.1.12 forum and currently using the old youtube bbc mod. I would like to use this one because it adds a lot more sites, obviously. From what I read I could simply uninstall the old bbc mod and install this one and it should embed the videos that are already in posts ( the old mod used the video's links ), but, I'll wind up with unparsed bbc tags in the posts that way. Can anyone suggest a way to strip those tags out of the posts?

Arantor

No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

vbgamer45

Quote from: david090366 on December 18, 2010, 02:25:03 AM
I'm running a 1.1.12 forum and currently using the old youtube bbc mod. I would like to use this one because it adds a lot more sites, obviously. From what I read I could simply uninstall the old bbc mod and install this one and it should embed the videos that are already in posts ( the old mod used the video's links ), but, I'll wind up with unparsed bbc tags in the posts that way. Can anyone suggest a way to strip those tags out of the posts?
How does the youtube bbc look like I could write a script to remove it.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Arantor

Or you could spend a few minutes bothering to look yourself, seeing how it's on the mod site.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.


Advertisement: