• Welcome to Simple Machines Community Forum. Please login or sign up.
January 19, 2022, 06:00:51 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Problem sending mails after new server

Started by diablo3x.dk, September 16, 2010, 04:15:00 PM

Previous topic - Next topic

diablo3x.dk

September 16, 2010, 04:15:00 PM Last Edit: September 16, 2010, 04:35:47 PM by diablo3x.dk
Hi all,

Recently our site - www.diablo3x.dk - has been moved to a new server.
We just did a test on the mail system and realized that we are able to send newsletters from the admin area. However, the system does not send any activation mail to new members when they have registered on our site.

As of now we use PHP Standard for mail - but the issue seems to be the same when using SMTP settings.

We feel that we have looked for a solution everywhere. Any help is appreciated. Feel free to request any info required to solve this task.

RC3

Thanks!

Alex' Manson

admin == members == registration == immediate registration (if ticked untick if u want activation mails ) if theres something else and cant solve is put (IMMEDIATE) hope i helped.

diablo3x.dk

September 16, 2010, 04:26:55 PM #2 Last Edit: September 16, 2010, 04:59:28 PM by diablo3x.dk
You seem to have misunderstood the issue we are experiencing. I know how to activate/deactivate the 'registration by mail' setting. The problem is that the system does not send any mails to new users even when registration by mail is activated. This, obviously, results in no new members as long as they don't receive any activation mail.


diablo3x.dk


gbsothere

Since you are able to send newsletters, etc., but not activation emails, I suppose asking the following is useless, but I'll get that out of the way.   :)

Is the webmaster address in Admin===>Server Settings one that is associated with your domain or is it a Gmail account?  (If neither, who do you show for the email host?)

In Admin==> Registration==> Settings:

What is your "Method of registration employed for new members" set to and, below that, do you have "Send welcome email to new members" checked?

If so, do you know if your members are getting the welcome email, once their accounts are approved?
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

diablo3x.dk

September 17, 2010, 12:39:14 PM #5 Last Edit: September 17, 2010, 01:24:09 PM by diablo3x.dk
Hi there :)

As of now, users can register immediately since we have deactivated e-mail activation (because it doesn't work atm).
I just registered a test user to test if a welcome email was sent; no email received...

The webmaster address is the one associated with the domain, yes.

Thanks.


gbsothere

Quote from: diablo3x.dk on September 17, 2010, 12:39:14 PM
Hi there :)

As of now, users can register immediately since we have deactivated e-mail activation (because it doesn't work atm).
I just registered a test user to test if a welcome email was sent; no email received...

The webmaster address is the one associated with the domain, yes.

Thanks.



Are you getting any errors at all, either in the forum error logs or server logs?  It sounds as if this function worked correctly before changing servers, so I doubt if this requires a file edit, although it's possible that some mod is interfering with it. 

Still, I'll dig around here and see if I can find some similar issue.   :)

(Curious if emails show to still be in the queue?)  Admin==> Maintenance==> Mail
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

diablo3x.dk

Appreciated, gbsothere.

No mail in queue.

Also, user receive mail properly when they receive PM's. It seems to us that only registration mails are not sent.


gbsothere

Attached is a file to test with, diablo3x.dk

In the first line, replace 'username@domain.com' with your own email address (associated with your domain) but leave it in single quotes.  Upload it to your forum's root and point your browser to it. 

You'll get back three results, the first, a response to "does it get emailed?", the second, to "do we get the message?" and the third, any generated errors if sending mail failed.

If all three responses are "we sent the mail" then it would implicate your server, I believe.  If, however, you get errors, this may implicate some forum setting and will hopefully shed some light on where to begin looking.  You can remove it when you're done. 

If this has only begun happening once you changed hosts, I'm not really expecting any errors (and can't promise you I'd even understand them, if you get any) but someone else may.  It's worth a try.
:)
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

diablo3x.dk

Really appreciate your help. I will try this first thing tomorrow. Over midnight here :)

gbsothere

Quote from: diablo3x.dk on September 17, 2010, 06:25:23 PM
Really appreciate your help. I will try this first thing tomorrow. Over midnight here :)


Sure thing!   ;)
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

dunny

A long shot, when I installed SMF on a new server a couple of weeks ago, I had accidentally set the webmaster email address to an account that does not exist on the server.  Have you done the same?

Phil

diablo3x.dk

Quote from: Mail TestFirst Mail Results: We failed to send the email
Second Mail Results: We failed to send the email
Third Results: We failed to send the email
Now Check your inbox, spam or whereever for your mail

Dunny - Webmaster email address i correct.

gbsothere

Quote from: diablo3x.dk on September 18, 2010, 11:20:16 AM
Quote from: Mail TestFirst Mail Results: We failed to send the email
Second Mail Results: We failed to send the email
Third Results: We failed to send the email
Now Check your inbox, spam or whereever for your mail


Failed to send the email....

No mail in queue.....

And you're using the PHP setting...   *thinking*


When you try SMTP settings, are you filling in the information as it is shown in your CPanel (email settings) with username (sometimes, the username is the complete email address; that's different with different servers), password, port, etc.?  (I'm sure you are, but these questions must be asked.)

Also, I don't see where it was answered before:  any errors either in the forum error log on in your server logs that seem related?

And just clarifying again, for the benefit of anyone reading along, newsletters, etc., send.  This is any email generated from the registration section; activation and/or welcome.
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

diablo3x.dk

Hi gbsothere,

We will post in this topic later this day. We think we are on track of something. Just to let you know that we have not forgot ;)

diablo3x.dk

Hi gbsothere.

I figured it out. Finally. It was probably a mix of a php settings error and an SMTP settings error. I thought it was a pure php-error since I had no problem in sending mails from asp.net (and it could send mail from smf in some cases (I think it was where it didn't use the simple mail method)).

So now the test says:
First Mail Results: We sent the email
Second Mail Results: We sent the email
Third Results: We sent the email
Now Check your inbox, spam or whereever for your mail

In php.ini I set the following:
cgi.force_redirect=0
fastcgi.impersonate=1
fastcgi.logging=1
extension_dir="C:\Program Files (x86)\PHP\ext"

SMTP = localhost
smtp_port = 25
sendmail_from = admin@diablo3x.dk

and I set the date.timezone value as well.

In the IIS 6.0 Manager I set some properties on the SMTP Virtual Server. If you are interested in what the values are I can post them.

So basically the issue was a relay failure to the smtp server.

Thanks a lot for your support, led me in the right direction.

Advertisement: