Advertisement:

Author Topic: Can't install/uninstall packages  (Read 7159 times)

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Can't install/uninstall packages
« on: October 31, 2010, 03:20:15 AM »
Everytime when I try to uninstall a package, just after I click "uninstall now", SMF loads a blank screen ( only changes the URL with uninstall2: ...action=admin;area=packages;sa=uninstall2;package=...), then if I refresh it it happens again. And if I click enter on the url box, I get "Your session timed out while posting. Please go back and try again."

Any ideas?

Thanks in advance

Edit: I just discovered I can't install packages either, same problem as for uninstalling

EDIT2:
Solved. If you get this error (just a blank page with nothing after the (un)install now click), check the backups folder inside Packages folder, since you may have (like me) like 200MB of them. Just make some space and it'll be fine.

tl;dr This problem is because of not having enough space for the next backup. Just make some space in your account.


PS:
Thank you very very much to mrtarkhan and k@ for all of their help n.n!
« Last Edit: November 02, 2010, 12:50:32 AM by kirbyiwaki »

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't uninstall packages
« Reply #1 on: October 31, 2010, 05:47:15 AM »
check the uninstall file, maybe it not exist in your package folder.

if you have a problem with that, you can uninstall it by own.

or you can change the url with this :

action=admin;area=packages;sa=uninstall;package=...), and remove 2.
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't uninstall packages
« Reply #2 on: October 31, 2010, 01:11:24 PM »
It happens with all packages. So it's not the package. Without the 2, it just reloads the pre-uninstall page.

By the way, everything passes the uninstall test, too.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #3 on: October 31, 2010, 04:11:51 PM »
change your theme to default.

if you have this problem again, replace a your package.php file (Sources folder) with new one.
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #4 on: October 31, 2010, 04:23:05 PM »
I have the default theme... tried replacing packages.php with the fresh one (it was the same size) and it didn't work either.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #5 on: October 31, 2010, 04:32:31 PM »
Maintenance => Database => Optimize all tables

it is a good choice when you have a problem like this.

and see this too :

log

your last package and your version ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #6 on: October 31, 2010, 04:33:20 PM »
Just curious...

Inside your "Packages" directory, do you have another, named "tmp"?

If not, try making one and make sure it's read/write enabled.

Anything in your error-log?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #7 on: October 31, 2010, 04:55:09 PM »
Optimize didn't work.

Made the tmp dir and didn't work either.

The error log gave me this: 2: fopen(/home/a8468215/public_html/Sources/Admin.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied

I changed everything to 777 and didn't work.

The worst part of this is I tried to install a package manually and didn't work either T___T

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #8 on: October 31, 2010, 04:58:33 PM »

The worst part of this is I tried to install a package manually and didn't work either T___T

In what way?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #9 on: October 31, 2010, 05:01:26 PM »
Following this instructions. http://custom.simplemachines.org/mods/index.php?action=parse

Maybe I just screwed it up, I don't think it's related, but I was just letting my frustration out.

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #10 on: October 31, 2010, 05:04:18 PM »
I think we've all been there...  :(

Maybe there's a problem with the file permissions.

If you look, in Admin>Packages>File permissions, is that set to "Standard"?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #11 on: October 31, 2010, 05:08:01 PM »
Nothing, and not with "free", either.

By the way, I think the weird part is that it's not even giving me an error or something, it just loads a blank page ._."

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #12 on: October 31, 2010, 05:18:02 PM »
Quote
The error log gave me this: 2: fopen(/home/a8468215/public_html/Sources/Admin.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied

That's saying that there's something that you're trying to access that you're not allowed to.

Have you had your site for very long?

To me (I could be wrong), that points to you not having full ownership of the files on your site.

Yes, I know you own your site. This is a different thing. ;)

Can you contact your host and ask them? (They'll know what you mean, unless they're dumb).

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #13 on: October 31, 2010, 05:27:17 PM »
But why all of the sudden? The support tickets on 000webhost take so long T__T

I have to add, error log just showed that once, if I try again, it just doesn't install and no error is returned.

If you want to forget about this, can you please explain me why when I manual install the mod above, I can't see any options in the admin panel? Error Log says: 8: Undefined index: awards_settings (and there's one for every name there, like awards_name, etc.)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #14 on: October 31, 2010, 05:34:39 PM »
When you do the manual edits, you do them for the theme that you're using, yes?

The edits that are made to files that are for the default theme also have to be made to the corresponding files that the custom theme has. (If they exist)

No idea why this could have suddenly just started happening.

Thing is, though, som hosts do things and don't even tell their clients.

One member, here, had his host change almost everything and his forum's been in tatters, since!

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #15 on: October 31, 2010, 05:35:42 PM »
Ok, I'll send a ticket... and no, I'm using default theme, and changed everything accordingly (triple checked already x.x)

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #16 on: October 31, 2010, 05:41:41 PM »
I found this:
This feature is useful when you have any files created by PHP (for example if you installed Joomla or used some file upload script), ownership of these files usually changes to "99" or "nobody" and you are not be able to delete or modify such files by FTP or File Manager, you will get "Permission denied" errors (such files can be deleted by PHP script only).

This tool fixes ownership for all files inside of your account, so you can edit or delete without problems.

Did it, and still not working x.x does the universe just hate me? xD

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #17 on: October 31, 2010, 05:47:16 PM »
excuse me,

do you change your cpanel password ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #18 on: October 31, 2010, 05:49:20 PM »
I feel like that, sometimes. :(

Check with your host.

If you get no joy, come back here and we'll try and figure something out, OK?

In the meantime, someone else might have some suggestions that you could try.

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #19 on: October 31, 2010, 05:54:54 PM »
I have just thought... I have get sometimes the possibility to set ftp password and username to make smf take care of ftp, but with an added "path to smf" textfield. I think maybe it could have something to do with it, or at least I want to try to see what's there, but in the section it only asks for host, user and port (no password or path)... so... how do I edit it?

I also changed the password recently, so I want to make sure it's correct too o.o"