Advertisement:

Author Topic: Can't install/uninstall packages  (Read 7143 times)

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Can't install/uninstall packages
« on: October 31, 2010, 03:20:15 AM »
Everytime when I try to uninstall a package, just after I click "uninstall now", SMF loads a blank screen ( only changes the URL with uninstall2: ...action=admin;area=packages;sa=uninstall2;package=...), then if I refresh it it happens again. And if I click enter on the url box, I get "Your session timed out while posting. Please go back and try again."

Any ideas?

Thanks in advance

Edit: I just discovered I can't install packages either, same problem as for uninstalling

EDIT2:
Solved. If you get this error (just a blank page with nothing after the (un)install now click), check the backups folder inside Packages folder, since you may have (like me) like 200MB of them. Just make some space and it'll be fine.

tl;dr This problem is because of not having enough space for the next backup. Just make some space in your account.


PS:
Thank you very very much to mrtarkhan and k@ for all of their help n.n!
« Last Edit: November 02, 2010, 12:50:32 AM by kirbyiwaki »

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't uninstall packages
« Reply #1 on: October 31, 2010, 05:47:15 AM »
check the uninstall file, maybe it not exist in your package folder.

if you have a problem with that, you can uninstall it by own.

or you can change the url with this :

action=admin;area=packages;sa=uninstall;package=...), and remove 2.
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't uninstall packages
« Reply #2 on: October 31, 2010, 01:11:24 PM »
It happens with all packages. So it's not the package. Without the 2, it just reloads the pre-uninstall page.

By the way, everything passes the uninstall test, too.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #3 on: October 31, 2010, 04:11:51 PM »
change your theme to default.

if you have this problem again, replace a your package.php file (Sources folder) with new one.
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #4 on: October 31, 2010, 04:23:05 PM »
I have the default theme... tried replacing packages.php with the fresh one (it was the same size) and it didn't work either.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #5 on: October 31, 2010, 04:32:31 PM »
Maintenance => Database => Optimize all tables

it is a good choice when you have a problem like this.

and see this too :

log

your last package and your version ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #6 on: October 31, 2010, 04:33:20 PM »
Just curious...

Inside your "Packages" directory, do you have another, named "tmp"?

If not, try making one and make sure it's read/write enabled.

Anything in your error-log?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #7 on: October 31, 2010, 04:55:09 PM »
Optimize didn't work.

Made the tmp dir and didn't work either.

The error log gave me this: 2: fopen(/home/a8468215/public_html/Sources/Admin.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied

I changed everything to 777 and didn't work.

The worst part of this is I tried to install a package manually and didn't work either T___T

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #8 on: October 31, 2010, 04:58:33 PM »

The worst part of this is I tried to install a package manually and didn't work either T___T

In what way?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #9 on: October 31, 2010, 05:01:26 PM »
Following this instructions. http://custom.simplemachines.org/mods/index.php?action=parse

Maybe I just screwed it up, I don't think it's related, but I was just letting my frustration out.

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #10 on: October 31, 2010, 05:04:18 PM »
I think we've all been there...  :(

Maybe there's a problem with the file permissions.

If you look, in Admin>Packages>File permissions, is that set to "Standard"?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #11 on: October 31, 2010, 05:08:01 PM »
Nothing, and not with "free", either.

By the way, I think the weird part is that it's not even giving me an error or something, it just loads a blank page ._."

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #12 on: October 31, 2010, 05:18:02 PM »
Quote
The error log gave me this: 2: fopen(/home/a8468215/public_html/Sources/Admin.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied

That's saying that there's something that you're trying to access that you're not allowed to.

Have you had your site for very long?

To me (I could be wrong), that points to you not having full ownership of the files on your site.

Yes, I know you own your site. This is a different thing. ;)

Can you contact your host and ask them? (They'll know what you mean, unless they're dumb).

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #13 on: October 31, 2010, 05:27:17 PM »
But why all of the sudden? The support tickets on 000webhost take so long T__T

I have to add, error log just showed that once, if I try again, it just doesn't install and no error is returned.

If you want to forget about this, can you please explain me why when I manual install the mod above, I can't see any options in the admin panel? Error Log says: 8: Undefined index: awards_settings (and there's one for every name there, like awards_name, etc.)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #14 on: October 31, 2010, 05:34:39 PM »
When you do the manual edits, you do them for the theme that you're using, yes?

The edits that are made to files that are for the default theme also have to be made to the corresponding files that the custom theme has. (If they exist)

No idea why this could have suddenly just started happening.

Thing is, though, som hosts do things and don't even tell their clients.

One member, here, had his host change almost everything and his forum's been in tatters, since!

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #15 on: October 31, 2010, 05:35:42 PM »
Ok, I'll send a ticket... and no, I'm using default theme, and changed everything accordingly (triple checked already x.x)

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #16 on: October 31, 2010, 05:41:41 PM »
I found this:
This feature is useful when you have any files created by PHP (for example if you installed Joomla or used some file upload script), ownership of these files usually changes to "99" or "nobody" and you are not be able to delete or modify such files by FTP or File Manager, you will get "Permission denied" errors (such files can be deleted by PHP script only).

This tool fixes ownership for all files inside of your account, so you can edit or delete without problems.

Did it, and still not working x.x does the universe just hate me? xD

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #17 on: October 31, 2010, 05:47:16 PM »
excuse me,

do you change your cpanel password ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #18 on: October 31, 2010, 05:49:20 PM »
I feel like that, sometimes. :(

Check with your host.

If you get no joy, come back here and we'll try and figure something out, OK?

In the meantime, someone else might have some suggestions that you could try.

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #19 on: October 31, 2010, 05:54:54 PM »
I have just thought... I have get sometimes the possibility to set ftp password and username to make smf take care of ftp, but with an added "path to smf" textfield. I think maybe it could have something to do with it, or at least I want to try to see what's there, but in the section it only asks for host, user and port (no password or path)... so... how do I edit it?

I also changed the password recently, so I want to make sure it's correct too o.o"

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #20 on: October 31, 2010, 06:03:16 PM »
If your password was wrong, you couldn't connect to the database, so it's not that.

The path to SMF must be right, too, or your forum simply wouldn't work, at all.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #21 on: October 31, 2010, 06:12:14 PM »
and do you change your .htacess file in your smf.

for Example you want change your address automaticly from non-www to www version.
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #22 on: October 31, 2010, 06:45:23 PM »
But the path for the ftp, I meant.

I didn't understand what mrtarkhan said, but .htaccess inside packages has:
<Files *>
    Order Deny,Allow
    Deny from all
    Allow from localhost
</Files>

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #23 on: October 31, 2010, 06:52:03 PM »
But the path for the ftp, I meant.

I didn't understand what mrtarkhan said, but .htaccess inside packages has:
<Files *>
    Order Deny,Allow
    Deny from all
    Allow from localhost
</Files>

for password i make mistake :-[ excuse me.

for htaccess :

i say if you use a redirected code in your file, your url don't work correctly. is it clear ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #24 on: October 31, 2010, 07:50:22 PM »
htaccess only has what I already posted. I even removed it from the site and it still happens. I'll upload another smf to the same host, and see if it works.

Edit:
Just did it and everything worked fine. Same webhost, so it has to be something with the other installation T_T

anyone? T_T this is so frustrating

Edit:
I edited packages.php, commenting "checkSession();" on "function PackageInstall();", and now if I put the 2 manually, I don't get the "Your session timed out while posting. Please go back and try again." error, just blank page.
« Last Edit: November 01, 2010, 12:42:34 AM by kirbyiwaki »

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #25 on: November 01, 2010, 03:25:47 AM »
removebumping!

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #26 on: November 01, 2010, 07:48:14 AM »
I dunno what that .htaccess was about, to be honest...

Have you tried this, to check the paths and stuff?

http://docs.simplemachines.org/index.php?topic=663

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #27 on: November 01, 2010, 02:16:22 PM »
Tried that with no luck. Thanks for trying to help, it's very appreciated

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #28 on: November 01, 2010, 05:02:37 PM »
Just had an idea...

In Admin>Packages>Options, you'll see "FTP Server:".

What's in that box?

Keep a copy of what's there, now. (Paste it in Notepad, or something), then change it to "localhost". (You can put it back, as-was, if this doesn't help).

Does that make any difference?

Apologies, if I've already suggested this.

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #29 on: November 01, 2010, 05:22:05 PM »
didn't work. Same blank screen.

I was wondering if there's some way to debug the actions of the InstallPackage() action on the packages.php file that executes in the install2 step (I hope it doesn't sound too confusing xD). I'm certain that the package uploads and deploys into the temp dir, so it must be something that stops the script after that (just don't have any idea of what)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #30 on: November 01, 2010, 05:29:02 PM »
I can see where you're coming from, with that.

Problem is, why would that affect you and not all of us, if it is that?

Odd that this is happening with installs AND uninstalls, though, innit?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #31 on: November 01, 2010, 06:14:53 PM »
I've been thinking (because I'm a php noob, but I have my ways with java), so I'm thinking is not that packages.php is wrong, but a function/variable/etc. that it's been called from there is the cause (maybe in another file modified by an installation).

I often debug my programs adding a print after a function and if it executes, I cut the print and paste it after the next function. That way I can isolate the problem.

So... echo didn't work to make something like that, and I'm wondering, is there something that I can put in packages.php that will execute in a visual way?

PS:
Maybe, just maybe, Aeva 1.1b was the last mod I installed (and I can't update it because I can't install xD)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #32 on: November 01, 2010, 06:17:23 PM »
If you have a look at your error log, you might find some clues.

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #33 on: November 01, 2010, 06:20:09 PM »
Nothing new since the error I reported (which apparently doesn't have anything to do xD)

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #34 on: November 01, 2010, 06:24:12 PM »
can u uninstall a package and after it past the last log here ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #35 on: November 01, 2010, 06:26:46 PM »
Nothing new since the error I reported (which apparently doesn't have anything to do xD)

What about the error-log in your CPanel?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #36 on: November 01, 2010, 06:32:33 PM »
@mrtarkhan - Problem is, that I can't uninstall a package.

@K@ - I think I have no error log in my CPanel o.o

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #37 on: November 01, 2010, 06:36:46 PM »
Under the "Logs" section, "Error logs"?

This is your site's CPanel, not SMF.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #38 on: November 01, 2010, 06:43:50 PM »
@mrtarkhan - Problem is, that I can't uninstall a package.
i know, just do it to see the blank page. after it go to error log.

you say your problem not is your permisions, FTP, SMF source, theme, DB.

so it must have a reason for that .

see your error log in smf and cpanel.

and i say it again: make a backup of DB and install your SMF again !
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #39 on: November 01, 2010, 07:03:42 PM »
Under the "Logs" section, "Error logs"?

This is your site's CPanel, not SMF.

There's only "activity log", I'm using 000webhost.

i know, just do it to see the blank page. after it go to error log.

you say your problem not is your permisions, FTP, SMF source, theme, DB.

so it must have a reason for that .

see your error log in smf and cpanel.

and i say it again: make a backup of DB and install your SMF again !
The blank page does not generate any error. I'll try to install it again, looks like is never gonna be solved T_T

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #40 on: November 01, 2010, 07:14:50 PM »
take this suggestion :

suicide!



i just kidding.

Quote
The blank page does not generate any error. I'll try to install it again, looks like is never gonna be solved T_T

so i am sure the problem is your DB. O:)
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #41 on: November 01, 2010, 07:37:24 PM »
So if I reinstall the forum, and restore the DB it will happen again... what part of the DB? xD

EDIT: F***ING FIXED! xD see first post for details!
« Last Edit: November 02, 2010, 12:44:48 AM by kirbyiwaki »

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #42 on: November 02, 2010, 06:55:20 AM »
OO! Yeah!

They can take-up a lot of room, those backups!

Might be good to keep the files saved on your computer, though.

They can come in handy.

Thanks for letting us know, kirbyiwaki! Might well help others, in the future, that!

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #43 on: November 03, 2010, 06:14:06 PM »
thanks kirbyiwaki
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))