Advertisement:

Author Topic: Can't install/uninstall packages  (Read 7139 times)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #20 on: October 31, 2010, 06:03:16 PM »
If your password was wrong, you couldn't connect to the database, so it's not that.

The path to SMF must be right, too, or your forum simply wouldn't work, at all.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #21 on: October 31, 2010, 06:12:14 PM »
and do you change your .htacess file in your smf.

for Example you want change your address automaticly from non-www to www version.
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #22 on: October 31, 2010, 06:45:23 PM »
But the path for the ftp, I meant.

I didn't understand what mrtarkhan said, but .htaccess inside packages has:
<Files *>
    Order Deny,Allow
    Deny from all
    Allow from localhost
</Files>

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #23 on: October 31, 2010, 06:52:03 PM »
But the path for the ftp, I meant.

I didn't understand what mrtarkhan said, but .htaccess inside packages has:
<Files *>
    Order Deny,Allow
    Deny from all
    Allow from localhost
</Files>

for password i make mistake :-[ excuse me.

for htaccess :

i say if you use a redirected code in your file, your url don't work correctly. is it clear ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #24 on: October 31, 2010, 07:50:22 PM »
htaccess only has what I already posted. I even removed it from the site and it still happens. I'll upload another smf to the same host, and see if it works.

Edit:
Just did it and everything worked fine. Same webhost, so it has to be something with the other installation T_T

anyone? T_T this is so frustrating

Edit:
I edited packages.php, commenting "checkSession();" on "function PackageInstall();", and now if I put the 2 manually, I don't get the "Your session timed out while posting. Please go back and try again." error, just blank page.
« Last Edit: November 01, 2010, 12:42:34 AM by kirbyiwaki »

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #25 on: November 01, 2010, 03:25:47 AM »
removebumping!

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #26 on: November 01, 2010, 07:48:14 AM »
I dunno what that .htaccess was about, to be honest...

Have you tried this, to check the paths and stuff?

http://docs.simplemachines.org/index.php?topic=663

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #27 on: November 01, 2010, 02:16:22 PM »
Tried that with no luck. Thanks for trying to help, it's very appreciated

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #28 on: November 01, 2010, 05:02:37 PM »
Just had an idea...

In Admin>Packages>Options, you'll see "FTP Server:".

What's in that box?

Keep a copy of what's there, now. (Paste it in Notepad, or something), then change it to "localhost". (You can put it back, as-was, if this doesn't help).

Does that make any difference?

Apologies, if I've already suggested this.

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #29 on: November 01, 2010, 05:22:05 PM »
didn't work. Same blank screen.

I was wondering if there's some way to debug the actions of the InstallPackage() action on the packages.php file that executes in the install2 step (I hope it doesn't sound too confusing xD). I'm certain that the package uploads and deploys into the temp dir, so it must be something that stops the script after that (just don't have any idea of what)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #30 on: November 01, 2010, 05:29:02 PM »
I can see where you're coming from, with that.

Problem is, why would that affect you and not all of us, if it is that?

Odd that this is happening with installs AND uninstalls, though, innit?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #31 on: November 01, 2010, 06:14:53 PM »
I've been thinking (because I'm a php noob, but I have my ways with java), so I'm thinking is not that packages.php is wrong, but a function/variable/etc. that it's been called from there is the cause (maybe in another file modified by an installation).

I often debug my programs adding a print after a function and if it executes, I cut the print and paste it after the next function. That way I can isolate the problem.

So... echo didn't work to make something like that, and I'm wondering, is there something that I can put in packages.php that will execute in a visual way?

PS:
Maybe, just maybe, Aeva 1.1b was the last mod I installed (and I can't update it because I can't install xD)

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #32 on: November 01, 2010, 06:17:23 PM »
If you have a look at your error log, you might find some clues.

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #33 on: November 01, 2010, 06:20:09 PM »
Nothing new since the error I reported (which apparently doesn't have anything to do xD)

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #34 on: November 01, 2010, 06:24:12 PM »
can u uninstall a package and after it past the last log here ?
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #35 on: November 01, 2010, 06:26:46 PM »
Nothing new since the error I reported (which apparently doesn't have anything to do xD)

What about the error-log in your CPanel?

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #36 on: November 01, 2010, 06:32:33 PM »
@mrtarkhan - Problem is, that I can't uninstall a package.

@K@ - I think I have no error log in my CPanel o.o

kat

  • Guest
Re: Can't install/uninstall packages
« Reply #37 on: November 01, 2010, 06:36:46 PM »
Under the "Logs" section, "Error logs"?

This is your site's CPanel, not SMF.

Offline mrtarkhan

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
  • IT Manager
    • mrtarkhan
Re: Can't install/uninstall packages
« Reply #38 on: November 01, 2010, 06:43:50 PM »
@mrtarkhan - Problem is, that I can't uninstall a package.
i know, just do it to see the blank page. after it go to error log.

you say your problem not is your permisions, FTP, SMF source, theme, DB.

so it must have a reason for that .

see your error log in smf and cpanel.

and i say it again: make a backup of DB and install your SMF again !
هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Offline kirbyiwaki

  • Semi-Newbie
  • *
  • Posts: 34
Re: Can't install/uninstall packages
« Reply #39 on: November 01, 2010, 07:03:42 PM »
Under the "Logs" section, "Error logs"?

This is your site's CPanel, not SMF.

There's only "activity log", I'm using 000webhost.

i know, just do it to see the blank page. after it go to error log.

you say your problem not is your permisions, FTP, SMF source, theme, DB.

so it must have a reason for that .

see your error log in smf and cpanel.

and i say it again: make a backup of DB and install your SMF again !
The blank page does not generate any error. I'll try to install it again, looks like is never gonna be solved T_T