Advertisement:

Author Topic: GET Method Not Implemented  (Read 15488 times)

Offline Jayne Louise

  • Semi-Newbie
  • *
  • Posts: 71
GET Method Not Implemented
« on: December 22, 2010, 06:43:52 PM »
Im getting this error with a mod that, besides this error, works perfectly. I already posted in the mod support with little response.

Can anyone tell me what it means. Ive installed the mod on a few different smf versions and am consistently getting this error. At least, it is consistent when running online but when I run it in xampp I dont get this error and everything runs smoothly.

What is the online server lacking? Is it a server issue? If it is, and I contact my host, what would I say that made sense? Is it something that can even be resolved?


Quote
Method Not Implemented

GET to /forum/index.php not supported.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

~J:L

Offline Forum Guy

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
  • tomorrow is when you missed yesterday!
Re: GET Method Not Implemented
« Reply #1 on: December 22, 2010, 08:20:17 PM »
your host probably got mod_security installed and SMF is not fully compatible with that


Offline Jayne Louise

  • Semi-Newbie
  • *
  • Posts: 71
Re: GET Method Not Implemented
« Reply #2 on: December 23, 2010, 06:00:57 PM »
Thanks for that Forum Guy.

My host says that to disable mod_security I should create a .htaccess in the same folder as the script (and tried every folder) that is causing the problem. I did that and entered the following, and variations of it, and still get the same error:

Quote
mod_security.c>
SecFilterEngine Off

The mod is question is the members awards mod. Bearing in mind I have used and tried over 40 mods and have never had this error before, does anyone know what it is that this mod is doing to produce this error and is there any way around it?

It happens when I make these calls:

Quote
index.php?action=profile;area=awardsMembers;id=1
index.php?action=admin;area=awards;sa=modify;id=1
index.php?action=admin;area=awards;sa=assign;step=1;id=1
index.php?action=admin;area=awards;sa=viewassigned;id=1
~J:L

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: GET Method Not Implemented
« Reply #3 on: December 23, 2010, 06:07:34 PM »
It has id= in the URL. It trips the rules for mod_security. If you can't turn it off using .htaccess, your host has disabled that option, meaning that without seriously rewriting the awards mod it won't ever work on that host.
No good deed goes unpunished
All helpful urges should be circumvented

Offline Forum Guy

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
  • tomorrow is when you missed yesterday!
Re: GET Method Not Implemented
« Reply #4 on: December 23, 2010, 07:11:06 PM »
Try this


<IfModule mod_security.c>
SecFilterEngine Off
</ifModule>

Offline Jayne Louise

  • Semi-Newbie
  • *
  • Posts: 71
Re: GET Method Not Implemented
« Reply #5 on: December 23, 2010, 07:52:45 PM »
Thanks both.

Quote
<IfModule mod_security.c>
SecFilterEngine Off
</ifModule>
I tried that variation Forum Guy with no luck...same result.

Quote
It has id= in the URL. It trips the rules for mod_security. If you can't turn it off using .htaccess, your host has disabled that option, meaning that without seriously rewriting the awards mod it won't ever work on that host.

This is what my host says:
Quote
If you find that mod_security is interfering too much with your web applications, you can disable it easily by following these steps:
   1.Create an .htaccess file in the directory of the script with which you are having problems.
   2.To disable mod_security completely, add the following line to the .htaccess file: SecFilterEngine Off
   3.To disable HTTP POST scanning only, use the following instead: SecFilterScanPOST Off
   4.Save the file and test your site to ensure that disabling mod_security has solved your problem.

I have asked them to confirm whether mod_security can actually be disabled and whether this information they have given me is correct. It seems I cant really try anything else right now until they get back to me.



 
~J:L

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: GET Method Not Implemented
« Reply #6 on: December 23, 2010, 07:53:52 PM »
Did you try just:
Code: [Select]
SecFilterEngine Off in the .htaccess file?
No good deed goes unpunished
All helpful urges should be circumvented

Offline Jayne Louise

  • Semi-Newbie
  • *
  • Posts: 71
Re: GET Method Not Implemented
« Reply #7 on: December 23, 2010, 08:04:24 PM »
Yes I have tried that and I get a 500 Internal Server Error and cant even access the forum.

Quote
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
~J:L

Offline Forum Guy

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
  • tomorrow is when you missed yesterday!
Re: GET Method Not Implemented
« Reply #8 on: December 23, 2010, 08:26:09 PM »
certainly your server's mod_security playing up but we can't help you to fix that - only your host can, sorry!

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: GET Method Not Implemented
« Reply #9 on: December 23, 2010, 08:26:38 PM »
Then tell them that's what happened. Your host's configuration doesn't let you override their settings, tell them, so they can change it.
No good deed goes unpunished
All helpful urges should be circumvented

Offline Jayne Louise

  • Semi-Newbie
  • *
  • Posts: 71
Re: GET Method Not Implemented
« Reply #10 on: December 23, 2010, 08:41:44 PM »
Thanks both for taking an interest.

I was coming to that conclusion myself. Doing what they've told me to do simply doesnt work.

If I get this fixed I will post a reply here in case anyone else ever has the same problem.

May take a few days now with xmas upon us...

~J:L

Offline Drunken Clam

  • Full Member
  • ***
  • Posts: 497
  • Gender: Male
  • A closed mouth gathers no foot....
Re: GET Method Not Implemented
« Reply #11 on: December 24, 2010, 11:28:03 AM »
I had this very same problem with another mod.

What you need to do is find which of the mods files actually builds the URL's, it's probably best to ask the mod author which files these are.

Once you know which files, you then need to edit them and find each occurrence of ;id and change them to &amp;id which will be handled by the browser as &id.

You could test this before making any changes by replacing the ; in the URL with a &, in one of your failing URL's,
i.e. change:

Code: [Select]
index.php?action=profile;area=awardsMembers;id=1
to
Code: [Select]
index.php?action=profile;area=awardsMembers&id=1
Hope that helps!
(Thanks to Arantor)

Offline Jayne Louise

  • Semi-Newbie
  • *
  • Posts: 71
Re: GET Method Not Implemented
« Reply #12 on: December 24, 2010, 04:53:19 PM »
Big Kiss and hats off to you Drunken Clam.

That has solved the problem, many thanks. Im unsure why I cant find anyone else having this same error with such a popular mod and why I need to add that ampersand but its running perfectly now.

If anyone else has a similar problem or the same problem with the member awards they may want to try the following:

All the ;id calls that were springing the error were found in these files:
Sources\Load.php
Sources\Profile-View.php
Sources\Profile.php
Sources\ManageAwards.php
Themes\default\ManageAwards.template.php

Then search all those files for every instance of the following making sure they are associated with the awards and calling  the ;id. Simply put an ampersand in front of the colon of each instance and bingo:
awardsmembers
viewassigned
editcategory
viewcategory
deletecategory


Thanks all.

~J:L

Offline akhn

  • Semi-Newbie
  • *
  • Posts: 18
Re: GET Method Not Implemented
« Reply #13 on: April 08, 2011, 03:52:28 PM »
I had this very same problem with another mod.

What you need to do is find which of the mods files actually builds the URL's, it's probably best to ask the mod author which files these are.

Once you know which files, you then need to edit them and find each occurrence of ;id and change them to &amp;id which will be handled by the browser as &id.

You could test this before making any changes by replacing the ; in the URL with a &, in one of your failing URL's,
i.e. change:

Code: [Select]
index.php?action=profile;area=awardsMembers;id=1
to
Code: [Select]
index.php?action=profile;area=awardsMembers&id=1
Hope that helps!
(Thanks to Arantor)

Thnks for everything.
I have solved the problem with yours ideas..

Really thnks for.

Offline akhn

  • Semi-Newbie
  • *
  • Posts: 18
Re: GET Method Not Implemented
« Reply #14 on: April 08, 2011, 03:55:23 PM »
Big Kiss and hats off to you Drunken Clam.

That has solved the problem, many thanks. Im unsure why I cant find anyone else having this same error with such a popular mod and why I need to add that ampersand but its running perfectly now.

If anyone else has a similar problem or the same problem with the member awards they may want to try the following:

All the ;id calls that were springing the error were found in these files:
Sources\Load.php
Sources\Profile-View.php
Sources\Profile.php
Sources\ManageAwards.php
Themes\default\ManageAwards.template.php

Then search all those files for every instance of the following making sure they are associated with the awards and calling  the ;id. Simply put an ampersand in front of the colon of each instance and bingo:
awardsmembers
viewassigned
editcategory
viewcategory
deletecategory


Thanks all.


thnks.

I have solved this problem with the same php on ftp.
these :

MGallery-Admin.php
MGallery-ModCP.php
MGallery-Embed.php
MGallery-Exif.php
MGallery-Sub.php
MGallery.php

Ftp den forum/themes/default
MGallery.template.php

I searced phps  ";id" and ı changed all of them "&id" in ftp folder.