Advertisement:

Author Topic: Novi webhosting i problem sa slovima  (Read 744 times)

Offline croboy

  • Semi-Newbie
  • *
  • Posts: 41
Novi webhosting i problem sa slovima
« on: January 01, 2011, 11:21:32 AM »
Pozdrav svima,

Procitao sam sve topice s problemima s nasim slovima. Jedno 7-8 ukupno plus pretrazio preko Googla (cca. 50-60 stranica) i na kraju nema druge nego da pitam i ovdje.

Prebacio sam forum na novi hosting.

Na starom hostingu je collation bio utf8_general_ci.
Tek sad sam vidio da je u language file-u index.croatian.php bio postavljen ISO-8859-2.
U settingsima je bilo $db_character_set = 'utf8';
To je radilo kako treba.

Na novom serveru je collation isto utf8_general_ci isti ali stvar ne radi.
Sve file-ove sam kopirao tako da je sve ostalo isto (index.croatian.php je i dalje postavljen na ISO-8859-2.)

Prije importa u novu bazu sam prebacio na utf8_general_ci. Kod importa odaberem UTF8.
Probao sam u settings staviti UTF-8. Probao sam koroz forum admin CP prebaciti u UTF8.
Probao sam promjeniti u index.croatian.php je i dalje postavljen na ISO-8859-2 u UTF8.
Nista ne radi i nemam vise ideja. Mozda bi trebalo raditi izmjene nekim redosljedom ali nemam pojma kojim.

Ima li netko ideju sto da napravim?
Na neki nacin sam dosao do toga da se novi postovi dobro prikazu (šđčćž) ali stari postoji i njihovi naslovi ne (uključujući i forum boardove). Importao sam bazu jedno 20-30 puta u svim mogucim kombinacijama.

U obje baze zapisi izgledaju isto (sa istim čudnim znakovima). Sad sam uspio dobiti da se na forumu prikazuje samo �
To mi se ranije znalo prikazati na starom u nekoj konfiguraciji.

Hvala
« Last Edit: January 01, 2011, 11:34:36 AM by croboy »

Offline croboy

  • Semi-Newbie
  • *
  • Posts: 41
Re: Novi webhosting i problem sa slovima
« Reply #1 on: January 01, 2011, 11:53:49 AM »
Nakon 30 importa i taman kad sam napisao ovdje poruku stvar se rijesila sama od sebe.
Ne znam tocno u kojoj kombijaciji je proradilo. Nista nisam posebno mjenjao. Importao normlanom procedurom.
Baza prvo prebacio na utf8_general_ci za svaki slucaj.
Importao file i odabrao UTF-8.

Lang. file je i dalje $txt['lang_character_set'] = 'ISO-8859-2';
Settings je i dalje $db_character_set = 'utf-8';

Za poluditi. Potrosio 7-8 sati i na kraju sve kao radi.