Advertisement:

Author Topic: Forum Firewall  (Read 305891 times)

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #480 on: July 22, 2011, 05:46:46 PM »
Here is info on %msg_id%.
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline stratocaster

  • Semi-Newbie
  • *
  • Posts: 10
Re: Forum Firewall
« Reply #481 on: July 22, 2011, 11:20:41 PM »
Here is info on %msg_id%.


Ok butchs, Thank you.

Offline justjim

  • Semi-Newbie
  • *
  • Posts: 60
    • SpywareHammer.com
Re: Forum Firewall
« Reply #482 on: July 24, 2011, 08:23:22 AM »
I'm receiving this error in the Forum Error log

Code: [Select]
2: strpos() [<a href='function.strpos'>function.strpos</a>]: Empty delimiter

..../Sources/ForumFirewall.php
Line: 202

What should l look for?

Thanks

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #483 on: July 24, 2011, 11:24:31 AM »
First off you should upgraded to the latest version, you are using version 1.1.1 or older.

Second your
Quote
Injection List
is either empty or it contains
Code: [Select]
|| which should be single
Code: [Select]
|.
 8)
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline justjim

  • Semi-Newbie
  • *
  • Posts: 60
    • SpywareHammer.com
Re: Forum Firewall
« Reply #484 on: July 24, 2011, 01:29:41 PM »
First off you should upgraded to the latest version, you are using version 1.1.1 or older.

Second your
Quote
Injection List
is either empty or it contains
Code: [Select]
|| which should be single
Code: [Select]
|.
 8)
Thank you. I'll re-load and re-check.

Offline Xarcell

  • SMF Hero
  • ******
  • Posts: 1,684
  • Gender: Male
  • SMF-DP Supporter
Re: Forum Firewall
« Reply #485 on: July 24, 2011, 03:48:29 PM »
Can forum firewall be used to stop spammers who manually register and spam my forums? If so, how?

I'm spending a 1/2 hour a day per site deleting spam. I keep banning people, but it just doesn't stop.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #486 on: July 24, 2011, 04:14:35 PM »
If there is a pattern to what they are doing they can be blocked.  You will need to look at your forum log.  You can PM me parts if you like...

Otherwise bad behavior with project honeypot enabled and/or stop forum spam can assist.

For some reason they have been aggressive the past few weeks.  Bad behavior has blocked over 1,000 spammers from my site this week.  Previously I averaged 300 blocks a week.


« Last Edit: July 24, 2011, 04:22:43 PM by butchs »
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline busterone

  • SMF Hero
  • ******
  • Posts: 2,150
  • Gender: Male
  • Devil Dog
    • The Demon's Den
Re: Forum Firewall
« Reply #487 on: July 24, 2011, 07:09:19 PM »
Indeed, the spammers have gotten extremely aggressive lately.  The little robo-roaches have been on steroids.  :)

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #488 on: July 24, 2011, 08:17:36 PM »
They were killing me earlier this month.  Not anymore...  I believe they are getting desperate!
 O:)
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Alex' Manson

  • Full Member
  • ***
  • Posts: 506
  • Gender: Male
  • dead and gone!
    • Sisko Hosting - FREE|PAID Hosting
Re: Forum Firewall
« Reply #489 on: July 25, 2011, 04:35:16 AM »
there is a mistake in the english language, in the enable robots.txt validation, press the help button, you will see that it says robots.tst inside it.

Offline MiY4Gi

  • Full Member
  • ***
  • Posts: 523
  • Gender: Male
  • Mm...
    • MyAnimeClub.net
Re: Forum Firewall
« Reply #490 on: July 25, 2011, 04:12:16 PM »
What would work best for harvester bots? Spammers aren't that big a deal, but I can't have bots killing my server. I see it says that Forum Firewall can prevent DDOS attacks. How does it do this? What about bots that "browse" my forum at light speed? Can I slow them down somehow?
Check out my new website, MyAnimeClub.net. I plan to create the largest anime community, and most fun and user-friendly anime forum in the world. It's still in the development stage though.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #491 on: July 25, 2011, 06:09:36 PM »
there is a mistake in the english language, in the enable robots.txt validation, press the help button, you will see that it says robots.tst inside it.

I am sure there are more.   :o
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #492 on: July 25, 2011, 06:22:22 PM »
What would work best for harvester bots? Spammers aren't that big a deal, but I can't have bots killing my server.

I designed this mod to get the bots that Bad Behavior was not getting.  It is designed to complement BB mod...  The ones that suck up bandwidth and/or try to hack your site.

I see it says that Forum Firewall can prevent DDOS attacks. How does it do this?

I can not tell you how I do it in an open forum, otherwise the bad guys will work-around-it but, please set-up your robots.txt as described in this post.

What about bots that "browse" my forum at light speed? Can I slow them down somehow?

Yes.  Make sure you have the "Crawl-delay:" set in robots.txt and google webmasters.  Then set your "DOS Attack",  "Trigger" and "Longterm Ban".  You can set the "Longterm Ban" to never for starters.  If they are persistent you can increase it.  The bots will retaliate by hitting your site hard for a week or two and then give up.

Your regular members with multiple posts should be added to the Whitelist Membergroup Permission.
 8)
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline justjim

  • Semi-Newbie
  • *
  • Posts: 60
    • SpywareHammer.com
Re: Forum Firewall
« Reply #493 on: July 25, 2011, 08:27:09 PM »
Thanks butchs for a great mod.  :)

Offline digit

  • Sophist Member
  • *****
  • Posts: 1,364
  • Gender: Male
Re: Forum Firewall
« Reply #494 on: July 26, 2011, 08:56:27 AM »
Besides copying files over files there were changes in the modsettings database.

You should be able to go to the admin page and manually enter the data there instead of having to have to reinstall.
  Copy the Robots to be tested from install_db.
  Then manually enter the action's from your robots file as explained in the help.
  Hit save and the information should load into the database.
 :)

Thanks Butchs,

Well, I went through the manual upgrade...  then enabled it and as soon as I submitted the settings, I got a white screen, killing the forum.  I removed the include in the index.php file (figured it was the fastest way to restore the forum) and voila it came back.

Looked in my error logs, and had a bunch of these...

Undefined index: possibly_robot
File: /users/Sources/Subs-ForumFirewall.php
Line: 205

Any ideas?

Thanks.
digit
Happily using a heavily modified 1.1.16 version of SMF!

2748011 Posts in 320998 Topics by 50986 Members


SOLD my website - thanks it was a good run - they converted to vbadvanced. (and screwed it up good!)

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #495 on: July 26, 2011, 05:51:17 PM »
That is because your are using the "Subs-ForumFirewall.php" for SMF 2.0.x.  If you unzip the mod and look in the "1x" folder you will find the correct "Subs-ForumFirewall.php" for SMF 1.1.x.  Grab the others while you are there...
 O:)
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline digit

  • Sophist Member
  • *****
  • Posts: 1,364
  • Gender: Male
Re: Forum Firewall
« Reply #496 on: July 26, 2011, 06:08:30 PM »
Thanks, did that, (must have copied over the 2x files after I DID copy over the 1x files!)

Now I am getting... 
Code: [Select]
HTTP Error 403 Forbidden

You don't have permission to access

/ on this server.

Your computer may be infected with a virus or a trojan. The Firewall has determined that you: Invalid ip!

If you get this message in error, please contact the ADM1N and provide the date and time of this message.

I added my current IP address and this still appears.

My log shows...  Invalid Admin IP: XX.XX.XXX! (x-ed out by me)

Sorry for the pain.

Thanks. (I can delete these messages after we get through this..)
Happily using a heavily modified 1.1.16 version of SMF!

2748011 Posts in 320998 Topics by 50986 Members


SOLD my website - thanks it was a good run - they converted to vbadvanced. (and screwed it up good!)

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #497 on: July 26, 2011, 06:30:33 PM »
You must have the wrong ip range in your bypass protection settings.  Read this post.
 :'(
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Alex' Manson

  • Full Member
  • ***
  • Posts: 506
  • Gender: Male
  • dead and gone!
    • Sisko Hosting - FREE|PAID Hosting
Re: Forum Firewall
« Reply #498 on: July 26, 2011, 08:18:22 PM »
is this normal:
GET /welcome-messages/welcome-adam-!/ HTTP/1.1 Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)   Hack: Disallowed characters!

?

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #499 on: July 26, 2011, 08:26:48 PM »
You may want to add "!" to your "Permitted URI Characters" since you like !.  Try something like "a-z 0-9~%$,.:;&#!?/+=_\-".  Humm... You may have to adjust.  I am not the best with regular expressions...
 :-X
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.