• Welcome to Simple Machines Community Forum. Please login or sign up.

PHP 4.4.0 Compatibility

Started by Ben_S, July 13, 2005, 07:50:22 AM

Previous topic - Next topic

JayBachatero

Well first besides the Dev team.  W/O them SMF wouldn't be what it is today.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Owdy

Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

JayBachatero

I'm not sir :P  Just forgot my smiley. :P:)
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

thugpolice

Just wanted to thank everyone for the posts on this subject. I was receiving:

Notice: Only variables should be assigned by reference in /home/###/public_html/Sources/Subs.php on line 232

Notice: Undefined index: is_admin in /home/###/public_html/Sources/Security.php on line 556

Notice: Undefined index: permissions in /home/###/public_html/Sources/Security.php on line 563

Warning
: in_array(): Wrong datatype for second argument in /home/###/public_html/Sources/Security.php on line 563
session_start(): Cannot send session cookie - headers already sent by (output started at /home/###/public_html/Sources/Subs.php: 232)

I could not get to the admin panel - so I downloaded and installed the Subs.php file noted in the first post. There was no &mysql_query to be found though - the "&" was already gone.

Again, thank you all.  8)

kimncris

we just got hit with this one today.  I removed the ampersand, and the forums are back but most of the avatars are missing (mine was uploaded to the forum server)

I re-uploaded the whole subs.php file above but the avatars are still mising.  Any ideas? (it's a simple thing to reupload the pictures, I'm just wondering why)

We are using 1.0.5 and the server says it is running php 4.4.1


-cris

JayBachatero

Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

kimncris

OK I uploaded that- pointed my browser to is and clicked "save settings"

which reverted my theme back to the default theme but no avatars came back.

an interesting thing happened when I clicked the red x and chose properties

I get this : "http://scgarrison.net/smf/index.php?action=dlattach;id=17;type=avatar"

however I am user "1" not 17!

I was able to just change my avatar to "link" to the currently saved file on the server (the one that was already there) but I was not even able to re-upload it to rid myself of the dreaded red X.

another thing of note is that the attached files and images are still showing up- just not the avatars.  (some of them are- but maybe those are ones hosted by us...)

thanks again for your help!!

-cris



JayBachatero

Try this
Admin > Forum Maintenance > Find and repair any errors.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

kimncris

I wish I could say that worked, but it didn't :(

It said no errors (actually it was blank)

I clicked anyway and it said  "all fixed" but still no avail

if you wanted to see for yourself it is at

http://scgarrison.net/smf/index.php      name: testmember  password: password

the avatar is a red x for this member right now....


thanks again

-cris

JayBachatero

when i go to http://scgarrison.net/smf/index.php?action=dlattach;id=88;type=avatar  it says attachment not found.  Not sure what to tell you.  Is this for all the memebrs or just thisone?
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

kimncris

November 22, 2005, 11:32:13 PM #150 Last Edit: November 23, 2005, 12:23:01 AM by kimncris
some members are showing up- some are red Xs.

Mine for instance was a red x

and so was the test member.  I think all of the hosted ones lost thier associations.  The thing is- even if they were erased, which I doubt, you should still be able to upload a new one which I was still not able to do...

I'll keep playing with it.  I swear the only file I touched was subs.php in sources!!

-cris

edit:  yep if I go to manage attachments in admin, all of the regular attachments are there, but if I go to avatars- even though it lists them all, if you click them you get file not found etc.  I checked the forum settings and it is still set to allow avatar uploads.  I cannot figure out what has changed. One minute all good- the next- Php4.4.0 errors galore followed by this after sources/subs.php was replaced...



worm5252

Jay what about checking the attachments folder through ftp to see if the attachment files are indeed there. If not what about uploading test images into that directory and renameing them to match the files names he has in the list as a temporary fix to allow people to edit their profiles and upload a new one again>

redone

Check via ftp that the images are indeed there and that permissions are correctly set. Experiment with your admin account also to track the issues with avatars.


kimncris

November 23, 2005, 12:58:27 PM #153 Last Edit: November 23, 2005, 01:00:09 PM by kimncris
thanks for the suggestions

this is what is in my attachments folder right now as far as avatars go:

avatar_1.jpg 18 k 0644
avatar_1.png 10 k 0644
avatar_10.jpg 11 k 0644
avatar_100.png 7 k 0644
avatar_106.png 10 k 0644
avatar_12.png 7 k 0644
avatar_13.png 9 k 0644
avatar_14.png 5 k 0644
avatar_16.png 8 k 0644
avatar_18.png 9 k 0644
avatar_19.gif 4 k 0644
avatar_2.jpg 18 k 0644
avatar_2.png 10 k 0644
avatar_20.png 9 k 0644
avatar_27.png 9 k 0644
avatar_28.png 7 k 0644
avatar_3.png 8 k 0644
avatar_30.jpg 6 k 0644
avatar_31.png 8 k 0644
avatar_33.jpg 1 k 0644
avatar_35.png 7 k 0644
avatar_37.png 9 k 0644
avatar_39.png 7 k 0644
avatar_50.png 9 k 0644
avatar_52.png 12 k 0644
avatar_55.png 8 k 0644
avatar_60.png 8 k 0644
avatar_62.png 6 k 0644
avatar_69.jpg 16 k 0644
avatar_69.png 5 k 0644
avatar_75.png 7 k 0644
avatar_76.png 8 k 0644
avatar_79.png 8 k 0644
avatar_83.png 7 k 0644
avatar_88.png 7 k 0644
avatar_9.png 8 k 0644
avatar_92.png 8 k 0644
index.php 0 k 0755


if you click them in  Cpanel you can see that the files are still there also.


the avatar I tried to upload to the testmember account is showing as

"http://scgarrison.net/smf/index.php?action=dlattach;id=90;type=avatar" when I right-click the "red x" properties but that member is actually ID = 2

as you can see, it DID upload the file correctly- avatar_2 is in the list and is the one I uploaded- but it is not linking correctly (I assume).

unfortunately (or fortunately for member 90) renaming the file avatar_90.png does not get it to show up for the testmember either.



I don't know if I said yet or not, but I CAN manually set the avatars to link to the files already on the server, but ever since I changed the &mysql to mysql in subs.php all of the avatars hosted in the attachments folder turned to red x's in the forum display.  And since we are now on php4.4.1 I can't even switch it back to the original file for testing.  I'm completely at a loss....



thanks again for the ideas!

-cris

watchman23

Hello, i'm a new member here and could really use some help in getting the new PHP installed and SMF 1.0.5.

My website is www.nwowatcher.com . About 3 days ago, the Forums stopped working, but everything else is still running. >:(

We work through the Lunar server, and have been on it for the past 2 years, and with the SMF for the past year. Anyway, long story short, i have been responsible for the billing at Nwowatcher for the past year, and was not the one keeping tabs on the SMF information. The person who installed the SMF has 'gone missing' for the past 4 months, and i recieved no notification that i would have to upgrade the PHP in order for our forums to continue running..

Lunar told me to download the newest version, as well as winzip from www.downloads.com, (which i have done) and i have access to the C-Panel for nwowatcher.com, but have no clue how to get this latest version installed, and finally get our forums working properly again..

Any help would be GREATLY appreciated as soon as possible..

Thanks in advance for any technical assistance that can get this problem taken care of..

Peace
Mike
--------------------------
--------------------------

Here is what comes up for our forums now:

Notice: Only variables should be assigned by reference in /home/nwowat2/public_html/smf/Sources/Subs.php on line 232

Notice: Undefined index: is_admin in /home/nwowat2/public_html/smf/Sources/Security.php on line 556

Notice: Undefined index: permissions in /home/nwowat2/public_html/smf/Sources/Security.php on line 563

Warning: in_array(): Wrong datatype for second argument in /home/nwowat2/public_html/smf/Sources/Security.php on line 563
session_start(): Cannot send session cache limiter - headers already sent (output started at /home/nwowat2/public_html/smf/Sources/Subs.php:232)
Notice: Only variables should be assigned by reference in /home/nwowat2/public_html/smf/Sources/Subs.php on line 232

kimncris

I am on lunar pages too.  Just uploading the newest subs.php was the fix for us- however as you can see above, for some unknown reason our uploaded avatars no longer display.  I'd be curious to see if yours come back since you are on the same host as us...


-cris

watchman23

Hey Kimncris, Lunar mentioned the same thing to me, but due to my computer illiteracy, i'm not quiet sure how to go about this..

Lunar Said
QuoteOne of their quick easy solutions mentioned is to remove the &  (ampersand)
from the following code in  /Sources/Subs.php

= &mysql_query

I have access to the C-panel for the site, but haven't been responsible for the more technical aspects. I've been trying to take care of all the other things needed to keep the site active (such as making the payments..:P )

Any advice on how to upload the newest subs/php ? ::)

kimncris

the easiest way is to go to cpanel file manager and then go to "your smf direcctory"/sources and edit the subs.php file to remove the above mentioned "&"

but you could also just download the new subs.php in the first post of this thread and upload it to your site on top of the existing one in the folder called sources.

I'd make a backup of the current one before you do either, just in case....


ck

JayBachatero

@watchman23 open up Subs.php and look for = &mysql_query and replace with = mysql_query.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

StarWars Fan

Quote from: kimncris on November 23, 2005, 09:51:46 PM
the easiest way is to go to cpanel file manager

Would highly recommend not using CPanel's editor for editing SMF files...

Advertisement: