Advertisement:

Author Topic: PHP 4.4.0 Compatibility  (Read 177393 times)

Offline deebee

  • Semi-Newbie
  • *
  • Posts: 17
Re: PHP 4.4.0 Compatibility
« Reply #20 on: July 17, 2005, 07:52:45 AM »
I have SMF 1.0.4 and my server has just been upgraded to php 4.4.0. Tried deleting the '&' in subs.php but this hasn't fixed the problem. Also, I can't even access the board admin to upgrade to 1.0.5.

Any suggestions?

David.

Offline Grudge

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,742
  • Gender: Male
  • Unofficial nuisance
Re: PHP 4.4.0 Compatibility
« Reply #21 on: July 17, 2005, 08:01:15 AM »
deebee,

Can you post a topic in the support forum? Can you detail in it in what way your forum isn't working (i.e. what do you see when you go into it)

Thanks,

Grudge
I'm only a half geek really...

Offline deebee

  • Semi-Newbie
  • *
  • Posts: 17
Re: PHP 4.4.0 Compatibility
« Reply #22 on: July 17, 2005, 08:37:51 AM »
Hi Grudge,

Have already posted in the thread that suggested the amperasand fix in subs.php. I can't access any aspect of the board - when I try, I get this error message

"Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later." Host tells me the server is fine and running OK.

There is just one mod on the board - Mambo-SMF bridge from Mambohacks. Problem is I can't even access the admin side of the board to remove this mod before upgrading to 1.0.5.

Offline Grudge

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,742
  • Gender: Male
  • Unofficial nuisance
Re: PHP 4.4.0 Compatibility
« Reply #23 on: July 17, 2005, 11:34:01 AM »
deebee,

I don't think that's related to the fix actually - it sounds like SMF can't find your database - can you verify the database is up by using phpMyAdmin - and if it is check the settings in Settings.php are correct...
I'm only a half geek really...

Offline deebee

  • Semi-Newbie
  • *
  • Posts: 17
Re: PHP 4.4.0 Compatibility
« Reply #24 on: July 17, 2005, 01:05:07 PM »
grudge,

I can access the database with phpmyadmin OK. I have, as recommended in another post, replaced the settings.php and settings.bak files with the orginal files from the initial 1.0.4 download. However, I still get this connection error.

A post on the support forum suggested upgrading to 1.0.5. Have just done a full backup prior to trying this but am a little nervous because...

[a] the updater to 1.0.5 suggested that it can't be used if there mods in place (I have one, Mambo-SMF) and

does the upgrader work on 1.04 to 1.0.5

What settings in settings.php should I be looking for?

Offline deebee

  • Semi-Newbie
  • *
  • Posts: 17
Re: PHP 4.4.0 Compatibility
« Reply #25 on: July 17, 2005, 01:24:20 PM »
Sorry, forget the last post. I've just adjusted the setting in settings.php & I'm back in the board now.
Thx for your help  :)

Offline Champi

  • Jr. Member
  • **
  • Posts: 108
  • Gender: Male
  • Woef!
    • Champi Dog Blog
Re: PHP 4.4.0 Compatibility
« Reply #26 on: July 17, 2005, 02:46:22 PM »
hi guys,

i installed the patch trough the package manager.. is that enough.. or do i have to make some other modifications too.

greetz.. thnx in forward

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: PHP 4.4.0 Compatibility
« Reply #27 on: July 17, 2005, 02:47:15 PM »
hi guys,

i installed the patch trough the package manager.. is that enough.. or do i have to make some other modifications too.

greetz.. thnx in forward

That 'll do fine.  ;)
"Insanity: doing the same thing over and over again and expecting different results."

Offline Champi

  • Jr. Member
  • **
  • Posts: 108
  • Gender: Male
  • Woef!
    • Champi Dog Blog
Re: PHP 4.4.0 Compatibility
« Reply #28 on: July 17, 2005, 02:48:57 PM »
Dank je wel... Thnx for the quick reply..  :D

Offline permutations

  • Jr. Member
  • **
  • Posts: 320
Re: PHP 4.4.0 Compatibility
« Reply #29 on: July 17, 2005, 06:26:06 PM »
FYI.... The package worked on one of my sites, but failed on another. The site it worked on originally had 1.0.3 installed, later upgraded to 1.0.5. The site it failed on was originally running YaBB-SE, and I upgraded that to 1.0.5. When I looked inside Subs.php on the formerly-YaBB-SE site, I saw that it didn't have the ampersand before the mysql_query call in the first place.

So you might want to tweak your package a little to exclude SMF sites that were upgraded from YaBB-SE. This site had no mods installed and I wasn't hacking files there, so the ampersand  wasn't missing due to anything I did.

Offline Grudge

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,742
  • Gender: Male
  • Unofficial nuisance
Re: PHP 4.4.0 Compatibility
« Reply #30 on: July 17, 2005, 06:27:12 PM »
permutations,

Be aware that the 1.0.5 packages on the download page have already had the fix installed - so if you upgraded recently that would be why it didn't work.
I'm only a half geek really...

Offline permutations

  • Jr. Member
  • **
  • Posts: 320
Re: PHP 4.4.0 Compatibility
« Reply #31 on: July 17, 2005, 06:43:20 PM »
That's probably it. I downloaded the upgrade package just the other day.

I wonder if there's a way the package manager can respond to this condition in a less frightening way than "failure" (in boldface red). It didn't scare me, but it might scare someone who didn't know how to look in Subs.php and see what failed.

(And OH WOW - someone fixed a problem in the editor that has been driving me crazy for many versions! I can highlight "failure" and click "bold" then "red" without having to re-reselect the word.)

Here's a little nit I noticed (since discovering the free version of XML Spy yesterday):

The package.xml file has the <type> tag after the <version> tag. This doesn't affect functionality, but it differs from what the schema says, so XML Spy complains.

Offline iman_ebru

  • Semi-Newbie
  • *
  • Posts: 50
  • Gender: Male
  • iman_ebru
    • Hugges. | Iman Usefzadeh's Weblog
Re: PHP 4.4.0 Compatibility
« Reply #32 on: July 17, 2005, 06:46:51 PM »
 everything works well  :)

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #33 on: July 17, 2005, 06:53:40 PM »
I wonder if there's a way the package manager can respond to this condition in a less frightening way than "failure" (in boldface red). It didn't scare me, but it might scare someone who didn't know how to look in Subs.php and see what failed.

Too many people ignore it.  The wording has been replaced with "Test failed" in 1.1 because people did not often realize that was what it meant.

Quote
(And OH WOW - someone fixed a problem in the editor that has been driving me crazy for many versions! I can highlight "failure" and click "bold" then "red" without having to re-reselect the word.)

Yes, this has changed in 1.1; Internet Explorer and Firefox both highlight properly.  Safari and Opera still do not.

Quote
The package.xml file has the <type> tag after the <version> tag. This doesn't affect functionality, but it differs from what the schema says, so XML Spy complains.

Odd - I don't believe the order is supposed to matter in the slightest.

-[Unknown]

Offline NBK

  • Newbie
  • *
  • Posts: 5
Re: PHP 4.4.0 Compatibility
« Reply #34 on: July 17, 2005, 07:16:51 PM »
I'm not sure that I still have al package servers in the list on my site. I can't find the any of the update packages. What is the URL of the server where the packages are located on? Maybe I deleted something :o
« Last Edit: July 17, 2005, 07:22:10 PM by NBK »

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #35 on: July 17, 2005, 07:21:25 PM »
I'm not sure that I still have al package servers in the list on my site. I never have been able to find any of the packages. What is the URL of the server where the packages are located on? Maybe I deleted something :o

The package for this is not on any package server.  Look at the "Browse Packages" page of your package manager and peel your eyes open.

-[Unknown]

Offline NBK

  • Newbie
  • *
  • Posts: 5
Re: PHP 4.4.0 Compatibility
« Reply #36 on: July 17, 2005, 07:24:14 PM »
LOL, it's hard to find something when you keep looking in the wrong place :-X

Offline sancho

  • Newbie
  • *
  • Posts: 6
Re: PHP 4.4.0 Compatibility
« Reply #37 on: July 17, 2005, 08:00:05 PM »
And if one is running 1.0.5 and PHP 4.3.11 is there any conflict?  Or is this where the in case scenario applies? Thanks/

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #38 on: July 17, 2005, 08:01:54 PM »
No, there's no conflict.  Even if you are running SMF 1.0 Beta 4 Public, you can apply this patch - and should, even on PHP 4.2.0 (although it won't make a bit of difference, until your host upgrades.)

-[Unknown]

Offline sancho

  • Newbie
  • *
  • Posts: 6
Re: PHP 4.4.0 Compatibility
« Reply #39 on: July 17, 2005, 08:14:56 PM »
Okay which file archive do I download? I downloaded smf 1.0.5 update zip on July 11 and this one has the same name for July 13.  Thanks