Advertisement:

Author Topic: PHP 4.4.0 Compatibility  (Read 185534 times)

Offline DefTol

  • Semi-Newbie
  • *
  • Posts: 41
Re: PHP 4.4.0 Compatibility
« Reply #60 on: July 21, 2005, 03:12:12 AM »
Hello...Just wondering,is this the part that was to have the ampersand removed,and if so is this the only place that it is located?

Code: [Select]
$ret = mysql_query($db_string, $db_connection);
if ($ret === false)
$ret = db_error($db_string, $file, $line);

Offline Meriadoc

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,263
  • Gender: Male
  • For the world is changing
    • Philip Renich: Websites
Re: PHP 4.4.0 Compatibility
« Reply #61 on: July 21, 2005, 04:41:09 AM »
yes, there was only one place to remove it from, and that was it :)
If I know the way home and am walking along it drunkenly, is it any less the right way because I am staggering from side to side? : Leo Tolstoy
Everything I know I learned from Calvin and Hobbes.
And patience is about the most useful thing you could ever have.  That and backups. : [Unknown]
If I choose to send thee, Tuor son of Huor, then believe not that thy one sword is not worth the sending. : Ulmo, Lord of the Waters - Unfinished Tales, by J.R.R. Tolkien

Offline MrWoof

  • Semi-Newbie
  • *
  • Posts: 30
  • Gender: Male
    • Reality HQ
Re: PHP 4.4.0 Compatibility
« Reply #62 on: July 21, 2005, 12:46:46 PM »
that was a sweet and simple update. i just got the message today about subs.php, found this and voila! :D
Are you a reality tv fan? Visit Reality HQ today to get your latest dose!

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #63 on: August 05, 2005, 09:00:57 AM »
Please post a link to your forum.

-[Unknown]

Offline Mark_Breznay

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
    • SundayNiagara
Re: PHP 4.4.0 Compatibility
« Reply #64 on: August 07, 2005, 01:29:09 PM »
I have v 1.0.5 installed.  Do I need this php upgrade?  If so, where do I find the upgrade files?
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: PHP 4.4.0 Compatibility
« Reply #65 on: August 07, 2005, 01:38:51 PM »
I have v 1.0.5 installed.  Do I need this php upgrade?  If so, where do I find the upgrade files?
Mark

Yes, it would be wiser to update just incase your host decides to change the php-version. Have you read the first post of this topic? It describes three different ways of how you can update.
"Insanity: doing the same thing over and over again and expecting different results."

Offline dtm.exe

  • SMF Hero
  • ******
  • Posts: 5,465
Re: PHP 4.4.0 Compatibility
« Reply #66 on: August 07, 2005, 01:38:54 PM »
I have v 1.0.5 installed.  Do I need this php upgrade?  If so, where do I find the upgrade files?
Mark

PHP 4.4.0 is not required to run SMF 1.0.5.  This is merely a fix to make SMF 1.0.5 compatible with this new version of PHP.

-Dan The Man

Offline Mark_Breznay

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
    • SundayNiagara
Re: PHP 4.4.0 Compatibility
« Reply #67 on: August 07, 2005, 03:16:12 PM »
My Package Manager doesn't work.  I don't have any mods.  Please SPECIFY which one I should use.  I don't like multiple choice.
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: PHP 4.4.0 Compatibility
« Reply #68 on: August 07, 2005, 04:11:26 PM »
My Package Manager doesn't work.  I don't have any mods.  Please SPECIFY which one I should use.  I don't like multiple choice.
Mark

Just upload the attached Subs.php to your Sourcesdirectory.
"Insanity: doing the same thing over and over again and expecting different results."

Offline Mark_Breznay

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
    • SundayNiagara
Re: PHP 4.4.0 Compatibility
« Reply #69 on: August 07, 2005, 04:32:41 PM »
???????????????
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

Offline dtm.exe

  • SMF Hero
  • ******
  • Posts: 5,465
Re: PHP 4.4.0 Compatibility
« Reply #70 on: August 07, 2005, 04:35:35 PM »
???????????????

Would you like for me to do it for you?  I understand how some people aren't the best with computers and the internet (like my mom :P).  Please PM or IM me if I can assist you with the upgrade.

-Dan The Man

Offline Mark_Breznay

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
    • SundayNiagara
Re: PHP 4.4.0 Compatibility
« Reply #71 on: August 07, 2005, 04:53:03 PM »
Just upload the attached Subs.php to your Sourcesdirectory.

This is what confused me.  To me, it indicated that this person had attached a file to his message.  I went back to the start of the thread and found the file.  It is now uploaded and all, hopefully, is well.  Thanks.
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

Offline tdv

  • Newbie
  • *
  • Posts: 2
Re: PHP 4.4.0 Compatibility
« Reply #72 on: August 09, 2005, 04:27:16 AM »
When I remore the '&', I got the following message:
Quote
Notice: Undefined index: is_admin in /home/davidh05/public_html/smf/Sources/Security.php on line 556

Notice: Undefined index: permissions in /home/davidh05/public_html/smf/Sources/Security.php on line 563

Warning: in_array(): Wrong datatype for second argument in /home/davidh05/public_html/smf/Sources/Security.php on line 563
session_start(): Cannot send session cache limiter - headers already sent (output started at /home/davidh05/public_html/smf/Sources/Subs.php:1890)
What I should do to get my board back?

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: PHP 4.4.0 Compatibility
« Reply #73 on: August 09, 2005, 05:38:25 AM »
Which version of SMF are you using? Try uploading the attached Subs.php from the first post of this thread. You'll need to install some mods again.
"Insanity: doing the same thing over and over again and expecting different results."

Offline tdv

  • Newbie
  • *
  • Posts: 2
Re: PHP 4.4.0 Compatibility
« Reply #74 on: August 09, 2005, 06:46:21 AM »
I uploaded the Sub.php, and got my boards back, thanks. ;)

Offline SMAguy

  • Semi-Newbie
  • *
  • Posts: 36
Re: PHP 4.4.0 Compatibility
« Reply #75 on: August 18, 2005, 06:18:25 PM »
Well, I have precisely the same problem as tdv but uploading the new Sub.php DIDN'T affect anything. I have SMF 1.04 and various mods.

Any ideas?

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #76 on: August 18, 2005, 06:22:41 PM »
Upload all of the files from the upgrade zip file on the downloads page and reinstall your mods.

-[Unknown]

Offline SMAguy

  • Semi-Newbie
  • *
  • Posts: 36
Re: PHP 4.4.0 Compatibility
« Reply #77 on: August 19, 2005, 01:17:19 AM »
Actually, having initially sent a trouble ticket to my hosting service, I received a reply in the interim from an engineer with them (they had just upgraded to PHP 4.4) and he examined the Sub.php and noticed an extra blank line that was somehow causing the problem!

I'm pretty impressed with that service (Site 5), I must say .


Offline Herman's Mixen

  • SMF Hero
  • ******
  • Posts: 7,233
    • HermanMixen on Facebook
    • @Hermans_Mixen on Twitter
    • Herman's Mixen
Re: PHP 4.4.0 Compatibility
« Reply #78 on: August 20, 2005, 07:04:11 PM »
oke ... but host upgraded to php 4.4.0 so why isn't SSI.php work correctly now
with SMF 1.0.5 installed it worked great with 4.3.xx of php version
???

Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

Offline xtremecruiser

  • Jr. Member
  • **
  • Posts: 375
    • GolfDiscussions.com
Re: PHP 4.4.0 Compatibility
« Reply #79 on: August 20, 2005, 09:37:09 PM »
Ok stupid Question.
My host went to 4.4.0 and I did the update and it was fine.  They changed back to 4.3.1 :o will that cuase issues ?
Thanks