Advertisement:

Author Topic: PHP 4.4.0 Compatibility  (Read 186053 times)

Offline codenaught

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,653
  • Gender: Male
  • Formerly Known As akabugeyes
Re: PHP 4.4.0 Compatibility
« Reply #80 on: August 20, 2005, 11:06:05 PM »
Ok stupid Question.
My host went to 4.4.0 and I did the update and it was fine.  They changed back to 4.3.1 :o will that cuase issues ?
Thanks
It should work fine doing the changes even if you are on PHP 4.3.
Dev Consultant
Former SMF Doc Coordinator

Offline m0to

  • Newbie
  • *
  • Posts: 6
  • Gender: Male
  • She is fit!
    • KrypticX
Re: PHP 4.4.0 Compatibility
« Reply #81 on: August 22, 2005, 01:37:11 PM »
i cannot find the = &mysql_query....any ideas?
hxxp:www.krypticx.com [nonactive]

Offline Compuart

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,774
  • Gender: Male
  • Zéeeeal
    • RealityNet
Re: PHP 4.4.0 Compatibility
« Reply #82 on: August 22, 2005, 02:24:40 PM »
i cannot find the = &mysql_query....any ideas?
The link in your signature points to an SMF 1.1 forum, which isn't affected at all by this compatibility problem. The same goes for the current 1.0.5 on the download page.
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

Offline m0to

  • Newbie
  • *
  • Posts: 6
  • Gender: Male
  • She is fit!
    • KrypticX
Re: PHP 4.4.0 Compatibility
« Reply #83 on: August 22, 2005, 02:53:41 PM »
oh im sorry i forgot to mention it is my friends that is messing up. he is upgrading to 1.0.5 and he says he cannot find the & thingy can you help?
hxxp:www.krypticx.com [nonactive]

Offline Meriadoc

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,263
  • Gender: Male
  • For the world is changing
    • Philip Renich: Websites
Re: PHP 4.4.0 Compatibility
« Reply #84 on: August 22, 2005, 04:03:57 PM »
1.0.5 on our downloads page contains the fix already, so it seems that when your friend upgraded, he uploaded a fixed copy of Subs.php.
If I know the way home and am walking along it drunkenly, is it any less the right way because I am staggering from side to side? : Leo Tolstoy
Everything I know I learned from Calvin and Hobbes.
And patience is about the most useful thing you could ever have.  That and backups. : [Unknown]
If I choose to send thee, Tuor son of Huor, then believe not that thy one sword is not worth the sending. : Ulmo, Lord of the Waters - Unfinished Tales, by J.R.R. Tolkien

Offline newbe

  • Newbie
  • *
  • Posts: 4
Re: PHP 4.4.0 Compatibility
« Reply #85 on: August 30, 2005, 05:23:43 PM »
Please help, I just moved to a new server.  Everything was working fine on the old server.  When I did the move, I know get this error msg.  I already had installed the update on the old server.  But it left the & in the subs file.  When I manually delete it, the site does not come up at all.  Just a blank screen, no errors, nothing.  Any idea.

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #86 on: August 30, 2005, 05:27:51 PM »
Please help, I just moved to a new server.  Everything was working fine on the old server.  When I did the move, I know get this error msg.  I already had installed the update on the old server.  But it left the & in the subs file.  When I manually delete it, the site does not come up at all.  Just a blank screen, no errors, nothing.  Any idea.

What text editor are you using?  Have you tried doing it with just Notepad?

-[Unknown]

Offline newbe

  • Newbie
  • *
  • Posts: 4
Re: PHP 4.4.0 Compatibility
« Reply #87 on: August 30, 2005, 05:32:20 PM »
yes. first I used dreamweaver.  Then I started over using notepad.  Both do the same thing.  If I return to the backup version the site comes back up, but so does the error.

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #88 on: August 30, 2005, 06:07:53 PM »
Are you uploading it using Dreamweaver?  Dreamweaver is known to mess up PHP files (like Subs.php.)

-[Unknown]

Offline newbe

  • Newbie
  • *
  • Posts: 4
Re: PHP 4.4.0 Compatibility
« Reply #89 on: August 30, 2005, 06:12:42 PM »
No, I am using cuteftp

Offline newbe

  • Newbie
  • *
  • Posts: 4
Re: PHP 4.4.0 Compatibility
« Reply #90 on: August 30, 2005, 06:31:11 PM »
Thank you for your help.  I tried editing the file directly on the server.  This solved the problem.  For now.  I hope...

Offline Aaron

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,711
  • Gender: Male
    • Aaronweb.net
Re: PHP 4.4.0 Compatibility
« Reply #91 on: August 31, 2005, 12:47:49 PM »
Download the 1.0.5 package from the downloadpage and extract Subs.php from it. Then upload that file. Solved?

Offline Dannii

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,212
  • Mind the volcano!
    • curiousdannii on GitHub
Re: PHP 4.4.0 Compatibility
« Reply #92 on: September 04, 2005, 08:51:32 AM »
that's a whole lot of work for removing only 1 letter. Use the package manager if you can, or else just edit the file directly.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Offline Elmacik

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,280
  • Gender: Male
  • = Human Draft =
    • IT Store
Re: PHP 4.4.0 Compatibility
« Reply #93 on: September 14, 2005, 04:05:36 PM »
my php version is 4.4.0 but got no errors about it till now..
Home of Elmacik

Offline nobodyhere

  • Newbie
  • *
  • Posts: 2
Re: PHP 4.4.0 Compatibility
« Reply #94 on: September 15, 2005, 10:36:39 PM »
SMF 1.1 Beta 3 Public spellcheck.js error?

SMF 1.05 upgraded to SMF 1.1 Beta 3 Public.
Spell check is enabled and working on my server.
php version to 4.4.0.

Click the Spell Check button and this error is displayed in a dialog box.

Problems with this Web page might prevent it from being displayed properly
or functioning properly. In the future, you can display this message .... etc.

Line: 9
Char: 2
Error: 'spell_formname' is null or not an object
Code: 0
URL: hxxp:domainname.com/testforum/index.php?action=post;board=1.0 [nonactive]

Did i do the upgrade wrong some how?
Is this a problem in spellcheck.js or somewhere else?
Any idea how to fix this?

I did search the board here and found nothing about this.
Did i miss it some how? Point me the right direction please?

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #95 on: September 15, 2005, 10:57:31 PM »
That has nothing to do with PHP 4.4.0, or if it does no one else has had the problem.

-[Unknown]

Offline M@D-M@X

  • Jr. Member
  • **
  • Posts: 140
Re: PHP 4.4.0 Compatibility
« Reply #96 on: September 19, 2005, 08:08:38 PM »
I load from the pages upgrade package (http://www.simplemachines.org/download.php/smf_1-0-5_upgrade.zip) and I drove its to the server but fault didn't repair.

Where is fault? in the forum is a few mod eg. bannermod and old warning mod which didn't operate (so sight) admin panel. Forum version is 0.5

Look http://www.newface2005.net/smf


Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #97 on: September 19, 2005, 08:56:11 PM »
Your problem is a mod installed in the theme you're using.

Please start new topics for new requests, and we'll help you there.

-[Unknown]

Offline Owdy

  • SMF Fossil
  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,627
  • Gender: Male
  • W00t!
    • janoloferiksson on LinkedIn
    • @@jaoler on Twitter
Re: PHP 4.4.0 Compatibility
« Reply #98 on: September 20, 2005, 02:26:50 AM »
Her problem started with this:

Notice: Only variables should be assigned by reference in /home/newface2/public_html/smf/Sources/Subs.php on line 232

Notice: Undefined index: is_admin in /home/newface2/public_html/smf/Sources/Security.php on line 556

Notice: Undefined index: permissions in /home/newface2/public_html/smf/Sources/Security.php on line 563

Warning: in_array(): Wrong datatype for second argument in /home/newface2/public_html/smf/Sources/Security.php on line 563
session_start(): Cannot send session cache limiter - headers already sent (output started at /home/newface2/public_html/smf/Sources/Subs.php:232)
Notice: Only variables should be assigned by reference in /home/newface2/public_html/smf/Sources/Subs.php on line 232


But its all fixed now.
Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

Offline skyhigh007

  • Semi-Newbie
  • *
  • Posts: 27
Re: PHP 4.4.0 Compatibility
« Reply #99 on: October 26, 2005, 07:32:23 PM »
My hosting company uses, PHP 4.3.11 and i download the smf 1.0.5.    and i got a  "Fatal error: Call to undefined function: db_error() in /home/placeto/public_html/forum/Sources/Subs.php on line 234"

The code for the line 234

$ret = mysql_query($db_string, $db_connection);
   if ($ret === false)
      $ret = db_error($db_string, $file, $line);   <------234

What should i do ?