Advertisement:

Author Topic: PHP 4.4.0 Compatibility  (Read 177769 times)

Offline Krysia

  • Jr. Member
  • **
  • Posts: 377
  • Gender: Female
    • KRYSIA'S WEB
Re: PHP 4.4.0 Compatibility
« Reply #40 on: July 17, 2005, 09:00:22 PM »
I get the following alert when I tried to install via the Package Manager:

Quote
An Error Has Occurred!
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

I have SMF 1.0.5 installed. Could this be because my server may have already updated the PHP thing, or is it the file?
Thank you... :)



Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #41 on: July 17, 2005, 09:45:20 PM »
You'll have to download the package from the first post and upload it to your Packages folder manually.

-[Unknown]

Offline Mark_Breznay

  • Jr. Member
  • **
  • Posts: 269
  • Gender: Male
    • SundayNiagara
Re: PHP 4.4.0 Compatibility
« Reply #42 on: July 17, 2005, 09:50:15 PM »
I get this:

 You cannot download or install new packages because the Packages directory is not writable!

Does this mean it is already installed/
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

Offline sancho

  • Newbie
  • *
  • Posts: 6
Re: PHP 4.4.0 Compatibility
« Reply #43 on: July 17, 2005, 09:53:29 PM »
It's just the subs.php file right? 

Offline Krysia

  • Jr. Member
  • **
  • Posts: 377
  • Gender: Female
    • KRYSIA'S WEB
Re: PHP 4.4.0 Compatibility
« Reply #44 on: July 17, 2005, 11:40:05 PM »
You'll have to download the package from the first post and upload it to your Packages folder manually.

-[Unknown]
Oh, darn. I knew it was going to be something like that. :-\
LOL...
<off to download>



Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: PHP 4.4.0 Compatibility
« Reply #45 on: July 17, 2005, 11:41:26 PM »
You'll have to download the package from the first post and upload it to your Packages folder manually.

-[Unknown]
Oh, darn. I knew it was going to be something like that. :-\
LOL...
<off to download>

Have you read the first post? This is a minor change, you can either make the change yourself in Subs.php or just upload the file attached in the first post.
"Insanity: doing the same thing over and over again and expecting different results."

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #46 on: July 18, 2005, 01:18:04 AM »
I get this:

 You cannot download or install new packages because the Packages directory is not writable!

Does this mean it is already installed/
Mark

No, it means either your Packages directory is not writable, or something else is wrong.  Please try doing it manually.

-[Unknown]

Offline colorjaws

  • Newbie
  • *
  • Posts: 2
Re: PHP 4.4.0 Compatibility
« Reply #47 on: July 18, 2005, 03:08:41 AM »
heu I removed the & but that is the message i am getting know??? what do I have to do to get it back on track?

Quote
Parse error: ""/Subs.php on line 1515

Notice: Undefined index: ""s/Sources/Security.php on line 556

Notice: Undefined index: permissions in""s/Sources/Security.php on line 563

Warning: in_array(): Wrong datatype for second argument in ""htdocs/Sources/Security.php on line 563
session_start(): Cannot send session cache limiter - headers already sent (output started at ""Subs.php:1515)
 
« Last Edit: July 18, 2005, 03:18:27 AM by colorjaws »

Offline happyb8888

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Female
  • That Happy Chica
Re: PHP 4.4.0 Compatibility
« Reply #48 on: July 18, 2005, 03:12:25 AM »
Three days ago, if you tried to get on my site you received a message saying the database couldn't be located.
Tonight I received your message about upgrade 1.05

Okay, I downloaded upgrade 1.05 and installed all the files.  When I try to go to the upgrade screen I get a message saying it can't be found.  It's there... in my www.mysite.com/forum (my real site not mysite) but it won't respond by opening when I address to it.  Am I doing something wrong??

I checked the Sub.php file and the ampersand isn't there.  But when I do the forum/index.php it still tells me the database can't be located.  Is this an ISP problem now??
« Last Edit: July 18, 2005, 03:41:51 AM by happyb8888 »
That Happy Chica,
Marcia Ellen

Offline colorjaws

  • Newbie
  • *
  • Posts: 2
Re: PHP 4.4.0 Compatibility
« Reply #49 on: July 18, 2005, 03:19:08 AM »
Ok I got the problem out and everyting is working fine know  8)

Offline Meriadoc

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,263
  • Gender: Male
  • For the world is changing
    • Philip Renich: Websites
Re: PHP 4.4.0 Compatibility
« Reply #50 on: July 18, 2005, 06:11:00 AM »
Three days ago, if you tried to get on my site you received a message saying the database couldn't be located.
Tonight I received your message about upgrade 1.05

Okay, I downloaded upgrade 1.05 and installed all the files.  When I try to go to the upgrade screen I get a message saying it can't be found.  It's there... in my www.mysite.com/forum (my real site not mysite) but it won't respond by opening when I address to it.  Am I doing something wrong??

I checked the Sub.php file and the ampersand isn't there.  But when I do the forum/index.php it still tells me the database can't be located.  Is this an ISP problem now??
Happy - could you post the actual error message you are receiving please?
Sounds like your Settings.php file doesn't have the right info to find your database. You could try repair_settings.php - What is repair_settings.php?
If I know the way home and am walking along it drunkenly, is it any less the right way because I am staggering from side to side? : Leo Tolstoy
Everything I know I learned from Calvin and Hobbes.
And patience is about the most useful thing you could ever have.  That and backups. : [Unknown]
If I choose to send thee, Tuor son of Huor, then believe not that thy one sword is not worth the sending. : Ulmo, Lord of the Waters - Unfinished Tales, by J.R.R. Tolkien

Offline sancho

  • Newbie
  • *
  • Posts: 6
Re: PHP 4.4.0 Compatibility
« Reply #51 on: July 18, 2005, 01:32:21 PM »
I'm a bit confused here about these directions.

Download the update archive file, and upload all of the files from it.
Download the modification file, attached to this message, and modify the files manually according to it.
Download the Subs.php file attached to this mesage, and upload it to your Sources directory (if you have no modifications installed.)
Find the following in Sources/Subs.php:


The update archive contains a number of files.  I can't find that archive.
Then there is the instruction to download the modification file and modify the files. 
Both of thse directions are in the plural and are talking of multiple files.
Then there is the option to download the subs.php which is just one file. So will my site be current if I just FTP the subs.php file or are there more files to edit or change?

Thanks

Offline bubbahs

  • Newbie
  • *
  • Posts: 3
Re: PHP 4.4.0 Compatibility
« Reply #52 on: July 18, 2005, 04:06:01 PM »
so the subs file is the the only thing that needs to be changed? Correct?

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: PHP 4.4.0 Compatibility
« Reply #53 on: July 18, 2005, 04:11:42 PM »
so the subs file is the the only thing that needs to be changed? Correct?

That is correct.
"Insanity: doing the same thing over and over again and expecting different results."

Offline Meriadoc

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,263
  • Gender: Male
  • For the world is changing
    • Philip Renich: Websites
Re: PHP 4.4.0 Compatibility
« Reply #54 on: July 18, 2005, 04:24:49 PM »
I'm a bit confused here about these directions.

Download the update archive file, and upload all of the files from it.
Download the modification file, attached to this message, and modify the files manually according to it.
Download the Subs.php file attached to this mesage, and upload it to your Sources directory (if you have no modifications installed.)
Find the following in Sources/Subs.php:


The update archive contains a number of files.  I can't find that archive.
Then there is the instruction to download the modification file and modify the files. 
Both of thse directions are in the plural and are talking of multiple files.
Then there is the option to download the subs.php which is just one file. So will my site be current if I just FTP the subs.php file or are there more files to edit or change?

Thanks

those are 4 different options you have for the patch, 4 steps of the same direction.
If I know the way home and am walking along it drunkenly, is it any less the right way because I am staggering from side to side? : Leo Tolstoy
Everything I know I learned from Calvin and Hobbes.
And patience is about the most useful thing you could ever have.  That and backups. : [Unknown]
If I choose to send thee, Tuor son of Huor, then believe not that thy one sword is not worth the sending. : Ulmo, Lord of the Waters - Unfinished Tales, by J.R.R. Tolkien

Offline happyb8888

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Female
  • That Happy Chica
Re: PHP 4.4.0 Compatibility
« Reply #55 on: July 18, 2005, 05:27:40 PM »
Happy - could you post the actual error message you are receiving please?
Sounds like your Settings.php file doesn't have the right info to find your database. You could try repair_settings.php - What is repair_settings.php?

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


That's the message I receive when I try to go to my site.  This is the message I receive when I try to load the upgrade.php file:

Page not found
The page you are looking for might have been removed,
had its name changed, or is temporarily unavailable.


I get the same message as above when trying to use the repair_settings.php .

« Last Edit: July 18, 2005, 05:37:04 PM by happyb8888 »
That Happy Chica,
Marcia Ellen

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PHP 4.4.0 Compatibility
« Reply #56 on: July 18, 2005, 06:08:08 PM »
That's the message I receive when I try to go to my site.

Have you contacted your host?  You might try to verify your connection information with repair_settings.php... What is repair_settings.php?

-[Unknown]

Offline happyb8888

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Female
  • That Happy Chica
Re: PHP 4.4.0 Compatibility
« Reply #57 on: July 19, 2005, 03:32:30 AM »

Have you contacted your host?  You might try to verify your connection information with repair_settings.php... What is repair_settings.php?

-[Unknown]

I can't get into repair_settings.php.  I get a message saying it can't find the page, even though I uploaded it to my site.
That Happy Chica,
Marcia Ellen

Offline Cynthia Blue

  • Semi-Newbie
  • *
  • Posts: 60
  • Gender: Female
    • Tip Tail
Re: PHP 4.4.0 Compatibility
« Reply #58 on: July 19, 2005, 10:04:54 AM »
Thanks for this thread! My forums were broken, and a search revealed this fix. Whew!  My forums are back now and working fine.

Offline teamvtec

  • Jr. Member
  • **
  • Posts: 110
Re: PHP 4.4.0 Compatibility
« Reply #59 on: July 19, 2005, 03:50:40 PM »
everything OK, upgrade complete  ;D