• Welcome to Simple Machines Community Forum. Please login or sign up.

Correctif de compatibilité avec PHP 4.4.0

Started by Alexandre P., July 14, 2005, 02:54:15 AM

Previous topic - Next topic

Alexandre P.

July 14, 2005, 02:54:15 AM Last Edit: July 15, 2005, 02:03:42 AM by Alexandre P.
Simple Machines vous publie aujourd'hui une mise à jour de compatibilité pour Simple Machines Forum 1.0.5.  Ce correctif concerne un problème de compatibilité avec la plus récente version de PHP, 4.4.0, qui cause le non-fonctionnement complet de SMF.

Vous pouvez très facilement mettre à jour votre forum par les façon suivantes:

  • Utilisez le Gestionnaire de paquets dans votre Centre d'administration ; un clic et hop! c'est fait
  • Téléchargez l'archive de mise à jour sur la page des téléchargements de Simple Machines et uploadez son contenu dans le dossier de votre forum
  • Téléchargez le fichier de modification, attaché à ce message, et modifiez manuellement les fichiers d'après celui-ci
  • Si vous n'avez installé aucun mod sur votre forum, téléchargez le fichier Subs.php, attaché à ce message, et uploadez-le dans le répertoire /Sources de votre forum
  • Appliquez manuellement la procédure suivante:
    Ouvrez le fichier /Sources/Subs.php.  Recherchez:
         $ret = &mysql_query($db_string, $db_connection);
    Enlevez le & ('et' commercial) dans cette ligne.  Vous pouvez modifier le fichier Subs.php avec n'importe quel éditeur de texte simple (ConText, Macromedia Dreamweaver, PHPEdit, BlueFish, le Bloc-Notes de Windows, ...)

Vous devriez installer ce correctif le plus rapidement possible si vous souhaitez utiliser le Gestionnaire de paquets, puisque votre forum deviendra inaccessible si votre hébergeur passe à PHP 4.4.0 si vous n'appliquez pas la modification, vous ne pourrez donc pas accéder au Gestionnaire de paquets.

Si vous utilisez SMF 1.1 Beta 3 Public, vous n'avez besoin de faire aucun changement.  Cette version de SMF est déjà compatible avec PHP 4.4.0.

Source: PHP 4.4.0 Compatibility, par Ben_S

Quote from: Notes supplémentairesLes archives d'installation et de mise à jour, sur la page des téléchargements de Simple Machines, ont été mises à jour aujourd'hui.  Si vous les avez téléchargés aujourd'hui ou ultérieurement, vous n'avez pas besoin d'effectuer cette correction.

Le problème concerne donc tous les forums SMF 1.0.5 (et inférieur) installés avant le 14 juillet et dont l'hébergeur passe à la version 4.4.0 de PHP.  Même si votre hébergeur ne met pas à jour immédiatement PHP, nous vous conseillons fortement d'appliquer le correctif afin d'éviter toute mauvaise surprise.
Aucun support par M.P., courriel ou messagerie instantanée / No support by P.M., email or I.M.

Advertisement: