News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Optimus

Started by Bugo, February 15, 2011, 03:48:12 PM

Previous topic - Next topic

Thomas057

My sitemap page is showing black page and by post is not showing on Google

Steve

@Bugo - be advised that the above user has removed the SMF copyright:

@Thomas057:

Quote from: Aleksi "Lex" Kilpinen on November 12, 2023, 03:06:22 AMAlso, be aware that we reserve the right to not support users that remove or alter the SMF copyright - And you have completely replaced it with your own, basically indicating that you do not need our support.
DO NOT pm me for support!

Thomas057

How can I add it back please help me

Kindred

Quote from: Thomas057 on November 19, 2023, 08:27:37 PMHow can I add it back please help me
undo whatever changes you made to remove it...   :P
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Dorin1

do you have any idea why google can't read my sitemap?
it generates it well, it looks ok and when I add it to the site on google it says that it cannot read it.

Xpresskonami

No Optimus Brave For SMF 2.0.15

Kindred

2.0.15 is outdated and insecure.

No one should still be using it.

Upgrade.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Xpresskonami

Quote from: Kindred on December 15, 2023, 09:25:43 AM2.0.15 is outdated and insecure.

No one should still be using it.

Upgrade.

Already upgraded..  but no optimus brave for smf 2.0 except smf 2.1 version

@rjen

I still have an old Optimus package for SMF 2.0 . I can upload it here, but the package comes as is: NO support
Running SMF 2.1 with latest TinyPortal at www.fjr-club.nl

@rjen

Quote from: @rjen on December 15, 2023, 03:59:38 PMI still have an old Optimus package for SMF 2.0 . I can upload it here, but the package comes as is: NO support

here it is
Running SMF 2.1 with latest TinyPortal at www.fjr-club.nl

Aleksi "Lex" Kilpinen

Just noting here for others that the package attached above includes a statement of being licensed under Artistic License 2.0 which allows redistribution in unmodified form.
Slava
Ukraini!
"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Xpresskonami

Quote from: @rjen on December 16, 2023, 07:10:24 AM
Quote from: @rjen on December 15, 2023, 03:59:38 PMI still have an old Optimus package for SMF 2.0 . I can upload it here, but the package comes as is: NO support

here it is

Thank you. The mod destroyed my web. It turns my web into a blank white page. and I have to re-install a new smf 2.0 version. It says my Php version is not working with the mod

Kindred

Always back up your files and database before applying mods.

And yeah,  the old mod does not support modern php - henve the reason it was replaced by a new version,  and the reason that the new version only supports smf 2.1.x
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

@rjen

Quote from: Xpresskonami on December 25, 2023, 10:50:26 PM
Quote from: @rjen on December 16, 2023, 07:10:24 AM
Quote from: @rjen on December 15, 2023, 03:59:38 PMI still have an old Optimus package for SMF 2.0 . I can upload it here, but the package comes as is: NO support

here it is

Thank you. The mod destroyed my web. It turns my web into a blank white page. and I have to re-install a new smf 2.0 version. It says my Php version is not working with the mod

Sorry to hear that, I did warn you about the lacking suport.


FYI this version is still running on Php 8.0 on one of my forums, so it is not THAT outdated. If you did not make a backup you can try dropping php version to 8.0 to uninstall the mod
Running SMF 2.1 with latest TinyPortal at www.fjr-club.nl

dmnlksm

How can I do the latest mod update? Do I need to delete the old version?

Bugo

It depends on what version you have specifically. But in general, yes. Usually the settings are stored in the database.

Julius_2000

#1016
Hi @Bugo,

I've got a question:
Ever since using this great tool, we've had just one minor "issue" with Facebook not showing our forum description for the boardindex. Instead the forum name is repeated a second time where the description is expected.
When I go to meta tag analyzing websites, the meta tag card is shown as expected: Title, description, image etc. Only on FB it won't show the description, no matter what I do. If I turn off Optimus and manually write the meta tag into the php, it works, but then I lose all the meta tags for individual boards and will get the same description for everything (boards, topics).

What's weird, though, is that on a message index and topic level, the descriptions work in FB. It's only the board index description that doesn't.

I've manually added as sort of a "backup"
<meta property="og:description" content="', $context['description'],'">
<meta name="description" content="', $context['description'],'">

but only the second one would be shown in the head of the html on the board index level and the first one be ignored.

Do you happen to have an explanation for this and/ or is anyone experiencing the same thing?

Bugo

The ways of the Facebook are mysterious, try to find some information in the API docs. However, some search engines also ignore the description meta tag, preferring to take some other text from the page as a description if it is more relevant to the user's request.

Julius_2000

#1018
Ah, well yeah I kind of figured that. But there's something that I observed and what I think may have a connection with this mod. Because when I look at the meta tags that are provided for the 3 forum levels, Boardindex, Messageindex and topic, they somewhat differ (an not the obvious differences, like "article" content in a topic).

In Boardindex, the meta tag for property="og:description" that I manually added (see above) is being just ignored and only the second one (property:"description") is printed, while in Messageindex, both of them are shown in the head.
In a topic, again, my meta tag for og:description is missing and only the Optimus one is printed.

What's also weird is, that in Messageindex, the plain property="description" is shown twice. One is my manually added one and one seems to be coming from somewhere else.

Bordindex
You cannot view this attachment.

Messageindex
You cannot view this attachment.

Topic
You cannot view this attachment.

I can't figure out why that is.

Edit: Also, my twitter:card tag that I added is shown twice on Messageindex, or is Optimus adding the second one on the Messageindex level by default but not for the Boardindex?

Bugo

Think about what an extra description might add - maybe it is specified manually in the template or added by some mod. Take a look at your theme's MessageIndex.template as well as MessageIndex.php and compare them with the original files.

Advertisement: