News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Optimus

Started by Bugo, February 15, 2011, 03:48:12 PM

Previous topic - Next topic

Kindred

Sorry, akonze, but I can not replicate your issue.

I use the current version and had no such reaction.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Bugo

Quote from: akonze on September 26, 2013, 03:11:18 PM
This mod deleted my complete configuration menu in the admin area. I can't administrate the board anymore and have to completetely reinstall everything.

I just can warn you to not use the current version. It seems to have a massive bug in it.
Just rename Subs-Optimus.php to Subs-Optimus1.php and re-check.

Low

This mod adds it's own sitemap with credit link regardless of your settings. This can be quite bad for SEO. Any chance of removing the sitemap?

Bugo

Disable "Create and periodically update Sitemap XML-file" option in mod's settings.

Low

Quote from: Bugo on October 13, 2013, 03:34:35 PM
Disable "Create and periodically update Sitemap XML-file" option in mod's settings.
That's what I posted originally, I've tried that.

Bugo

Is it difficult for you to remove sitemap.xml (see forum's root)?

dianneu

I don't mean to seem dense. But how do I know if it's running? I had a please wait... on forever.

I copied everything that needed to be based on what was on the page.

Not certain if it's even running? How do I confirm this? I'm not a programmer, just can do installs I guess. I'm running GT5 as the forum.


DeroZ

Quote from: Bugo on October 13, 2013, 03:34:35 PM
Disable "Create and periodically update Sitemap XML-file" option in mod's settings.

Where is this option? i need disable to remove linktree on my site (simpleportal)

cortez

#308
Really nice mod, I have few questions though:

1. Suggested robots.txt


User-agent: Googlebot-Image
Disallow: /forum/

User-agent: YandexImages
Disallow: /forum/

User-agent: msnbot-MM
Disallow: /forum/

User-agent: Googlebot-Mobile
Allow: /forum/*wap
Disallow: /forum/

User-agent: YandexImageResizer
Allow: /forum/*wap
Disallow: /forum/

User-agent: MediaPartners-Google
Allow: /forum/

User-agent: *
Allow: /forum/$
Allow: /forum/*.xml
Allow: /forum/*sitemap
Disallow: /forum/*action
Disallow: /forum/*board=*wap
Disallow: /forum/*board=*imode
Disallow: /forum/*topic=*wap
Disallow: /forum/*topic=*imode
Disallow: /forum/*;
Disallow: /forum/*PHPSESSID
Allow: /forum/*board*.html$
Allow: /forum/*topic*.html$
Disallow: /forum/
Sitemap: well this one is hidden
Crawl-delay: 5


"Disallow: /forum/" ? Forum is in /forum/ dir and this setting will disallow bots from accessing it? Also, why is "Googlebot-Image" blocked by default? For example, I want images from my site (picture posting is highly valued) to appear everywhere.

2. Inserting html tag for additional ownership verification fails for me, webmaster tools can't detect it (yes, it's formatted properly). Insterting analytics code works, though.

3. Does formatting of allowed "topic" and "board" have issues with enabled "Search engine friendly URLs" setting in SMF?

Kindred

that SEF setting is stupid and should not be used anyway.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

cortez

Alright, that was short and to the point. :) Any suggestions about other stuff?

Bugo

Quote from: cortez on February 09, 2014, 06:59:40 PM
"Disallow: /forum/" ? Forum is in /forum/ dir and this setting will disallow bots from accessing it?
There are more strong methods to prohibit bots any access to your forum. For example, using the rules in .htaccess file.

Quote from: cortez on February 09, 2014, 06:59:40 PMAlso, why is "Googlebot-Image" blocked by default? For example, I want images from my site (picture posting is highly valued) to appear everywhere.
Just remove a line with this rule ("Googlebot-Image" bla-bla-bla).

Quote from: cortez on February 09, 2014, 06:59:40 PM
2. Inserting html tag for additional ownership verification fails for me, webmaster tools can't detect it (yes, it's formatted properly). Insterting analytics code works, though.
Well, try to find information on this question in the Google's help. Maybe, they have changed your html tag etc.

Quote from: cortez on February 09, 2014, 06:59:40 PM
3. Does formatting of allowed "topic" and "board" have issues with enabled "Search engine friendly URLs" setting in SMF?
After enabling this option "topic/board" rules in robots.txt will be changed. And yes,
Quote from: Kindred on February 09, 2014, 08:40:51 PM
that SEF setting is stupid and should not be used anyway.

cortez

Quote from: Bugo on February 10, 2014, 08:39:57 PM
Well, try to find information on this question in the Google's help. Maybe, they have changed your html tag etc.

Nope, I've double checked that. It just doesn't insert a line in <head>.

_socrates_


Hi,

I get the following error on my sitemap.xml:

QuoteThis page contains the following errors:

error on line 3 at column 21: Entity 'nbsp' not defined
Below is a rendering of the page up to the first error.

How can I troubleshoot this? I have uninstalled/reinstalled the mod, but the same error appears.

Thanks!

johnpaul2k2

this particular board has refused to show

check the page 2 of this place please

http://www.topnichez.com/index.php/board,10.15.html

could it caused by this mod

please how can i set it to work

thanks

Kindred

turn off the silly SEO friendly urls...
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

johnpaul2k2

Quote from: Kindred on February 26, 2014, 07:03:55 PM
turn off the silly SEO friendly urls...
then it will affect my 2 years urls in search engines. I think this started of recent  because other page 2 boards are openings !!

hawe2014

Excuse me, i am brandnew to SMF and tried to use the optimus brave modification on my board.

But after installation and configuration my board url still is: /index.php/board,2.0.html

I wanted something like "/board1/topc1.html

I already tried to activate/deactivate SMF internal SEO URL (the "?" says, that my server supports SEO URL) and i tried to reinstall optimus brave twice. Still no changes.

Is there anything else my server need to get this done? I host my forum on a namecheap business account. Do i need a .htaccess in my root? I don't see where i could have made an error.

I would love to get some help on this issue.

Thank you and best regards.

Harald

Kindred

Welcome to smf.

First... This mod does nothing to the urls. Urls have no benefit to see anyway... This mod only changes things like the title, description and keywords.

Second, if you just started your board, the. Insuggestbthat your turn off the silly seo thing. It serves no useful purpose any more (it was intended for search engines years ago, when they looked for the HTML at the end of a website address) search engines will catalog sites just fine without any silly URL changes.

Third, if you absolutely insist on change the urls  you will have to install a mod like pretty urls or smf sef urls.
In both cases, there are potential issues with those urls and other mods
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

hawe2014

Hello Kindred,

thank you for your reply. So i totally misunderstodd the use of Optimus Brave ;-) Thank you for the explanation and i see, if i will test pretty url oder sef url. I thought Optimus Brave does this :) Thanks again!

Advertisement: