Advertisement:

Author Topic: Optimus  (Read 224423 times)

Offline njtweb

  • Sophist Member
  • *****
  • Posts: 1,101
Re: Optimus
« Reply #760 on: October 02, 2020, 07:59:56 AM »
Hi @Bugo - Facebook question

They have recently changed the format/design of the website. I've noticed a few things with shared posts from my website.

1. If there is no image in a site topic - Facebook no longer posts the default image which is identified in Optimus settings. It doesn't even post the topic title, it only posts the URL, nothing is parsed from the topic to Facebook
2. Ift the default image in a topic is small, like 260x260 Facebook does some weird stuff. It either defaults to a very old image from a Tiny Portal article, or it doesn't post any image at all and only posts the URL to the topic. Nothing is parsed.
3. If a topic has a normal sized image, FB will parse that and post it but there's no description

Lastly, in all 3 of these scenarios, I always run every topic I want to post on Facebook through the Facebook debugger. They always parse correctly but since Facebook changed, things don't seem to equate from debugger to facebook in general.

Which brings me to this question. Has FB changed how it parses code again? If it has can you fix this for me? $25USD for your help.

Thank yoU!


EDIT: I was able to install the Chrome Facebook "Switch to classic" extension in order to post topics correctly. This is only a bandaid and I expect the extension to eventually stop working.
« Last Edit: October 02, 2020, 08:10:54 AM by njtweb »

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,659
  • Gender: Male
    • dragomano on GitHub
    • Support me on Ko-fi
Re: Optimus
« Reply #761 on: October 02, 2020, 08:14:16 AM »
Lets wait for the next release TinyPortal (2.0.0 final) because some things will be changed there.
Any case, I have already changed a TinyPortal addon for the current Optimus dev version.

Can you test articles with specific images (1200х630 px)?

Offline njtweb

  • Sophist Member
  • *****
  • Posts: 1,101
Re: Optimus
« Reply #762 on: October 02, 2020, 08:19:15 AM »
Lets wait for the next release TinyPortal (2.0.0 final) because some things will be changed there.
Any case, I have already changed a TinyPortal addon for the current Optimus dev version.

Can you test articles with specific images (1200х630 px)?

Okay Bugo, thank you. I'll continue to use the Chrome extension for now. I'll get back to you on the image test.

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #763 on: October 06, 2020, 12:41:19 PM »
I have spent the morning trying to get the mod to work.  There are no instructions on how to do this.

I uploaded the zip file via admin panel.  then I clicked on install.   Mod shows a green light but I dont see the mod interface anywhere.  there is a database.php file in the zip file.  do I need to do something with that?

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,659
  • Gender: Male
    • dragomano on GitHub
    • Support me on Ko-fi
Re: Optimus
« Reply #764 on: October 06, 2020, 01:01:59 PM »
On the mod page find "Manual install" select box, select your SMF version and click "Parse" button.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 60,203
  • Gender: Male
    • Kindred-999 on GitHub
Re: Optimus
« Reply #765 on: October 06, 2020, 01:14:59 PM »
if you used the package manager to install it, then it should already BE installed

it installed under a heading in the admin called "Search Engine Optimization
index.php?action=admin;area=optimus
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #766 on: October 06, 2020, 01:26:55 PM »
if you used the package manager to install it, then it should already BE installed

it installed under a heading in the admin called "Search Engine Optimization
index.php?action=admin;area=optimus

Its installed but not there.  And I dont see any changes to the database.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 60,203
  • Gender: Male
    • Kindred-999 on GitHub
Re: Optimus
« Reply #767 on: October 06, 2020, 01:28:59 PM »
have you been able to install any other mods?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #768 on: October 06, 2020, 01:40:28 PM »
have you been able to install any other mods?
Have not tried.  But its a good idea.

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #769 on: October 06, 2020, 04:00:10 PM »
Yes.  I installed invitation Mod.  And it works.

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #770 on: October 06, 2020, 04:09:59 PM »
Here is what my admin panel shows.  Not the left column shows Invitation mod but not the other Optimus mod.


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 60,203
  • Gender: Male
    • Kindred-999 on GitHub
Re: Optimus
« Reply #771 on: October 06, 2020, 04:39:58 PM »
You could try uninstalling and then reinstalling optimus

if that doesn't work, then yes... you will probably have to manually install the Optimus mod, since your system seems to be incapable of installing it automatically.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #772 on: October 07, 2020, 07:32:43 AM »
You could try uninstalling and then reinstalling optimus

if that doesn't work, then yes... you will probably have to manually install the Optimus mod, since your system seems to be incapable of installing it automatically.

Uninstalling and reinstalling was the first thing I tried.

Going back to my original post...........are there any instructions on how to install this manually.

I noticed that owner is set to root for all of the mod files/directories when it is installed from the admin panel.  Is that a problem?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 60,203
  • Gender: Male
    • Kindred-999 on GitHub
Re: Optimus
« Reply #773 on: October 07, 2020, 09:12:08 AM »
if another mod installed correctly, it should not be a problem....

Manual install instructions are on the mod download page...
On the mod page find "Manual install" select box, select your SMF version and click "Parse" button.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus
« Reply #774 on: October 07, 2020, 09:47:49 AM »
Those are not instructions. 

There is a database modification file that isnt even mention in the "directions".

Offline pixelpadre

  • Semi-Newbie
  • *
  • Posts: 22
Re: Optimus error log
« Reply #775 on: October 07, 2020, 07:11:33 PM »
Two different error log entries:

Apply Filter: Only show the error messages of this URL
https://cwpforum.com/index.php?action=admin;area=logs;sa=errorlog;desc;filter=error_type;value=database [nofollow]
Apply Filter: Only show the errors with the same message
2: Illegal string offset 'member_name'
Apply Filter: Only show the errors from this file
File: /home/user/public_html/cwpforum/Sources/ManageErrors.php
Line: 204

and

Apply Filter: Only show the error messages of this URL
https://cwpforum.com/index.php?action=admin;area=packages;sa=install2;package=optimus_2.6.5_smf20.zip;pid=0 [nofollow]
Apply Filter: Only show the errors with the same message
2: fopen(/home/user/public_html/cwpforum/Themes/default/css/optimus/optimus.css): failed to open stream: Permission denied
Apply Filter: Only show the errors from this file
File: /home/user/public_html/cwpforum/Sources/Subs-Package.php
Line: 2545

Offline Massl

  • Jr. Member
  • **
  • Posts: 334
Re: Optimus
« Reply #776 on: October 19, 2020, 04:19:02 PM »
Hi Bugo, is there a reason why this option has been removed?

Quote
Add ALL topic pages to the sitemap
If not checked, only the first pages of topics will be added to the sitemap.

Thanks

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,659
  • Gender: Male
    • dragomano on GitHub
    • Support me on Ko-fi
Re: Optimus
« Reply #777 on: October 20, 2020, 12:55:50 AM »
Usually, the search spider gets the first link - http://yourforum/?topic=x.0 - and then finds all other automatically, no need to collect all possible links in sitemaps.

Offline Massl

  • Jr. Member
  • **
  • Posts: 334
Re: Optimus
« Reply #778 on: October 21, 2020, 03:04:54 AM »
Thanks for your reply Bugo  :)

In my forum I have many discussions with over 50 pages and after the upgrade from 2.8.3 to 2.9.3 the google indexing has dropped a lot, last pages are no longer indexed.

I think it is better put back the option.

Offline Neol

  • Full Member
  • ***
  • Posts: 478
  • Gender: Male
  • ##########
    • Respublica.tech
Re: Optimus
« Reply #779 on: October 21, 2020, 06:44:57 PM »
Need some help here.
I tried to add emojis to the forum title and description, but it won't work. If I add an emoji the whole title or description text will disappear. Usually, emojis are treated as text, and shouldn't be a problem to add/use them. I use emojis sometimes in topic titles and there are no issues in these cases. Just inside the meta data it won't work. Any idea why?