• Welcome to Simple Machines Community Forum. Please login or sign up.
September 19, 2021, 03:37:42 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Περιεργα Πραγματα

Started by fiestalunatic, February 24, 2011, 04:00:36 AM

Previous topic - Next topic

fiestalunatic

Καλημερα σε ολους!  :)

Εχω 2 φορουμ ενα τεστ και ενα κανονικο σε 2 διαφορετικους servers.

Εγκατεστησα το aeva media στο τεστ και παιζει μια χαρα.Οταν το εγκατεστησα
στο κανονικο server τα textboxs - textfields εμφανιζαν ερωτηματικα οταν εγραφα ελληνικα.

Το collation των πινακων του aeva στο κανονικο φορουμ ηταν latin swedish_ci και το μετετρεψα σε utf8-gerenal-ci μεσω phpmyadmin (που ήταν και στο τεστ ετσι) με την ελπιδα οτι θα παιξει αλλα δυστυχως περνω ερωτηματικα οταν γραφω ελληνικα.

Επισης μεσα απο την διαχειριση εκανα και 'Μετατροπή οντοτήτων HTML σε χαρακτήρες UTF-8' αλλα δεν πετυχα κατι. (smf 1.1.11)

Τι αλλο μπορει να φταιει?

fiestalunatic

Tελικα εκανα drop ολους τους πινακες του aeva μεσω phpmyadmin και εγκατεστησα παλι το mod.

Μαλλον καποιο conflict θα γινοταν με μια παλιοτερη εκδοση του aeva (aeva light) που
ειχα εγκαταστησει.

vkot

Έχω ένα πρόβλημα με την κωδικοποίηση, όχι στα πεδία κειμένου, αλλά στα ονόματα των φακέλων των άλμπουμ που ανοίγει το aeva media.
Οι φάκελοι στον σέρβερ ανοίγονται με το όνομα του τίτλου του άλμπουμ, κάτι που είναι εντελώς βλακώδες γιατί βάζοντας τίτλο στα ελληνικά τελικά έχω φακέλους στον σέρβερ με αλαμπουρνέζικα ή με κάτι σαν html entities αν επιλέξω την επιλογή στις ρυθμίσεις του aeva, και τελικά τα άλμπουμ/φωτογραφίες δεν διαβάζονται αφού ο σέρβερ δεν αναγνωρίζει το όνομα φακέλου (εκτός αν αυτό περιέχει επίσης αριθμούς ή λατινικούς χαρακτήρες, αν δεν απατώμαι)
For specialized SMF installation/customization, Web Development, Linux Server Administration, click here.
Για εξειδικευμένες υπηρεσίες στα παραπάνω, πατήστε εδώ.

Advertisement: