Advertisement:

Author Topic: Peoplesign - Photo Captcha  (Read 24821 times)

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
Peoplesign - Photo Captcha
« on: April 20, 2011, 12:34:53 PM »
Link to Mod

Support for smf 2.0 is now available!   
« Last Edit: June 16, 2011, 10:07:54 PM by peoplesignDave »

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,403
    • StoryBB/StoryBB on GitHub
Re: Peoplesign - Photo Captcha
« Reply #1 on: April 20, 2011, 02:04:53 PM »
And what about users who are visually impaired?

Web site operators in the UK are bound by the Disability Discrimination Act 1995, Ireland by its Disability Act 2005, and US governmental websites by the Section 508 rule (which is under consideration to be expanded to any site in the US in theory), as well as test cases being brought in Australia for accessibility.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
Re: Peoplesign - Photo Captcha
« Reply #2 on: April 21, 2011, 02:55:33 PM »
Regarding support for visually impaired users, we have a proven short term solution.  However, this short term solution is undeniably inconvenient.  Therefore we have plans for a better long term solution. 

Recently via direct communication I personally assisted a visually impaired user in passing a Peoplesign challenge.   I was inspired by his patience and resourcefulness in the context of the obvious inconvenience he incurred by having to contact us. 

We have an audio version of the service in the works.  We think you'll like it.  Please be patient while we complete this difficult feature.  Complex functional software can't be conjured up on a whim.  Until it's ready, please understand that visually impaired users already have a workable albeit inconvenient method of passing peoplesign challenges.
« Last Edit: April 21, 2011, 02:58:49 PM by peoplesignDave »

Offline Martine M

  • Full Member
  • ***
  • Posts: 532
  • Gender: Female
    • Unlimited PSP Fun
Re: Peoplesign - Photo Captcha
« Reply #3 on: April 27, 2011, 06:36:36 PM »
I installed peoplesign at my forum.
http://www.united-tutorials-registration.com/
I manually installed in the Mesh theme as was written at the peoplesign modification page here on smf.

It seems to work great, the spammers stay away (and a got 6 a day) and I got some new members so I guess it works fine for people to get registered.

But at my admin error log i get pages of errors like this.
"8: Use of undefined constant PEOPLESIGN_CHALLENGE_URL - assumed 'PEOPLESIGN_CHALLENGE_URL'
File: /home/unitedtu/public_html/Themes/mesh_114/languages/Modifications.english.php
Line: 145"

in that php at line 145 is this ". '<a href=\"'. PEOPLESIGN_CHALLENGE_URL . '\">here</a> to '
                              146              . 'verify you\'re a human.</p>';

I really hope you can help me out, I would love to keep this mod.
Thank you.
« Last Edit: April 27, 2011, 06:41:03 PM by enitram »
Running SMF 2.09 - Diego Andrés Theme Elegant Mind - TP 1.0 - Main Forum language English - Browser Firefox 33


Offline Martine M

  • Full Member
  • ***
  • Posts: 532
  • Gender: Female
    • Unlimited PSP Fun
Re: Peoplesign - Photo Captcha
« Reply #4 on: April 28, 2011, 05:47:56 AM »
Thanks Spuds, I changed what you told me to and those error messages are gone now.
I tried the peoplesign out to see if it still works fine and then went back to the error log and I see this error.

"8: Undefined index: peoplesign_NO_FRAMES_MESSAGE_2
File: /home/unitedtu/public_html/Sources/peoplesignMessages.php
Line: 17"

maybe this error messages only comes when people use peoplesign?
Running SMF 2.09 - Diego Andrés Theme Elegant Mind - TP 1.0 - Main Forum language English - Browser Firefox 33


Offline Martine M

  • Full Member
  • ***
  • Posts: 532
  • Gender: Female
    • Unlimited PSP Fun
Re: Peoplesign - Photo Captcha
« Reply #5 on: April 28, 2011, 10:37:01 AM »
Thank you Spuds, I changed it and I think I have no error's anymore.
Running SMF 2.09 - Diego Andrés Theme Elegant Mind - TP 1.0 - Main Forum language English - Browser Firefox 33


Offline Martine M

  • Full Member
  • ***
  • Posts: 532
  • Gender: Female
    • Unlimited PSP Fun
Re: Peoplesign - Photo Captcha
« Reply #6 on: April 29, 2011, 05:24:17 AM »
Get other error messages

"8: Undefined index: captcha_peoplesignCRS
File: /home/unitedtu/public_html/Sources/peoplesignUtilities.php
Line: 13"

at line 12 is :  function getPostVar($varName, $varType) {
at line 13 is:  return $_POST[$varName];
Running SMF 2.09 - Diego Andrés Theme Elegant Mind - TP 1.0 - Main Forum language English - Browser Firefox 33


Offline MPerrine

  • Semi-Newbie
  • *
  • Posts: 32
Re: Peoplesign - Photo Captcha
« Reply #7 on: May 09, 2011, 02:31:15 PM »
Hello,

Since I updated my forum to 1.1.13, ajaxchat doesn't work anymore. I get errors with Peoplesign :

Code: [Select]
Use of undefined constant PEOPLESIGN_CHALLENGE_URL - assumed 'PEOPLESIGN_CHALLENGE_URL'
Fichier: /xxx/forum/Themes/default/languages/Shout.french.php (eval?)

in errors log in admin (+2000 errors /3 minutes)

I also get

Code: [Select]
Notice: Use of undefined constant PEOPLESIGN_CHALLENGE_URL - assumed 'PEOPLESIGN_CHALLENGE_URL' in /home/jmmathe/xxx/forum/Sources/Load.php(1737) : eval()'d code on line 21
I can't get to uninstall Peoplesign... Even when I delete files and entries in mysql, errors still come up.

Any idea ?

Offline MPerrine

  • Semi-Newbie
  • *
  • Posts: 32
Re: Peoplesign - Photo Captcha
« Reply #8 on: May 10, 2011, 04:25:31 AM »

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
New version (1.5) available - annoying log message problem fixed
« Reply #9 on: May 11, 2011, 02:51:01 AM »
Sorry for the delay in fixing this.   I'm now setup to get notifications on this topic so I'll be more responsive in the future. 


Offline Daniel Hofverberg

  • Senior Translator
  • Sr. Member
  • *
  • Posts: 981
  • Gender: Male
    • Dubbningshemsidan
Re: Peoplesign - Photo Captcha
« Reply #10 on: May 27, 2011, 10:14:03 PM »
Thanks for the mod. It's a very interesting and nice idea, and it looks promising. I will however hold off with trying it until there is some sort of solution for visually impaired people, in order not to exclude anyone.

I would also really like to be able to have the actual PeopleSign interface in Swedish (I e the "Choose the best match for picture" text and similar messages).

As far as I can make out, the mod only supports the registration screen for the time being, and that doesn't cut it for me. In order for it to be useful, I would also like to be able to add PeopleSign to guest posting, when guests are posting on forums with guest posting enabled.

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: New version (1.5) available - annoying log message problem fixed
« Reply #11 on: June 13, 2011, 04:56:27 PM »
Sorry for the delay in fixing this.   I'm now setup to get notifications on this topic so I'll be more responsive in the future.


I just added this mod yesterday to two of my SMF 1.1.14 forums and am filling my error log with the same error, apparently it occurs with every register action:
8: Undefined Index: peoplesign_options
File: / /home/public_html/forum/Themes/default/Register.template.php (before sub template - eval?)
Line 156

Note: Since this forum does not allow copy and paste, I had to type out the error message so there may be errors in the error message:-) Are they (SMF support forums) ever going to fix this?
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
Re: Peoplesign - Photo Captcha
« Reply #12 on: June 13, 2011, 05:26:31 PM »
This problem should have been fixed in version 1.5 of our mod.  Maybe you're using an older version?

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: Peoplesign - Photo Captcha
« Reply #13 on: June 13, 2011, 09:11:41 PM »
This problem should have been fixed in version 1.5 of our mod.  Maybe you're using an older version?

Well, I downloaded it from the SMF mods page yesterday and it said 1.5. The only way I could have downloaded an older version was to unclick the dot box and then click 1.4, I did no such thing.

I think it's due to my using version 1.1.14, it probably effects this mod in some way. Have you checked the compatibility for 1.1.14?
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
Re: Peoplesign - Photo Captcha
« Reply #14 on: June 13, 2011, 10:27:28 PM »
This is very odd.  I don't think it's related to your use of SMF 1.1.14. I upgraded my system from 1.1.13 to to 1.1.14, did a sample registration, and didn't see any error messages.

If anyone else has the above error message in your log file (viewed from the SMF admin), please leave a post.

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
Re: Peoplesign - Photo Captcha
« Reply #15 on: June 13, 2011, 11:10:15 PM »
When I did a fresh install of 1.1.14, I was able to trigger the problem.  I've found the source of the problem and will be releasing a new version (1.6) soon.

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: Peoplesign - Photo Captcha
« Reply #16 on: June 14, 2011, 12:59:17 AM »
When I did a fresh install of 1.1.14, I was able to trigger the problem.  I've found the source of the problem and will be releasing a new version (1.6) soon.

Soon? Assuming it's a few lines of code, can you tell us what the source of the problem is so we can fix it ourselves? Between my two forums, I'm getting about 100 errors in a 24 hour period!
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Offline peoplesignDave

  • Semi-Newbie
  • *
  • Posts: 15
Re: Peoplesign - Photo Captcha
« Reply #17 on: June 14, 2011, 03:14:29 AM »
I'm sorry for the ambiguous 'soon'.  Below is a manual fix.  WARNING: If you manually change a file, it will prevent the corresponding package from being uninstalled cleanly.

Since this is only a problem of log file pollution (correct me if I'm wrong) I'm going to delay 1.6 until the end of this week (6-19-2011) so I can also deliver support for SMF 2.0. 

Here's the fix.

WARNING:  CatfishEd reported this fix doesn't work! Your mileage may vary.

Open /home/public_html/forum/Themes/default/Register.template.php, go to Line 156.

replace
$modSettings['peoplesign_options']
with
!empty($modSettings['peoplesign_options']) ? $modSettings['peoplesign_options'] : ''
« Last Edit: June 14, 2011, 07:10:20 PM by peoplesignDave »

Offline Martine M

  • Full Member
  • ***
  • Posts: 532
  • Gender: Female
    • Unlimited PSP Fun
Re: Peoplesign - Photo Captcha
« Reply #18 on: June 14, 2011, 04:57:05 PM »
I really hope you are going to make a version for SMF 2.0, Just upgraded and I miss it already.
Running SMF 2.09 - Diego Andrés Theme Elegant Mind - TP 1.0 - Main Forum language English - Browser Firefox 33


Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: Peoplesign - Photo Captcha
« Reply #19 on: June 14, 2011, 06:17:50 PM »
I'm sorry for the ambiguous 'soon'.  Below is a manual fix.  WARNING: If you manually change a file, it will prevent the corresponding package from being uninstalled cleanly.

Since this is only a problem of log file pollution (correct me if I'm wrong) I'm going to delay 1.6 until the end of this week (6-19-2011) so I can also deliver support for SMF 2.0. 

Here's the fix.

Open /home/public_html/forum/Themes/default/Register.template.php, go to Line 156.

replace
$modSettings['peoplesign_options']
with
!empty($modSettings['peoplesign_options']) ? $modSettings['peoplesign_options'] : ''

Well thanks, I followed your directions right down to the last " and it disabled my registration settings page altogether showing a paragraph or two of error info. I figured I could revert back using my backup copy of Register.template.php but instead it totally removed peoplesign from my registration page. It's still listed in my packages as installed so I guess I'm totally screwed. >:( :( And now Stop Forum Spam is down so I'm hanging out there begging for more spam and I'll have to check each one individually. >:(

Edit! Edit! I got my Register.template.php from my other forum, also with Peoplesign and sent that up and reinstalled the key. Now at least I'm back to square 1 and anxiously awaiting your fix. (either version 1.6 or a correction that works for sure) That scared the heck out of me, I had spammers signing up every minute and no way to stop them. :o There's definitely something wrong with your manual fix, I was very careful to make sure I was doing exactly what was instructed and it exploded.
« Last Edit: June 14, 2011, 06:42:10 PM by catfished »
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com