Advertisement:
GCWebhosting

Author Topic: Post prview not working  (Read 1658 times)

Offline lolf

  • Newbie
  • *
  • Posts: 5
Post prview not working
« on: May 27, 2011, 01:32:00 PM »
Tried using the search, didn't find anything relevent/recent. Please don't shoot me if this is something that many people ask  :-\

So I'm running a small forum that I don't fiddle with EVER. As long as it works, I'm not touching anything. I have a couple of packages installed a youtube mod and a wow thing (that I stopped after the problem appeared). Everything has been running without issues for months. Since yesterday the post prview is just not working, it's hanging up at "fetching preview...". The only relevent info I can add is that I got an email that there's a problem with database connectivity, but that's happened before and the forum is working without a hitch... except for the preview thing.

I ran the things in Forum Maintenance (all except for the convert HTML to UTF thing, it sounds scary) that did not help, any suggestions?

Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
    • ZubaFitness
Re: Post prview not working
« Reply #1 on: May 27, 2011, 01:55:52 PM »
Link to your site with a test account?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Offline lolf

  • Newbie
  • *
  • Posts: 5
Re: Post prview not working
« Reply #2 on: May 27, 2011, 02:18:09 PM »
hxxp:www.hostileforagers.com/index.php [nonactive]

How do you mean a test account? I made one that can see all forums - test123 / t35t

Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
    • ZubaFitness
Re: Post prview not working
« Reply #3 on: May 27, 2011, 02:25:03 PM »
Please run the below file and post the results

What is file_check.php?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Offline lolf

  • Newbie
  • *
  • Posts: 5
Re: Post prview not working
« Reply #4 on: May 27, 2011, 02:30:04 PM »
hxxp:hostileforagers.com/file_check.php [nonactive] that's how I'm supposed to do it right?

Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
    • ZubaFitness
Re: Post prview not working
« Reply #5 on: May 27, 2011, 02:32:43 PM »
Looks like the files on your site were compromised (I hesitate to use the term hacked because *you* probably weren't 'hacked', but someone else on the server which then affected you too).

You'll need to go through and manually check all of those files listed (except for ssi_examples.php, barber.php, and benihana.php) and look at the very end of the file.  The very very very last thing should be ?> with no spaces or lines after it.  Anything that is after it needs to be removed.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Offline lolf

  • Newbie
  • *
  • Posts: 5
Re: Post prview not working
« Reply #6 on: May 27, 2011, 02:48:04 PM »
um wow, there really is something at the end of files. So i opened index from sources and i have
   exit;

?><img heigth="1" width="1" border="0" src="hxxp:whatever.cz.cc/184014.jpg [nonactive]">

So I just delete everyting after ?> and reupload the file to the same spot. Got it.

Thanks a lot for your time mate.

Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
    • ZubaFitness
Re: Post prview not working
« Reply #7 on: May 27, 2011, 02:57:44 PM »
No problem :)
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Offline lolf

  • Newbie
  • *
  • Posts: 5
Re: Post prview not working
« Reply #8 on: May 27, 2011, 03:10:00 PM »
yep, everything works now. /www/www/stats/index.php had the silliness in it, but it was weirder than the other files and still shows up on the checker utility, didn't touch anything other than removing the link and it all works now so I'll quickly forget about everything now :D

Thanks again!