SMF 1.1.14 has been released

Started by Norv, June 11, 2011, 05:32:34 PM

Previous topic - Next topic

miDnIghtEr20C

Quote from: ddabcd277 on June 12, 2011, 04:39:56 AM
Just installed 1.1.14. Seems ok. Thanks for the update guys.  :)

I understand from the comments above and on other places that 2.0 is the better choice and recommended, even on the admin panel it is redirecting now to 2.0, but I still pluck up courage to update to 2.0. I am afraid not to brake my forum. Why not possible in the similar way update from 1.1.x to 2.0? Some kind of an automatic update?

Cheers,
where are you seeing this in the admin area?  i'm looking, and that's how i want to update my forum, but i don't see that option like i did to update to 1.1.14. 

thanks.

DarkAngel612

Quote from: miDnIghtEr20C on June 13, 2011, 01:11:44 AM
Quote from: ddabcd277 on June 12, 2011, 04:39:56 AM
Just installed 1.1.14. Seems ok. Thanks for the update guys.  :)

I understand from the comments above and on other places that 2.0 is the better choice and recommended, even on the admin panel it is redirecting now to 2.0, but I still pluck up courage to update to 2.0. I am afraid not to brake my forum. Why not possible in the similar way update from 1.1.x to 2.0? Some kind of an automatic update?

Cheers,
where are you seeing this in the admin area?  i'm looking, and that's how i want to update my forum, but i don't see that option like i did to update to 1.1.14. 

thanks.
mine was missing too but they said to look in admin/packages and the link will be in there---and it was
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

miDnIghtEr20C

Quote from: DarkAngel612 on June 13, 2011, 01:20:50 AM
Quote from: miDnIghtEr20C on June 13, 2011, 01:11:44 AM
Quote from: ddabcd277 on June 12, 2011, 04:39:56 AM
Just installed 1.1.14. Seems ok. Thanks for the update guys.  :)

I understand from the comments above and on other places that 2.0 is the better choice and recommended, even on the admin panel it is redirecting now to 2.0, but I still pluck up courage to update to 2.0. I am afraid not to brake my forum. Why not possible in the similar way update from 1.1.x to 2.0? Some kind of an automatic update?

Cheers,
where are you seeing this in the admin area?  i'm looking, and that's how i want to update my forum, but i don't see that option like i did to update to 1.1.14. 

thanks.
mine was missing too but they said to look in admin/packages and the link will be in there---and it was
ya, i don't see it there yet.   bummer.   i saw the update to 1.1.14 there, and updated to that... but now i'm waiting for the update to 2.0 shows up there.

DarkAngel612

oops sorry I misunderstood and thought you meant the 1.1.14 update

since 2.0 seems to be totally rewritten I don't think there will be a direct update to it in packages...I may be wrong but I am not holding my breath at all.
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

Burridge

There are no package updates for 2.0. It has to be done via Large update I think.

huaxia


miDnIghtEr20C

Quote from: Burridge on June 13, 2011, 04:14:51 AM
There are no package updates for 2.0. It has to be done via Large update I think.
ahhh crap then!   i'm through godaddy and all that jazz for my server, and not that techy on it... though it seems it could be easy, i'll have to read the faq thing... but man, it is sure easy to see the update in the package manager section, and just update it that way.

man i hope somehow they can make that happen for people that suck at this stuff like me!  :)

Kindred

there will never be a package manager update for RC versions or major upgrades (like 1.1.x to 2.x or 2.x to 3.x)
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

esttecb

Just to let you people know, someone forgot to include the upgrade_1-1.sql on the 1.1.4 update package, this is important to people doing the manual upgrade. However, you still can upgrade your smf with the 1.1.4 upgrade package. Which are pretty hidden now > http://download.simplemachines.org/index.php?archive;start=200 (don't know if there's a shortcut)

Besides, I think most people don't know they have to update they data base too, not only the .php files. It would be nice a little advice in the manual update page about this.

DarkAngel612

Quote from: esttecb on June 13, 2011, 12:41:06 PM
Just to let you people know, someone forgot to include the upgrade_1-1.sql on the 1.1.4 update package, this is important to people doing the manual upgrade. However, you still can upgrade your smf with the 1.1.4 upgrade package. Which are pretty hidden now > http://download.simplemachines.org/index.php?archive;start=200 (don't know if there's a shortcut)

Besides, I think most people don't know they have to update they data base too, not only the .php files. It would be nice a little advice in the manual update page about this.

maybe cause you got the update package NOT the upgrade package, they are in the upgrade one, I tried to attach them but it won't show the browse button so get the upgrade package for the files you need
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

dcmouser

Quote1.1.14 will remain in maintenance stage, and it will continue to be supported for security and major/critical functionality fixes

On behalf of all of us who have made so many changes to our smf 1.1x install that upgrading is not simple, i want to say thank you for this position, which seems fair and sensible.  Three cheers for the SMF team!
proud member of donationcoder.com (forum)

青山 素子

Quote from: esttecb on June 13, 2011, 12:41:06 PM
Just to let you people know, someone forgot to include the upgrade_1-1.sql on the 1.1.4 update package, this is important to people doing the manual upgrade. However, you still can upgrade your smf with the 1.1.4 upgrade package. Which are pretty hidden now > http://download.simplemachines.org/index.php?archive;start=200 (don't know if there's a shortcut)

Besides, I think most people don't know they have to update they data base too, not only the .php files. It would be nice a little advice in the manual update page about this.

If you are updating from 1.1.13 manually, you only need the small update archive. No database changes occurred between 1.1.13 and 1.1.14, afaik.

If you are using an older version, you will need the large upgrade archive.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


DarkAngel612

Quote from: 青山 素子 on June 14, 2011, 04:24:49 PM
Quote from: esttecb on June 13, 2011, 12:41:06 PM
Just to let you people know, someone forgot to include the upgrade_1-1.sql on the 1.1.4 update package, this is important to people doing the manual upgrade. However, you still can upgrade your smf with the 1.1.4 upgrade package. Which are pretty hidden now > http://download.simplemachines.org/index.php?archive;start=200 (don't know if there's a shortcut)

Besides, I think most people don't know they have to update they data base too, not only the .php files. It would be nice a little advice in the manual update page about this.

If you are updating from 1.1.13 manually, you only need the small update archive. No database changes occurred between 1.1.13 and 1.1.14, afaik.

If you are using an older version, you will need the large upgrade archive.

although my forums behave they are like salmons and go against the flow at time...lol

I updated all from admin/packages and found to day that I have to upload the update.php and corresponding file then run it because I got the error message that the files were 1.1.14 but database was still 1.1.13

so it wouldn't hurt to grab the full installer to get the files needed, or is it the upgrader zip...sorry can't reember which one...heat is turning brain to mush
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

gamebalance

when I click update in package manager it brings me error like:
"Forbidden
You don't have permission to access /forum/index.php on this server."

tho the forum works. I even added akismet mod. all works.

Burridge

Try chmodding the index.php file to 755(?).

Quote from: miDnIghtEr20C on June 13, 2011, 12:35:27 PM
...
It isn't that hard if you read Upgrading SMF.

Aleksi "Lex" Kilpinen

Quote from: DarkAngel612 on June 14, 2011, 05:37:15 PM
I updated all from admin/packages and found to day that I have to upload the update.php and corresponding file then run it because I got the error message that the files were 1.1.14 but database was still 1.1.13
That's - Sadly - just a misleading error message. The DB version is not the error, it is just extra info for you to use for debugging the actual error displayed. If the last time the DB was updated, was on 1.1.13 then the DB version will stay on 1.1.13 even with you running the update.php ;)

The actual error you should be looking at, is usually displayed before the DB version notice :)

In short - You can safely ignore the DB version numbering, and concentrate on whatever the error was you actually got.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

TheCollisionVision

is there a way to directly update from 1.1.13 to 2.0 with out removing everything and doing it over again?

Illori


klra

1.1.14 installed and working fine on 3 different installations - thanks guys!

bonbagay

Please help me, I have problem with my forum this the massage I have anytime I`m click member

( Fatal error: require_once() [function.require]: Failed opening required 'D:\hosting\2561782\html\bbboard/Sources/StopSpammer.php' (include_path='.;C:\php5\pear') in D:\hosting\2561782\html\bbboard\Sources\ManageMembers.php on line 95)


help please

Advertisement: