Advertisement:

Author Topic: YaBB 2.1 to SMF 2.0  (Read 14426 times)

Offline sheff

  • Newbie
  • *
  • Posts: 1
YaBB 2.1 to SMF 2.0
« on: June 22, 2011, 05:53:11 PM »
Is there a topic for this conversion yet? If so please link me to it, i tried searching and couldn't find anything. Thanks!

I am trying to convert our outdated YaBB 2.1 board to the brand new SMF 2.0 board. I have installed SMF and have the YaBB install on an accessible place on the same server. When I run the converter (placed in newly installed SMF folder) I get the following:

Code: [Select]
Converting...
Successful.
Converting membergroups...
Successful.
Converting members...
array(6) { [0]=> array(4) { ["file"]=> string(32) "/var/www/html2/yabb21_to_smf.php" ["line"]=> int(219) ["function"]=> string(10) "alterTable" ["args"]=> array(4) { [0]=> &string(7) "members" [1]=> &array(1) { ["PRIMARY"]=> string(16) "DROP PRIMARY KEY" } [2]=> &string(0) "" [3]=> &array(1) { ["id_member"]=> string(74) "CHANGE COLUMN id_member id_member mediumint( unsigned NOT NULL default 0" } } } [1]=> array(2) { ["function"]=> string(12) "convertStep3" ["args"]=> array(0) { } } [2]=> array(4) { ["file"]=> string(26) "/var/www/html2/convert.php" ["line"]=> int(1346) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) { [0]=> &string(12) "convertStep3" } } [3]=> array(4) { ["file"]=> string(26) "/var/www/html2/convert.php" ["line"]=> int(973) ["function"]=> string(17) "run_php_converter" ["args"]=> array(0) { } } [4]=> array(2) { ["function"]=> string(7) "doStep1" ["args"]=> array(0) { } } [5]=> array(4) { ["file"]=> string(26) "/var/www/html2/convert.php" ["line"]=> int(51) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) { [0]=> &string(7) "doStep1" } } } Incorrect table name ''

Incorrect table name. Any thoughts/ideas? Thanks in advance!

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
Re: YaBB 2.1 to SMF 2.0
« Reply #1 on: July 29, 2011, 06:03:16 AM »
You may have more mileage in upgrading your YaBB to SMF1.1.14, then upgrading that to SMF2.  More outage, and certainly much more to go wrong, but it seems none of the YaBB to SMF2 converters work at all. Even the YaBB to SMF1 ones are a bit shoddy  :'(