Advertisement:

Author Topic: How do I fix Updating thumbnail attachments PNG. (Item:110)  (Read 3698 times)

Offline mcadamsp

  • Newbie
  • *
  • Posts: 1
I was upgrading to 2.0 and got the error.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: How do I fix Updating thumbnail attachments PNG. (Item:110)
« Reply #1 on: June 28, 2011, 07:27:22 PM »
I was upgrading to 2.0 and got the error.


Hi,

Can you copy and paste the error here
or
take a screen shot and attach it?

More information is needed,
Cloud  8)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline jeronij

  • Semi-Newbie
  • *
  • Posts: 13
Re: How do I fix Updating thumbnail attachments PNG. (Item:110)
« Reply #2 on: June 30, 2011, 02:49:30 PM »

Having the exact same problem here:


Quote



Progress
Step 1: Login
Step 2: Upgrade Options
Step 3: Backup
Step 4: Database Changes
Step 5: Delete Upgrade



63%

 

Overall Progress


68%

 

Step Progress








Time Elapsed: 176 mins, 34 seconds.


Database Changes



Executing database changes

Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made!

Executing upgrade script 2 of 2.
Executing: "Updating attachment data..." (12 of 42 - of this script)


 Updating member approval...done
 Adding new holidays...done
 Updating event start and end dates...done
 Converting other date columns...done
 Checking for an old table...done
 Creating "message_icons"...done
 Inserting "message_icons"...done
 Creating "package_servers"...done
 Inserting "package_servers"...done
 Updating flood control log...done
 Updating ip address storage...done
 Converting "log_online"...done
 Updating poll column sizes...done
 Updating attachments table...done
 Updating boards and topics...done
 Updating members...done
 Recounting member pm totals (step 1)...done
 Recounting member pm totals (step 2)...done
 Converting server stored setting...done
 Converting avatar upload setting...done
 Updating attachments...done
 Updating settings...done
 Registering thumbs...done
 Adding image dimensions...done
 Splitting ban table...done
 Updating ban statistics...done
 Deleting some very old permissions...done
 Renaming permissions...done
 Upgrading "deny"-permissions...done
 Upgrading post based group permissions...done
 Upgrading by-board permissions...done
 Removing all guest deny permissions...done
 Removing guest admin permissions (if any)...done
 Creating search cache tables...done
 Rebuilding fulltext index...done
 Indexing topic subjects...done
 Converting settings...done
 Creating log table indexes (this might take some time!)...done
 Preparing log table upgrade...done
 Converting log tables (this might take some time!)...done
 Updating last message IDs for boards...done
 Cleaning up old log indexes...done
 Preparing messages table for strict upgrade...done
 Adjusting text fields...done
 Replacing messages index...done
 Adding log_topics index...done
 Updating the members table ...done
 Expanding message column size...done
 Sorting the boards...done
Moving to next script file...done
 Renaming table columns...........................................................................done
 Converting "log_online"...done
 Implementing board redirects...done
 Creating spider table...done
 Removing a spider...done
 Creating spider hit tracking table...done
 Making some changes to spider hit table...done
 Creating spider statistic table...done
 Resetting settings_updated...done
 Changing stats settings...done
 Enable cache if upgrading from 1.1 and lower..done
 Changing visual verification setting...done
 Changing visual verification setting, again...done
 Changing default personal text setting...done
 Removing allow hide email setting...done
 Ensuring stats index setting present...done
 Ensuring forum width setting present...done
 Replacing old calendar settings...done
 Deleting old calendar settings...done
 Adjusting calendar maximum year...done
 Adding advanced signature settings...done
 Updating spam protection settings...done
 Adjusting timezone settings...done
 Checking theme layers are correct for default themes...done
 Adding index to log_notify table...done
 Creating "custom_fields" table...done
 Adding search ability to custom fields...done
 Fixing default value field length...done
 Enhancing privacy settings for custom fields...done
 Checking display fields setup correctly...done
 Adding new custom fields columns...done
 Creating "log_digest" table...done
 Adding digest option to "members" table...done
 Creating "log_packages" table...done
 Adding extra "log_packages" columns...done
 Changing URL to SMF package server...done
 Creating "mail_queue" table...done
 Adding new mail queue settings...done
 Change mail queue indexes...done
 Adding type to mail queue...done
 Creating "log_reported" table...done
 Creating "log_reported_comments" table...done
 Adding moderator center permissions...done
 Adding moderation center preferences...done
 Creating member notices table...done
 Creating comments table...done
 Adding user warning column...done
 Ensuring warning settings are present...done
 Creating "log_group_requests" table...done
 Adding new membergroup table columns...done
 Creating "group_moderators" table...done
 Altering attachment table...done
 Populate the attachment extension...done
 Updating thumbnail attachments JPG...done
 Updating thumbnail attachments PNG...done
failed


!!
Error!

Error retrieving information on step: Updating thumbnail attachments PNG. (Item: 110)





SMF ©2011, Simple Machines

I hope you can help ¡¡  ;D

Thanks in advance  ;)

Offline jeronij

  • Semi-Newbie
  • *
  • Posts: 13
Re: How do I fix Updating thumbnail attachments PNG. (Item:110)
« Reply #3 on: July 02, 2011, 03:11:36 AM »
Hello again,

Nobody can give us a hand with this problem ? Or a clue about what to search at least ?  ;)

I tried a fresh new upgrade again. This time I dont have the same error, but I get stucked at the exact same point  :o ¡¡

Quote
SMF Upgrade Utility
Simple Machines Forum
Progress

    Step 1: Login
    Step 2: Upgrade Options
    Step 3: Backup
    Step 4: Database Changes
    Step 5: Delete Upgrade

63%
 
Overall Progress
68%
 
Step Progress
Time Elapsed: 13 mins, 32 seconds.
Database Changes
Executing database changes
Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made!
Executing upgrade script 2 of 2.
Executing: "Updating attachment data..." (12 of 42 - of this script)

Updating member approval...done
Adding new holidays...done
Updating event start and end dates...done
Converting other date columns...done
Checking for an old table...done
Creating "message_icons"...done
Inserting "message_icons"...done
Creating "package_servers"...done
Inserting "package_servers"...done
Updating flood control log...done
Updating ip address storage...done
Converting "log_online"...done
Updating poll column sizes...done
Updating attachments table...done
Updating boards and topics...done
Updating members...done
Recounting member pm totals (step 1)...done
Recounting member pm totals (step 2)...done
Converting server stored setting...done
Converting avatar upload setting...done
Updating attachments...done
Updating settings...done
Registering thumbs...done
Adding image dimensions...done
Splitting ban table...done
Updating ban statistics...done
Deleting some very old permissions...done
Renaming permissions...done
Upgrading "deny"-permissions...done
Upgrading post based group permissions...done
Upgrading by-board permissions...done
Removing all guest deny permissions...done
Removing guest admin permissions (if any)...done
Creating search cache tables...done
Rebuilding fulltext index...done
Indexing topic subjects...done
Converting settings...done
Creating log table indexes (this might take some time!)...done
Preparing log table upgrade...done
Converting log tables (this might take some time!)...done
Updating last message IDs for boards...done
Cleaning up old log indexes...done
Preparing messages table for strict upgrade...done
Adjusting text fields...done
Replacing messages index...done
Adding log_topics index...done
Updating the members table ...done
Expanding message column size...done
Sorting the boards...done
Moving to next script file...done
Renaming table columns........................................................................done
Converting "log_online"...done
Implementing board redirects...done
Creating spider table...done
Removing a spider...done
Creating spider hit tracking table...done
Making some changes to spider hit table...done
Creating spider statistic table...done
Resetting settings_updated...done
Changing stats settings...done
Enable cache if upgrading from 1.1 and lower..done
Changing visual verification setting...done
Changing visual verification setting, again...done
Changing default personal text setting...done
Removing allow hide email setting...done
Ensuring stats index setting present...done
Ensuring forum width setting present...done
Replacing old calendar settings...done
Deleting old calendar settings...done
Adjusting calendar maximum year...done
Adding advanced signature settings...done
Updating spam protection settings...done
Adjusting timezone settings...done
Checking theme layers are correct for default themes...done
Adding index to log_notify table...done
Creating "custom_fields" table...done
Adding search ability to custom fields...done
Fixing default value field length...done
Enhancing privacy settings for custom fields...done
Checking display fields setup correctly...done
Adding new custom fields columns...done
Creating "log_digest" table...done
Adding digest option to "members" table...done
Creating "log_packages" table...done
Adding extra "log_packages" columns...done
Changing URL to SMF package server...done
Creating "mail_queue" table...done
Adding new mail queue settings...done
Change mail queue indexes...done
Adding type to mail queue...done
Creating "log_reported" table...done
Creating "log_reported_comments" table...done
Adding moderator center permissions...done
Adding moderation center preferences...done
Creating member notices table...done
Creating comments table...done
Adding user warning column...done
Ensuring warning settings are present...done
Creating "log_group_requests" table...done
Adding new membergroup table columns...done
Creating "group_moderators" table...done
Altering attachment table...done
Populate the attachment extension...done
Updating thumbnail attachments JPG...done
Updating thumbnail attachments PNG...done
!!
Error!
Server has not responded for 30 seconds. It may be worth waiting a little longer or otherwise please click here to try this step again
SMF ©2011, Simple Machines

I waited for more than 12 hours and nothing. I tried clicking in Try Again and the same happens again. Server not responding... :(

I didnt mention before, I am upgrading from an old modded 1.1.5 to 2.0, but this error does not seem to be related to this, but to attachments, which I need to keep too  ::)

Thanks in advance to anyone who can make some light about this issue ¡¡  ;D

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,584
Re: How do I fix Updating thumbnail attachments PNG. (Item:110)
« Reply #4 on: July 02, 2011, 06:15:44 AM »
can you try restoring your old database, and upgrading to 1.1.14 first and then to 2.0? that may help a bit.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,584
Re: How do I fix Updating thumbnail attachments PNG. (Item:110)
« Reply #5 on: July 02, 2011, 06:48:32 AM »
you could also try this

Quote from: Norv
ETA2: I know why it happens on some upgrades. You may actually try this instead, too:
upgrade_2-0.sql
Code: [Select]
---# Adding file hash.
ALTER TABLE {$db_prefix}attachments
ADD COLUMN file_hash varchar(40) NOT NULL default '';
---#
Cut and move it before the previous step(s), somewhere like, before:
Code: [Select]
---# Populate the attachment extension.

Offline jeronij

  • Semi-Newbie
  • *
  • Posts: 13
Re: How do I fix Updating thumbnail attachments PNG. (Item:110)
« Reply #6 on: July 02, 2011, 12:31:17 PM »
Thanks for the replies. The problem was indeed with the file_hash field not being created by the upgrade script. I created it manually in the database and continued with the upgrade, and everything worked like a charm. Direct from 1.1.5 to 2.0 ¡¡  I found the reply here: http://www.simplemachines.org/community/index.php?topic=437353.msg3070478#msg3070478
Thanks to all for the assistance.  I'd hazard to say "Case Closed" ;)