Advertisement:

Author Topic: Vertex  (Read 82378 times)

Offline NanoSector

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,499
  • Gender: Male
  • VC321xb47@aperture:~#
    • Yoshi2889 on GitHub
Re: Vertex
« Reply #20 on: February 22, 2012, 09:29:13 AM »
Great theme, I installed it on my site, adjusted my logo and it looks really great :)
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Offline MLM

  • Full Member
  • ***
  • Posts: 498
    • Visual Pulse
Re: Vertex
« Reply #21 on: February 22, 2012, 03:38:06 PM »
Great theme :)
There's still one hard coded text in index.template.php:
<a href="', $scripturl ,'?action=login">', $txt['vp_login'] ,'</a> or <a href="', $scripturl ,'?action=register">', $txt['vp_register'] ,'</a>

;)

Its fine,  not all text needs to be a text string especially for small characters. Creates redundancy.
My Themes:
My Mods:
Unsolved Threads:
  • None atm...

Offline NanoSector

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,499
  • Gender: Male
  • VC321xb47@aperture:~#
    • Yoshi2889 on GitHub
Re: Vertex
« Reply #22 on: February 22, 2012, 03:42:04 PM »
Could you please fix the "Undefined index" errors in the next version?

I already fixed it on my site, but with my latest mod installed (which adds an Error Log counter into the Admin menu button) I was starting to get worried about what was happening ::)

In fact, it only requires you to put an empty() around the variable, like this:
Code: [Select]
if (!empty($settings['social_icons_present']))
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Offline MLM

  • Full Member
  • ***
  • Posts: 498
    • Visual Pulse
Re: Vertex
« Reply #23 on: February 22, 2012, 03:43:26 PM »
Could you please fix the "Undefined index" errors?

I already fixed it on my site, but with my latest mod installed (which adds an Error Log counter into the Admin menu button) I was starting to get worried about what was happening ::)

Already been fixed... read a couple posts up and download 1.1
My Themes:
My Mods:
Unsolved Threads:
  • None atm...

Offline phantomm

  • Sophist Member
  • *****
  • Posts: 1,064
  • Gender: Male
    • pages/smfpl/171860759503032 on Facebook
    • Polish ElkArte community
Re: Vertex
« Reply #24 on: February 22, 2012, 04:06:39 PM »
Its fine

Quote
// Vertex text file because we cant have hard coded text...

if you say so... but if someone uses this theme on site (like I do) and uses also different language than English (I'm using Polish) then I have to manual edit index.template.php because this text is not in ThemeStrings. For me it's fine, but just think about it...
Polskie wsparcie SMF na simplemachines.org

My mods

Offline NanoSector

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,499
  • Gender: Male
  • VC321xb47@aperture:~#
    • Yoshi2889 on GitHub
Re: Vertex
« Reply #25 on: February 22, 2012, 04:07:40 PM »
Could you please fix the "Undefined index" errors?

I already fixed it on my site, but with my latest mod installed (which adds an Error Log counter into the Admin menu button) I was starting to get worried about what was happening ::)

Already been fixed... read a couple posts up and download 1.1
I downloaded the theme today, and the issue was still in there.
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Offline MLM

  • Full Member
  • ***
  • Posts: 498
    • Visual Pulse
Re: Vertex
« Reply #26 on: February 22, 2012, 04:18:03 PM »
I downloaded the theme today, and the issue was still in there.

if you say so... but if someone uses this theme on site (like I do) and uses also different language than English (I'm using Polish) then I have to manual edit index.template.php because this text is not in ThemeStrings. For me it's fine, but just think about it...

welp, just added it so 1.2  8)

- Fixed undefined
- Added the or language string
My Themes:
My Mods:
Unsolved Threads:
  • None atm...

Offline Matthew K.

  • SMF Super Hero
  • *******
  • Posts: 12,430
  • Gender: Male
    • matthew.kerle on Facebook
    • @matthew_kerle on Twitter
Re: Vertex
« Reply #27 on: February 22, 2012, 04:25:26 PM »
Could you please fix the "Undefined index" errors in the next version?

I already fixed it on my site, but with my latest mod installed (which adds an Error Log counter into the Admin menu button) I was starting to get worried about what was happening ::)

In fact, it only requires you to put an empty() around the variable, like this:
Code: [Select]
if (!empty($settings['social_icons_present']))
I had to install this theme on someone's website, and I fix any and all errors that are encountered, even if it's the mods/themes fault. So I posted the fixes for MLM earlier, which he applied.

Also - To be politically correct? Very few inline text strings are allowed. (Copyrights, or unique names such as a company, etc. which would not be translated anyways). So in this case "Or" would need to be translated.

Offline NanoSector

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,499
  • Gender: Male
  • VC321xb47@aperture:~#
    • Yoshi2889 on GitHub
Re: Vertex
« Reply #28 on: February 22, 2012, 04:27:02 PM »
Could you please fix the "Undefined index" errors in the next version?

I already fixed it on my site, but with my latest mod installed (which adds an Error Log counter into the Admin menu button) I was starting to get worried about what was happening ::)

In fact, it only requires you to put an empty() around the variable, like this:
Code: [Select]
if (!empty($settings['social_icons_present']))
I had to install this theme on someone's website, and I fix any and all errors that are encountered, even if it's the mods/themes fault. So I posted the fixes for MLM earlier, which he applied.
Apparently not in my theme, then, as the issue was still going. The issue with the Facebook and Twitter icons was solved in the template I got, but not that issue.
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Offline kent[ka]

  • Semi-Newbie
  • *
  • Posts: 27
Re: Vertex
« Reply #29 on: February 22, 2012, 11:20:31 PM »
Well, looks like i have 2-0-2-v1-1 and not 2-0-2-v1-2  Do i need to uninstall the old one for the upgrade or how can i do it?

Offline MLM

  • Full Member
  • ***
  • Posts: 498
    • Visual Pulse
Re: Vertex
« Reply #30 on: February 22, 2012, 11:22:59 PM »
Well, looks like i have 2-0-2-v1-1 and not 2-0-2-v1-2  Do i need to uninstall the old one for the upgrade or how can i do it?

Just install the new one and apply that theme. They will be called the same thing so you may want to delete them. But if you look at the paths they will be different.
My Themes:
My Mods:
Unsolved Threads:
  • None atm...

Offline kent[ka]

  • Semi-Newbie
  • *
  • Posts: 27
Re: Vertex
« Reply #31 on: February 22, 2012, 11:34:34 PM »
Okay, i will remove the old one then, thanks for the fast reply. :D
« Last Edit: February 22, 2012, 11:57:31 PM by kent[ka] »

Offline impreza

  • Sophist Member
  • *****
  • Posts: 1,054
    • infomiasto.eu
Re: Vertex
« Reply #32 on: February 24, 2012, 04:54:52 AM »
nice style, very like his colors. Blue is cool
Portal infomiasto.eu - treści w postaci artykułów i filmów tematycznych

OnzeDanny

  • Guest
Re: Vertex
« Reply #33 on: February 24, 2012, 08:16:15 AM »
Cool this theme! Congrats !!!  8)

Offline Flavious

  • Semi-Newbie
  • *
  • Posts: 62
Re: Vertex
« Reply #34 on: February 24, 2012, 05:18:27 PM »
Hello all;

I have members all telling me they are not getting any email notifications. Where in the world in the vertex admin screens are the settings for email off the server? Or where else do I look for how SMF is sending emails?

Offline MLM

  • Full Member
  • ***
  • Posts: 498
    • Visual Pulse
Re: Vertex
« Reply #35 on: February 24, 2012, 05:20:19 PM »
Hello all;

I have members all telling me they are not getting any email notifications. Where in the world in the vertex admin screens are the settings for email off the server? Or where else do I look for how SMF is sending emails?

Nothing to do with the theme. The admin menus are untouched.
My Themes:
My Mods:
Unsolved Threads:
  • None atm...

Offline Skyflash

  • Semi-Newbie
  • *
  • Posts: 53
  • Gender: Male
  • SMF Newbie :)
    • Dragons of Atlantis Italia
Re: Vertex
« Reply #36 on: March 05, 2012, 07:29:33 AM »
Great theme! I'm using it on my new project (i'm newbie of SMF, sorry if i'm asking something stupid :) ) at this address doaitalia.it

I'm using Vertex theme combined with ADK Portal modification. Everything seems good with your theme, but i'm having a little problem with the ADK Portal function that permits me showing its sidebar into the forum (sorry for my bad english... i attach an image for better explain)



I've tried some other themes, the adk portal's right colum is correctly sown in the forums, but not in Vertex.
Is not a great problem, i'm simply asking you if maybe a mistake in the theme sources, or it don't use the same function called by adk portal.

Oh, i have another question: i've set a background image url in the theme settings:



but the only way i've found for displaying it (i know, it's horrible logo... i must redo it :) ) was manual editing of the index.php :(
« Last Edit: March 05, 2012, 07:47:45 AM by Skyflash »

Offline Demonic722

  • Semi-Newbie
  • *
  • Posts: 27
Re: Vertex
« Reply #37 on: March 05, 2012, 07:19:54 PM »
Oh, i have another question: i've set a background image url in the theme settings:



but the only way i've found for displaying it (i know, it's horrible logo... i must redo it :) ) was manual editing of the index.php :(
I like this theme as well and I plan to use it on my site as soon as I get more info as to how to fix some of the errors I'm experiencing as well. One of the errors I found was the Logo display as well. I couldn't get it to work in the SMF settings, but I copied the path of where the "Vertex" Logo was loading from and replaced it.

@Skyflash, if you're unsure as to where it is, look here:
Code: [Select]
/Themes/Vertex-Theme2-0-2-v1-2/images/vertex_image/banner_logo.png

I simply replaced the "banner_logo.png" file with my own picture and renamed it to "banner_logo.png" and it worked. Its not as efficient as manually uploading the path of your image and pasting it into the SMF Settings, but it works.

Another problem would be in the menu bar. I've taken a snip of the error I'm getting:


I'm not sure what's causing that, but is there a way it could be fixed? It's only working like that on my current site, but I've tried it on a fresh SMF and everything worked fine...Also, the scroll thing (I'm not sure what it's called) is supposed to follow the cursor of the mouse in the menu bar, but on my site, it doesn't (it does on the fresh SMF though).

Some Background Information:
- I'm running SMF Version 2.0.2. It's not a fresh SMF Site, but rather an upgrade from Version 2.0.1. I'm not sure if that's the problem or not..

- I'm running SimplePortal on my site so if that's causing an issue, let me know.

Thanks in advance! :)

Offline Skyflash

  • Semi-Newbie
  • *
  • Posts: 53
  • Gender: Male
  • SMF Newbie :)
    • Dragons of Atlantis Italia
Re: Vertex
« Reply #38 on: March 06, 2012, 04:15:01 AM »
@Skyflash, if you're unsure as to where it is, look here:
Code: [Select]
/Themes/Vertex-Theme2-0-2-v1-2/images/vertex_image/banner_logo.png

I simply replaced the "banner_logo.png" file with my own picture and renamed it to "banner_logo.png" and it worked. Its not as efficient as manually uploading the path of your image and pasting it into the SMF Settings, but it works.
I preferred modify the index.php file, but the result was the same :)

Quote
Another problem would be in the menu bar. I've taken a snip of the error I'm getting:


I'm not sure what's causing that, but is there a way it could be fixed?
As i said, i'm new to SMF and its framework, but in my Wordpress and Joomla experience, i thik maybe related to a Javascript library you load in your forum.

Vertex uses jQuery. Look if you're loading the same library twice (other mods that uses jQuery, mooTools etc?) and if the two libraries has different versions.

Offline Skyflash

  • Semi-Newbie
  • *
  • Posts: 53
  • Gender: Male
  • SMF Newbie :)
    • Dragons of Atlantis Italia
Re: Vertex
« Reply #39 on: March 06, 2012, 06:21:18 AM »
I'm not sure what's causing that, but is there a way it could be fixed? It's only working like that on my current site, but I've tried it on a fresh SMF and everything worked fine...Also, the scroll thing (I'm not sure what it's called) is supposed to follow the cursor of the mouse in the menu bar, but on my site, it doesn't (it does on the fresh SMF though).
Install this Chrome Extension and reload the page

You should see all the javascript libraries your site is loading (see the attached picture)