Advertisement:

Author Topic: YaBB 2.5AE to SMF2.0 error  (Read 16777 times)

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
YaBB 2.5AE to SMF2.0 error
« on: July 18, 2011, 06:28:31 AM »
During the conversion process, I get the following error...

Converting...
Converting mark read data...The database value you're trying to insert does not exist: id_member


Is it because the converter is for Y2.2, and I am using Y2.5?

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
Re: YaBB 2.5AE to SMF2.0 error
« Reply #1 on: July 29, 2011, 05:30:41 AM »
Same error if I convert from YaBB 2.2

From YaBB 2.1, I get:
Successful.
Converting membergroups...
Successful.
Converting members...
array(6) {
  • => array(4) { ["file"]=> string(35) "/var/www/smf2test/yabb21_to_smf.php" ["line"]=> int(219) ["function"]=> string(10) "alterTable" ["args"]=> array(4) {
  • => &string(7) "members" [1]=> &array(1) { ["PRIMARY"]=> string(16) "DROP PRIMARY KEY" } [2]=> &string(0) "" [3]=> &array(1) { ["id_member"]=> string(74) "CHANGE COLUMN id_member id_member mediumint(8) unsigned NOT NULL default 0" } } } [1]=> array(2) { ["function"]=> string(12) "convertStep3" ["args"]=> array(0) { } } [2]=> array(4) { ["file"]=> string(29) "/var/www/smf2test/convert.php" ["line"]=> int(1346) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) {
  • => &string(12) "convertStep3" } } [3]=> array(4) { ["file"]=> string(29) "/var/www/smf2test/convert.php" ["line"]=> int(973) ["function"]=> string(17) "run_php_converter" ["args"]=> array(0) { } } [4]=> array(2) { ["function"]=> string(7) "doStep1" ["args"]=> array(0) { } } [5]=> array(4) { ["file"]=> string(29) "/var/www/smf2test/convert.php" ["line"]=> int(51) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) {
  • => &string(7) "doStep1" } } } Incorrect table name ''

Offline jason192222

  • Newbie
  • *
  • Posts: 5
Re: YaBB 2.5AE to SMF2.0 error
« Reply #2 on: September 22, 2011, 08:32:37 AM »
Is your problem solved ? I don't have YaBB but one of my friend have a YaBB forum. Do you know how can i add user's in my SMF

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
Re: YaBB 2.5AE to SMF2.0 error
« Reply #3 on: September 22, 2011, 09:03:04 AM »
Is your problem solved ? I don't have YaBB but one of my friend have a YaBB forum. Do you know how can i add user's in my SMF
Yes, mind solved.

YaBB 2.5AE > yabb 2.4-smf1 tool > smf1.1.4 > smf2 > fix boards and perms > smf2.0.1

Loses any pms in yabb's pm store (not inbox or sent items though)

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
Re: YaBB 2.5AE to SMF2.0 error
« Reply #4 on: September 28, 2011, 05:21:40 PM »
I am now live with SMF 2.0.1 :D

My old YaBB site is now set to read-only, and only deals with old incoming links :)