Advertisement:

Author Topic: SA Twitter Integration  (Read 125079 times)

Offline darcysarto

  • Semi-Newbie
  • *
  • Posts: 35
Re: SA Twitter Integration
« Reply #20 on: August 29, 2011, 05:26:54 PM »
sry for the long wait

just a hunch do you have datasebase driven sessions enabled?

Yes it was enabled, I have turned it off but the problem still exists.

Offline kingkingston

  • Full Member
  • ***
  • Posts: 650
  • Gender: Male
    • @ozzysportsforum on Twitter
    • aussiesportsforum.com
Re: SA Twitter Integration
« Reply #21 on: August 31, 2011, 01:05:05 PM »
Hi, I've just installed this and attempting to test it I get this error:

Quote
The database value you're trying to insert does not exist: p_twitname
I got that same message when i registered at your site but it registered me anyway

Offline darcysarto

  • Semi-Newbie
  • *
  • Posts: 35
Re: SA Twitter Integration
« Reply #22 on: September 01, 2011, 04:31:05 AM »
I got that same message when i registered at your site but it registered me anyway

Hi yes, thanks for trying it.  Yes it does still register you, although I don’t think you can then actually login with your Twitter account?

Offline mxcape21

  • Semi-Newbie
  • *
  • Posts: 75
    • TechMedia
Re: SA Twitter Integration
« Reply #23 on: September 01, 2011, 07:52:43 PM »
How can I manually un-install this mod, my site suddenly won't load at all and this mod is the only error showing in the logs?  ???
It worked just fine for a week and all of a sudden KA-POW, white screen with no display of errors or reason for site not loading....

Note this is not the site in my sig.

Edit; Yep...that was it, I deleted all of the files for this mod and everything is back to normal, the site is accessible with no errors.

Thanks anyway  ::)
« Last Edit: September 01, 2011, 09:42:42 PM by mxcape21 »
The only thing I can presume, since I know I'm not crazy (certifiably at least), is that everybody else is until they prove otherwise! 8)
http://techraffle.com/forum/index.php

Offline awolexpat

  • Jr. Member
  • **
  • Posts: 129
Re: SA Twitter Integration
« Reply #24 on: September 02, 2011, 03:16:21 AM »
I am getting an error in my logs which I can only presume is related to this mod (thanks by the way as I had been waiting for it!). The error is as follows:

http://www.awolonline.net/forum/index.php?action=register
2: Invalid argument supplied for foreach()
File: /home/xxxxxxx/public_html/forum/twitterauth/lib/Twitter.php
Line: 394

This looks like it is something to do with Guests trying to register using their Twitter ID but I have no idea really. I have not altered the file in question and it installed without a hitch. Can anyone help?

Offline darcysarto

  • Semi-Newbie
  • *
  • Posts: 35
Re: SA Twitter Integration
« Reply #25 on: September 02, 2011, 05:05:05 AM »
I have now switched this mod off.  Has anyone actually got it working?

Offline Errapolis

  • Semi-Newbie
  • *
  • Posts: 25
Re: SA Twitter Integration
« Reply #26 on: September 04, 2011, 12:06:53 AM »
I'm so pleased this mod is now available, thank you!  I've got it working fine on my website.

However, my own theme is a customised version of curve, and I was looking for a way to place the Twitter login button just under my Facebook login button in the site header.

With Facebook (i'm using your SA Facebook mod) I simply copied the HTML for the button from the Login page of SMF and pasted it into index.template.php.  However with the Twitter login button, I can't as it seems to generate a new oauth token each time.

Is there an easy way of dropping the button into the theme coding somehow?

Here's my site: http://forum.onlyanexcuse.com/

I'd like the button to sit just under my Facebook Connect button at the top-right of the screen.  I'd be okay in adding this to the index.template.php file, what I need is the right code to put in there.  I looked through the mod's files but i'm none the wiser.

If you can help then that would be great, or even a push in the right direction.  Thanks!

Offline SA™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,954
  • (T)ogether (E)veryone (A)chieves (M)ore
    • DenotsNiaga on Facebook
    • SAChatBar
Re: SA Twitter Integration
« Reply #27 on: September 05, 2011, 11:00:31 AM »
your need to call

twit_init();

then you can use the $url varible like

Code: [Select]
global $url;
twit_init();
echo'<a href="'.$url.'"><img src="http://si0.twimg.com/images/dev/buttons/sign-in-with-twitter-l.png" alt="'.$txt['twittsign'].'"/></a>';
http://samods.github.io/SAChatBar/

Xbox Live: smokerthecheese 360 or xbone
My Work
Piano Movers / Delivery service
Quote
My allies are dead.
I'm 'bout to be too.
Zombies are chasing me.
F*** it, I'm screwed -___-

Offline SA™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,954
  • (T)ogether (E)veryone (A)chieves (M)ore
    • DenotsNiaga on Facebook
    • SAChatBar
Re: SA Twitter Integration
« Reply #28 on: September 05, 2011, 11:03:55 AM »
I am getting an error in my logs which I can only presume is related to this mod (thanks by the way as I had been waiting for it!). The error is as follows:

http://www.awolonline.net/forum/index.php?action=register
2: Invalid argument supplied for foreach()
File: /home/xxxxxxx/public_html/forum/twitterauth/lib/Twitter.php
Line: 394

This looks like it is something to do with Guests trying to register using their Twitter ID but I have no idea really. I have not altered the file in question and it installed without a hitch. Can anyone help?

in that file line 394 you can add
$obj = array();
before
 $obj = json_decode($this->responseText);
http://samods.github.io/SAChatBar/

Xbox Live: smokerthecheese 360 or xbone
My Work
Piano Movers / Delivery service
Quote
My allies are dead.
I'm 'bout to be too.
Zombies are chasing me.
F*** it, I'm screwed -___-

Offline awolexpat

  • Jr. Member
  • **
  • Posts: 129
Re: SA Twitter Integration
« Reply #29 on: September 05, 2011, 11:53:08 AM »
Thanks SA - I have made that edit and will only post on here again if the errors continue.

Offline Errapolis

  • Semi-Newbie
  • *
  • Posts: 25
Re: SA Twitter Integration
« Reply #30 on: September 05, 2011, 04:46:00 PM »
Much appreciated SA, going to try this out now. Cheers!

Offline Errapolis

  • Semi-Newbie
  • *
  • Posts: 25
Re: SA Twitter Integration
« Reply #31 on: September 05, 2011, 06:34:21 PM »
your need to call

twit_init();

then you can use the $url varible like

Code: [Select]
global $url;
twit_init();
echo'<a href="'.$url.'"><img src="http://si0.twimg.com/images/dev/buttons/sign-in-with-twitter-l.png" alt="'.$txt['twittsign'].'"/></a>';

I tried putting this in but to no avail, and tried messing about with it to try get it working, but it ended up confusing me no end.

I want to place it in a div container (called "twbox" which I can use to position it under the FB button), then into the index.template.php inside the "top_section" div of the curve theme.

If it's possible you could help further it would be greatly appreciated.  PHP isn't my forte, sadly.

Offline awolexpat

  • Jr. Member
  • **
  • Posts: 129
Re: SA Twitter Integration
« Reply #32 on: September 06, 2011, 09:24:37 PM »
Sorry to report that the error has started appearing again - to save anyone searching it is this:
 Guest 66.249.68.114        Today at 05:46 AM  58f390da47f21f73c162a6ed3afe3bc9
 Type of error: General
hxxp://www.awolonline.net/forum/index.php?topic=527.02: Invalid argument supplied for foreach()
File: /home/xxxxxxx/public_html/forum/twitterauth/lib/Twitter.php
Line: 395

Different line I guess because of the edit made. Any ideas?

Offline SA™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,954
  • (T)ogether (E)veryone (A)chieves (M)ore
    • DenotsNiaga on Facebook
    • SAChatBar
Re: SA Twitter Integration
« Reply #33 on: September 08, 2011, 10:41:43 AM »
@Errapolis
if you can post up the file your editing i can show you what todo

@awolexpat
thanks for testing that i think im going to use a different twitter lib in the next realse the current one does seem a ittle to buggy for my liking
http://samods.github.io/SAChatBar/

Xbox Live: smokerthecheese 360 or xbone
My Work
Piano Movers / Delivery service
Quote
My allies are dead.
I'm 'bout to be too.
Zombies are chasing me.
F*** it, I'm screwed -___-

Offline darcysarto

  • Semi-Newbie
  • *
  • Posts: 35
Re: SA Twitter Integration
« Reply #34 on: September 09, 2011, 05:17:02 AM »
@Errapolis
if you can post up the file your editing i can show you what todo

@awolexpat
thanks for testing that i think im going to use a different twitter lib in the next realse the current one does seem a ittle to buggy for my liking

Any news on the 'The database value you're trying to insert does not exist: p_twitname' error?

Offline anicolac

  • Semi-Newbie
  • *
  • Posts: 49
    • Apple Maniacos
Re: SA Twitter Integration
« Reply #35 on: September 11, 2011, 05:01:51 AM »
the mod works great, but I stop working some functionality of TinyPortal, such as block management.
Anyone else has happened?
----------------
el mod funciona muy bién, pero me deja de funcionar alguna funcionalidad de Tinyportal, como por ejemplo la gestión de bloques.
A alguién más le ha pasado?

Saludos y gracias.
« Last Edit: September 12, 2011, 08:58:33 AM by anicolac »

Offline Danni_X

  • Semi-Newbie
  • *
  • Posts: 10
Re: SA Twitter Integration
« Reply #36 on: September 19, 2011, 08:05:14 PM »
Yes,me.
It's a problem with TinyPortal and this.
When SA twitter is enable dont work admin from tiny portal and error is Fatal error: Cannot redeclare get_boards() (previously declared in /home/****/public_html/Sources/Twitter/TwitterHooks.php:293) in /home/****/public_html/Sources/TPortalAdmin.php on line 3877

get_boards() is declared in tinyportal files.

Offline phantomm

  • Sophist Member
  • *****
  • Posts: 1,064
  • Gender: Male
    • pages/smfpl/171860759503032 on Facebook
    • Polish ElkArte community
Re: SA Twitter Integration
« Reply #37 on: September 20, 2011, 06:12:40 PM »
i think i have the same error as awolexpat
Code: [Select]
/index.php?/board,31.0.html
2: Invalid argument supplied for foreach()
File: /home/xxx/domains/xxx/public_html/twitterauth/lib/Twitter.php
Line: 396

how to fix it?
Polskie wsparcie SMF na simplemachines.org

My mods

Offline Danni_X

  • Semi-Newbie
  • *
  • Posts: 10
Re: SA Twitter Integration
« Reply #38 on: September 26, 2011, 02:33:01 AM »
Yes,me.
It's a problem with TinyPortal and this.
When SA twitter is enable dont work admin from tiny portal and error is Fatal error: Cannot redeclare get_boards() (previously declared in /home/****/public_html/Sources/Twitter/TwitterHooks.php:293) in /home/****/public_html/Sources/TPortalAdmin.php on line 3877

get_boards() is declared in tinyportal files.

PLS help me to fix it!

Offline SA™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,954
  • (T)ogether (E)veryone (A)chieves (M)ore
    • DenotsNiaga on Facebook
    • SAChatBar
Re: SA Twitter Integration
« Reply #39 on: September 26, 2011, 02:52:44 PM »
try this package
http://samods.github.io/SAChatBar/

Xbox Live: smokerthecheese 360 or xbone
My Work
Piano Movers / Delivery service
Quote
My allies are dead.
I'm 'bout to be too.
Zombies are chasing me.
F*** it, I'm screwed -___-