Advertisement:

Author Topic: New and Old Install error "Template Parse Error"  (Read 7207 times)

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
New and Old Install error "Template Parse Error"
« on: August 25, 2011, 05:35:52 AM »
Hi.

Some weeks ago, I have a 2.0RC3 install and works good.
Now, give me error in some cases.
Per example when i try to register a new user say this:

Code: [Select]
Template Parse Error!

It seems something has gone sour on the forum with the template system. This problem should only be temporary, so please come back later and try again. If you continue to see this message, please contact the administrator.

You can also try refreshing this page.

Also, I I try to go to Feature Setings, or Package Manager or other say some similar:


Code: [Select]
Template Parse Error!

There was a problem loading the /Themes/default/Packages.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.

Now, I download final version 2.0, and install in new database and new directory and have the same problems.

What happend ?

I try too, put 755 chmod to all files, and same problem.

Can anyone help me, please ?

I don´t know How to do.

Thanks.

kat

  • Guest
Re: New and Old Install error "Template Parse Error"
« Reply #1 on: August 25, 2011, 06:01:00 AM »
Hi, eldanas! Welcome to the forum!

As that second message mentions language files, what language is your forum using?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,045
Re: New and Old Install error "Template Parse Error"
« Reply #2 on: August 25, 2011, 06:04:38 AM »
sounds like an issue with the themes not being updated or uploaded completely on your server.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #3 on: August 27, 2011, 04:08:08 AM »
Hi, eldanas! Welcome to the forum!

As that second message mentions language files, what language is your forum using?

I use the standard of the new instalation.
I install over 0 all.

No chages made, only standard install.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #4 on: August 27, 2011, 04:10:16 AM »
sounds like an issue with the themes not being updated or uploaded completely on your server.
I don´t channge anything.
I do a new standard install.
Also, I do a new database with new user, and new 2.0 install, and give the same error.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #5 on: August 27, 2011, 05:30:06 AM »
Other example, when not login in forum, and click to register.

Code: [Select]
Template Parse Error!
It seems something has gone sour on the forum with the template system. This problem should only be temporary, so please come back later and try again. If you continue to see this message, please contact the administrator.

You can also try refreshing this page.



Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,045
Re: New and Old Install error "Template Parse Error"
« Reply #6 on: August 27, 2011, 06:40:39 AM »
can you or your host verify the ownership and chmod of all your theme and language files?

How do I chmod? / what is chmod?

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #7 on: August 27, 2011, 05:15:02 PM »
can you or your host verify the ownership and chmod of all your theme and language files?

How do I chmod? / what is chmod?

All files have 755

kat

  • Guest
Re: New and Old Install error "Template Parse Error"
« Reply #8 on: August 27, 2011, 05:18:14 PM »
Do you OWN the files?

Only your host can tell you that.

This explains it all rather well.

http://en.wikipedia.org/wiki/Chown

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,045
Re: New and Old Install error "Template Parse Error"
« Reply #9 on: August 27, 2011, 05:19:10 PM »
files should be 644 not 755 that might help.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #10 on: August 27, 2011, 05:39:17 PM »
files should be 644 not 755 that might help.
Code: [Select]
I change to 644 and report all pages this error:

Forbidden
You don't have permission to access /index.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

And the files are my own files. (normaly)

I change again 755 an now work the forum, but report same error to access in some parts, and register part.


Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,045
Re: New and Old Install error "Template Parse Error"
« Reply #11 on: August 27, 2011, 05:55:25 PM »
ask your host to check your file permissions

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #12 on: August 27, 2011, 06:05:26 PM »
ask your host to check your file permissions

My file permision is Ok. (because if were wrong, forum not work at all, but now some pages work good)
Is not a file permision problem. Have 755 and own files.
The forum works, exceps some places, like register, packages, users ... but forum works good, because see the posts.

Something extrange happend, and not know how !!

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,045
Re: New and Old Install error "Template Parse Error"
« Reply #13 on: August 27, 2011, 06:09:49 PM »
you are not telling us why those pages dont work. and i am not sold on this not being a permissions issue even if some pages are working.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #14 on: August 27, 2011, 06:21:06 PM »
you are not telling us why those pages dont work. and i am not sold on this not being a permissions issue even if some pages are working.

Well.
I have all my files to 755 permisions. rwx-rx-rx, and all files are my own.
Show the General discusion forum well, and hel, login page ..etc..
The forum, now show the index.php good, but if click in register, show the error.

Can see here: http://tuwebenlared.com/gpro [nofollow]

Before, when enter as admin, can´t enter in users, pacakges, forums, show the error.

I hope explain good, my english is not very well ;-)

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,045
Re: New and Old Install error "Template Parse Error"
« Reply #15 on: August 27, 2011, 06:33:39 PM »
shows what error?

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #16 on: August 28, 2011, 02:50:17 AM »
shows what error?
go to website and try to register to view error.

kat

  • Guest
Re: New and Old Install error "Template Parse Error"
« Reply #17 on: August 28, 2011, 10:45:36 AM »
Just a hunch...

These two files:

Sources>Register.php

Themes>Default>Register.template.php

Do they exist? If they do, are they read-enabled?

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #18 on: August 28, 2011, 01:40:56 PM »
Just a hunch...

These two files:

Sources>Register.php

Themes>Default>Register.template.php

Do they exist? If they do, are they read-enabled?

Yes, exists and have rwx-rx-rx, and size is 28.002, is the orignal of a new installation.
Register.php, have rwx-rx-rx, and size is 32,024, is the orignal of a new installation.

kat

  • Guest
Re: New and Old Install error "Template Parse Error"
« Reply #19 on: August 28, 2011, 04:09:46 PM »
You still haven't told us if you have FULL OWNERSHIP of the files on your site.

As I said, earlier, your host will need to confirm that.

I'm not talking "CHMOD". I'm talking "CHOWN".