Advertisement:

Author Topic: New and Old Install error "Template Parse Error"  (Read 7123 times)

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #20 on: August 29, 2011, 02:33:54 AM »
You still haven't told us if you have FULL OWNERSHIP of the files on your site.

As I said, earlier, your host will need to confirm that.

I'm not talking "CHMOD". I'm talking "CHOWN".

I say yes some post ago.
Are my own files.

rwx-rx-rx   eldanas  eldanas  Register.template.php 28,002  06/06/2011 19:43:45

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #21 on: August 30, 2011, 05:37:45 AM »
I go to the error log and show me this:

Code: [Select]
Apply Filter: Only show the error messages of this member Guest
Apply Filter: Only show the error messages of this IP address 83.33.137.230 
  Reverse chronological order of list Today at 04:33:54 AM
Apply Filter: Only show the error messages of this session 81a24b751d519dd68ab6c6b480b05f99
Apply Filter: Only show the errors of this type Type of error: General
Apply Filter: Only show the error messages of this URL
http://tuwebenlared.com/gpro/index.php?action=register
Apply Filter: Only show the errors with the same message
2: Please contact support about failure
Apply Filter: Only show the errors from this file
File: /home/eldanas/public_html/gpro/Sources/Load.php
Line: 2151

If I click to the file show me this:

Code: [Select]
2148: // Are we going to use eval?
2149: if (empty($modSettings['disableTemplateEval']))
2150: {
==>2151: $file_found = file_exists($filename) && eval('?' . '>' . rtrim(file_get_contents($filename))) !== false;
2152: $settings['current_include_filename'] = $filename;
2153: }

How can solve ?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #22 on: August 30, 2011, 05:46:33 AM »
is that the full error message? usually when load.php is in the error message it is an eval message and the error is elsewhere.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #23 on: August 30, 2011, 05:56:09 AM »
is that the full error message? usually when load.php is in the error message it is an eval message and the error is elsewhere.
I onle see this in the error log.
Where can see if there are more ?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #24 on: August 30, 2011, 06:02:25 AM »
look for the error in the error log without sorting and see if it is different.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #25 on: August 30, 2011, 06:18:23 AM »
look for the error in the error log without sorting and see if it is different.
I see the same error.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #26 on: August 30, 2011, 06:19:53 AM »
it looks like from the message and code you posted it is an eval error. are you sure you disabled template evaluation in the server settings page?

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #27 on: August 30, 2011, 06:35:18 AM »
it looks like from the message and code you posted it is an eval error. are you sure you disabled template evaluation in the server settings page?
I can not access to Server Sttings by forum. (say me the same error, template parse error)
Can I change en database directly or in a file ?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #28 on: August 30, 2011, 06:40:21 AM »
run this in phpmyadmin given that your table prefix is smf_
Code: [Select]
REPLACE INTO smf_settings VALUES ('disableTemplateEval', 1);

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #29 on: August 30, 2011, 06:47:59 AM »
run this in phpmyadmin given that your table prefix is smf_
Code: [Select]
REPLACE INTO smf_settings VALUES ('disableTemplateEval', 1);
I haven´t disableTemplateEval variable in smf_setings.
I have create the variable into the table with value 1, and now works all good.

So much thanks, to solve the problem.  :D
I know how more do it to solve !!!

That I can´t understand is that in a new install, not work and must add this variable !!!  :o

Thank you again.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #30 on: August 30, 2011, 06:49:47 AM »
adding that does not fix the problem, but tells you what the exact error is. now check your error log.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #31 on: August 30, 2011, 06:53:34 AM »
adding that does not fix the problem, but tells you what the exact error is. now check your error log.

Yes, the problem has solve. Now works all good.
Register, package manager, users ... all functions works good now.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #32 on: August 30, 2011, 06:55:26 AM »
well it should not, your error log should tell you the error you were getting so we can actually fix it.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #33 on: August 30, 2011, 06:59:51 AM »
well it should not, your error log should tell you the error you were getting so we can actually fix it.
Don´t know, but now all works good.
Can you enter in de website and click to register and now works.
And other problem that I had in admin, works too.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #34 on: August 30, 2011, 07:01:55 AM »
have you actually checked the error log?

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #35 on: August 30, 2011, 07:17:26 AM »
have you actually checked the error log?
No error in error log.
I clean the error when works, and now are clean and works all functions.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,477
Re: New and Old Install error "Template Parse Error"
« Reply #36 on: August 30, 2011, 07:18:48 AM »
strange it should not be that way, but i will mark this thread solved.

Offline eldanas

  • Semi-Newbie
  • *
  • Posts: 20
Re: New and Old Install error "Template Parse Error"
« Reply #37 on: August 30, 2011, 07:29:52 AM »
strange it should not be that way, but i will mark this thread solved.

Very strange, but solve.
Mark as solve.

Lot of Thanks.