News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

Installed Tiny Portal and got this.

Started by MichiganMinis, May 24, 2005, 10:36:00 AM

Previous topic - Next topic

MichiganMinis

 I just installed Tiny Portal and now I can get my forum to work at all.

I got this message.
Warning: main(/home/michiga1/public_html/forum/Sources/TPortal.php) [function.main]: failed to open stream: No such file or directory in /home/michiga1/public_html/forum/index.php on line 57

Fatal error: main() [function.require]: Failed opening required '/home/michiga1/public_html/forum/Sources/TPortal.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/michiga1/public_html/forum/index.php on line 57

[Unknown]

Looks like it didn't install properly.  You can upload all the files from the upgrade zip file to get things working again.

I suggest you ask in the topic about the mod for more information.

-[Unknown]

MichiganMinis

I fixed it but now I have this.

Table 'michiga1_smf1.tportal_settings' doesn't exist
File: /home/michiga1/public_html/forum/Sources/TPortal.php
Line: 40

Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.3, whereas your database is at version SMF 1.0. It is recommended that you execute the latest version of upgrade.php.

[Unknown]

Again, it wasn't installed fully/correctly.  To fix it, upload all the files from the "upgrade" package and try installing it again.

-[Unknown]

MichiganMinis

I am lost. I cant get anywhere with out that message. So how to I upload the upgrade package? I tried to do it all manually. But that wont work.

bloc

Just upload the upgrade package through FTP and OVERWRITE existing files, then do a "...yourpath/upgrade.php" and the forum will presumeably work fine afterwards.

The reason why the mod did not work in the first place, i am not sure, but it did not get installed correctly for some reason. If you are using anything but the most recent beta, it may well be that whats causing it to not install proper. Although beta4/5 (which I assume you have, since I don't have you on my beta-testers list) should work from the start.

MichiganMinis

OK, so now how to I uninstall the portal. I get this message after the upgrade:
Table 'michiga1_smf1.tportal_settings' doesn't exist
File: /home/michiga1/public_html/forum/Sources/TPortal.php
Line: 40

I can not get to the admin page to uninstall the portal.

Kindred

to uninstall, you will have to upload clean versions of the SMF source and templae files.

TinyPortal is currently in beta... and does not have a clean uninstall...

Download the upgrade ZIP file.
unzip on your local drive
use FTP to upload all files to your server in the appropriate directories.

note: You will also lose any other mods that you have installed...
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

MichiganMinis


bloc

Its like this: TinyPortal adjusts 3 files: forum/index.php , forum/Sources/Load.php and forum/Themes/default/index.tempalte.php.

If you overwrite these 3 files with same files from the upgrade package, or make sure they are overwritten during upgrade, TP will be "gone".

MichiganMinis

All that is done. Now it just wont go into anything.

Check it out. www.michiganminis.com/forum

MichiganMinis


penmin

2: copy(/home2/penadmin/public_html/smf/Themes/default/images/divider.gif): failed to open stream: Permission denied
File: /home2/penadmin/public_html/smf/Sources/Subs-Package.php
Line: 814


Both Bloc and I are baffled  :'(
We ruled out the safe mode issue when I talked with my hoster.

Any suggestions?

Advertisement: