Wondering if this will always be free?  See why free is better.

Main Menu

500 Internal Error when try to install any mod

Started by JadeCat95, October 06, 2011, 05:28:47 AM

Previous topic - Next topic


I seriously need some help ASAP. Our forum is currently in maintenance mode for 1.1.14 > 2.0.1 upgrade and I'm having serious issues trying to install mods.

Every time I hit "Install Now", it sits for a while and then I get a 500 Internal Server error. This is what the page says:

QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache mod_qos/9.69 mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ Server at Port 80

I've tried several different mods and they all do the same thing.

When I check my Control Panel error log, I see this:

Quote[Thu Oct 06 04:20:01 2011] [error] [client] File does not exist: /home/ab5061/public_html/500.shtml, referer:;area=packages;sa=install;
[Thu Oct 06 04:18:01 2011] [error] [client] File does not exist: /home/ab5061/public_html/500.shtml, referer:;area=packages;sa=install;
[Thu Oct 06 04:16:01 2011] [error] [client] File does not exist: /home/ab5061/public_html/500.shtml, referer:;area=packages;sa=install;

Can anyone please help me try to figure this out, or does anyone know what the problem is?

Our host is Hostgator. If any more info is needed, let me know what you need.

I'm desperate and pressed for time. :(


check the file permissions on the packages you are trying to install, chmod them 644 and try again.


Quote from: Illori on October 06, 2011, 05:38:37 AM
check the file permissions on the packages you are trying to install, chmod them 644 and try again.
I did this with two separate packages and no change. :(


well then best i can tell you is get a non-oversold host and see if that helps.


Quote from: Illori on October 06, 2011, 05:56:36 AM
well then best i can tell you is get a non-oversold host and see if that helps.
After doing some searching around these threads, that seems to be a common "fix".

No other ideas to fix this?? Anything specific to report to the host?


that they are terrible, and scam users out of their money for services they cant really provide? nope nothing that i know of you can tell them to fix the problem.


I just thought of something....

We are running a mirror forum on the same host and the package installer there is working fine. Is there a file, or files that could be copied to the main forum that might help this issue?



This can happen due to various reasons

- Misconfiguration of the server: The server was trying to handle a request that it was not able to successfully fulfill
- Invalid file permissions on some files
- Could be an invalid .htaccess file
- Error in a cgi script that caused it to fail or output an error message before it started producing valid HTML
Github Profile
Android apps

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved


There IS a file called "mod_security.htaccess" that I had never noticed before (although that doesn't mean it wasn't there), that said something about Apache server not working with SMF very well and to either rename the file to ".htaccess" or add two lines, "SecFilterEngine Off" and "SecFilterScanPOST Off" to the .htaccess of the forums root file.

However, when I tried that, the whole forum became unavailable coming back with the 500 error.  That "mod_security.htaccess" file is now sitting in both the Packages folder and the root forum folder.


ask your host if mod_security is running on the server, if so ask if they can disable it, it often causes more issues then it fixes.


I have given this new info to our server, and they are going to try to debug it.

Thank you for your help and I will update the process if needed.



Ok, right now, my server is telling me that I may be trying to use more than the allocated memory in trying to install the plugins. That the plugins may still be effectively running;

"I'd almost recommend attempting to disable all the plugins while attempting the upgrade as those plugins are going to be using memory out of your 64MB total. It's possible the problems are a result of the PHP memory running out because the memory is in use by the plugins."

I had tried to uninstall them before the upgrade, but was getting the same 500 error.

What I need to know now, is, can I manually delete the plugin file/folders from the server without messing up the main SMF files?? If so, are there any specific things I need to avoid or do?


who is your host and what mods do you have installed?


The host is Hostgator, and the package manager is showing that NO mods are installed. However, all the mods we had before the update are already sitting in the Browse section, and the files are sitting on the server in the Packages folder and the backups folder also has a bunch of files in it.


hostgator is a known overseller, best i can suggest you at this point is to find a new host that is not an overseller. next you know they will tell you to move up to a vps or another server package which you most likely dont need.


I understand that, however, I still need to know if I can safely delete the plugin files from the server without messing up the SMF main files.

Are there any SMF files that might be making it appear to PHP that the plugins are running? I don't have a problem with deleting the package files from the server, I just need to know if that will cause any problems with SMF main files. Will deleting the package files do ANYTHING in realation to the PHP memory allocation?


smf does not have any "plugins" we have mods, and many mods have code in the main files, so i am unsure what you are talking about with plugin files.



Just as a 'for instance', according to the SMF Package Manager, there are no mods installed. However, from before the upgrade, Aeva has a folder called "mgal_data" in the forum root. Before the upgrade, I downloaded the "forum" folder to my computer as a backup, so I have that "mgal_data" on my computer. Can I safely delete that folder from the server without affecting the other SMF files?