SMF Support > YaBB/YaBB SE

Yabb 2.5AE to SMF Error...

(1/3) > >>

Hi all,

I am new here (first post).  I am wanting to move a couple of forums from Yabb 2.4 & 2.5AE to SMF and found an older converter.  I read up on it and also downloaded the additional file.  I also saw that some others (on this forum) have had success in converting 2.5AE to SMF.  When I ran the converter, this is the error I got:

Converting membergroups... Successful.
Converting members... Unsuccessful!
This query:
FROM `corners0_smf168`.smf_membergroups
Caused the error:
Unknown column 'groupName' in 'field list'

I am not proficient with code so I don't know what this means.  I understand that it found a column it didn't like in the field list, but apart from that, I don't know what to do with the information it is telling me nor do I know how to proceed in correcting it.  Any pointers or help in any way would be greatly appreciated. 

j razz

I've found a in my yabb directory- I assume this is the same thing as membersgroups.txt (perhaps it converts it to .txt or just changes the file extension)?  When I open the file in notepad I cannot find groupName when doing a search in the file.  Maybe I'm on the wrong file but I couldn't find a membersgroups.txt.

j razz

I also found this in the error log:

[10-Oct-2011 21:15:45] PHP Warning:  file(/home/corners0/public_html/cgi-bin/forum/Variables/membergroups.txt) [<a href='function.file'>function.file</a>]: failed to open stream: No such file or directory in /home/corners0/public_html/smf/yabb22_to_smf.php on line 150
[10-Oct-2011 21:15:45] PHP Warning:  Invalid argument supplied for foreach() in /home/corners0/public_html/smf/yabb22_to_smf.php on line 151

That led me to look in the Variables folder and as the error states, there is no such file there.  I am going to make a dummy file and call it by that name to see if it is actually needed or just fussing that the file is not there.

I'll report back.

j razz

I tried a blank file as well as taking the file that ended in .pl, changing the extension and uploading it to the Variables directory.  Still no luck.

I am at a loss.  If anyone can help shed some light on this, it would be greatly appreciated.  Currently I am unable to log into my SMF forum (which is blank and not being used) because I told the converter to wipe out existing members... however, since SMF was installed via cpanel I believe I can just reinstall it without issue if need be.  Ideally though, I would like to import my members and log in using my login information from Yabb.

Thanks again for any help anyone can provide on this.

j razz

Are you using the route that IamTheBoy used?

--- Quote ---YaBB 2.5AE > yabb 2.4-smf1 tool > smf1.1.4 > smf2 > fix boards and perms > smf2.0.1
--- End quote ---

I followed that & it worked reasonably well, it was only the attachments that caused a major headache. I removed that folder & converted again, it worked fine but I had to manually upload the attachments into posts in SMF 2.01.

I'm afraid I'm not good with code/errors, so can't help with yours.



[0] Message Index

[#] Next page

Go to full version