News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Not returning to the Post

Started by djoos5, October 11, 2011, 01:13:27 AM

Previous topic - Next topic

djoos5

Not sure if this is a bug with the new release 2.01, and if it has already been reported, but when we post on our boards, it returns to the top of the topic, not to the post just made. How can I correct this, or is it needing fixed?

Thanks in advance!

Kermit

I tried now,and it worked as it should,it doesn't seem to be something with new version,please attach your Post.php file to your next post,so we can have a look
My Mods
Please don't PM/mail me for support,unless i invite you
Formerly known as Duncan85
Quote
"Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe."

A. Einstein

djoos5


MK4A52


djoos5

If it is any help, I have applied the following mods to my boards:

Custom View of attachments
which affects the following -
/boards/sources/manageattachments.php
/boards/sources/display.php
/boards/Themes/default/display.template.php
/boards/Themes/default/languages/modifications.english.php

Dice Roller code files
/boards/Sources/subs-editor.php
/boards/sources/subs.php
/boards/sources/subs-post.php
/boards/Themes/default/languages/modifications.english.php
Move the included file "dice_warn.gif" to "./Themes/default/images"
Move the included file "roll.gif" to "./Themes/default/images/bbc"

Justify code files
/boards/Sources/subs-editor.php
/boards/sources/subs.php
/boards/Themes/default/languages/modifications.english.php
Move the included file "justify.gif" to "./Themes/default/images"

Admin Notepad code files
/boards/Themes/default/languages/modifications.english.php
/boards/index.php
/boards/Themes/default/admin.template.php
Move the included file "Notepad2.php" to "./Sources"

I also edit my Subs.php file to change my Menu selection across the top so it looks like the attached.

djoos5

All right, forget most of this post, as I just realized that when I post on the SMF forums it does the same thing.

Is there an issue with SMF 2.01 and the new Internet Explorer 9? Do I need to have something turned on when I go to my boards?

It is not that this is a major issue, it just is nicer when you his Post and it immediately reveals your post, instead of returning to the top of the particular Topic.

Thanks in advance for the help.


djoos5

Okay... with the Compatibility View option activated in my IE9 browser, the forum reacts how it should.

Not sure if that is something the programmers want to know, but that is what's happening... at least for me.

Thanks for the help.

Michael Pfaff

Hey djoos5,

What dice roller mod are you using? I'm looking to install one for my 2.0.1 SMF.

Thanks!

Mike

djoos5

I actually have two:

I use the Dice Roller mod that you can get on the SMF site under Modifications, which allows you to roll inside the post. It is a good roller, but it will not allow you to go back and edit the post, if there were any errors. I understand why because it keeps the dice roll from being questioned, but it can sometimes be an inconvenience when GM'ing.

I also have a java-based roller that I downloaded from Wizards of the Coast site a long time ago. It is simple java and html that opens a separate window for rolling. The only problem with it is that you can't keep record of the rolls, all you can do is cut and paste the results. This roller has to keep players on the honor system. Still, it is a convenient tool. I have no problem zipping the files up if you want them. PM me with an address you'd wna the files to go to. You will just have to tweak your SMF software to open the roller.


Joker™

Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

djoos5

I just read through the attached link. Is there something I need to do to my Load.php file, or is that a bug tracker? I am still a newbie on these boards and I am not sure if that was for me or for the programmers.  ;)

Thanks

Joker™

Quote from: djoos5 on October 14, 2011, 03:59:22 PM
I just read through the attached link. Is there something I need to do to my Load.php file, or is that a bug tracker? I am still a newbie on these boards and I am not sure if that was for me or for the programmers.  ;)

Thanks
I've updated this issue as a bug in the bug tracker for our developers to work on it.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

djoos5

Thanks for helping me out with this.

Do you want me to mark this topic as solved, or will you guys take care of that?

Joker™

Quote from: djoos5 on October 14, 2011, 04:31:37 PM
Thanks for helping me out with this.

Do you want me to mark this topic as solved, or will you guys take care of that?
For now you can leave it as it is.

I've already made a quick fix for it. I'll try to test/debug/re-debug it after landing in home :P.
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

emanuele

Digging around... :P

Quote from: djoos5 on October 12, 2011, 06:33:46 PM
Is there an issue with SMF 2.01 and the new Internet Explorer 9?
More or less: IE9 is not recognized and so it is not working as expected in few cases (see issue 4850, but also 4887).

A possible fix would be to change:
Code (find) Select
$context['browser']['is_ie'] = $context['browser']['is_ie4'] || $context['browser']['is_ie5'] || $context['browser']['is_ie5.5'] || $context['browser']['is_ie6'] || $context['browser']['is_ie7'] || $context['browser']['is_ie8'];
Code (replace with) Select
$context['browser']['is_ie'] = !$context['browser']['is_opera'] && !$context['browser']['is_gecko'] && !$context['browser']['is_web_tv'] && preg_match('~MSIE \d~', $_SERVER['HTTP_USER_AGENT']) == 1;
...even if I wonder why all the !$contex...the preg_match at the end should be enough...or not?

and
Code (find) Select
$context['browser']['ie_standards_fix'] = !$context['browser']['is_ie8'];
Code (replace with) Select
$context['browser']['ie_standards_fix'] = $context['browser']['is_ie4'] || $context['browser']['is_ie5'] || $context['browser']['is_ie5.5'] || $context['browser']['is_ie6'] || $context['browser']['is_ie7'];

in Load.php.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Joker™

emanuele, some said somewhere (meh memory loss) that the whole browser function is going to be a re-write. Looking forward to it with the fix you have provided ;).
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

Arantor

The reason for doing that like that is because a bunch of browsers, especially older ones, used to stuff MS IE into their user agent. Kind of like how every browser out there indicates it's Mozilla compatible.
Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

Joker™

Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

emanuele

I know it will be rewritten.
But at the moment there are issues with browser detection and IE9 and this is a workaround that could be useful. ;)

* emanuele is just throwing few php lines all around. :P


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: