News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Titoli sezioni ma non leggi

Started by laudia, October 12, 2011, 01:47:40 PM

Previous topic - Next topic

emanuele

Soluzione veloce: decomprimi i pacchetti sul tuo computer e caricali via ftp nella directory Packages.
Es.
/Packages/mio_mod/tutti i file qui

Soluzione meno veloce: capire perché SMF non trova zlib. Prova a creare un phpinfo e postare il link (o mandamelo in privato se non vuoi che sia pubblico).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Vittorio

Allora emanuele...ho fatto come hai detto decompresso i file ed inviati via ftp nella cartella che hai detto, però quando clicco qui : Pacchetti installati non risulta installato.Quando clicco Sfoglia i pacchetti dice: Spiacente, la configurazione di PHP non fornisce la libreria zlib. Senza di essa la gestione dei pacchetti non può funzionare. Contattare il servizio di hosting riguardo questo problema per ulteriori informazioni..

Vittorio

La libreria zlib è presente sul server...

Registered PHP Streams  https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip 

emanuele

Un registered stream (a quanto ne so) è diverso dall'avere la funzione gzinflate.
Affiché il package manager funzioni hai bisogno di gzinflate.
Il fatto che non ti consenta di vedere la lista dei pacchetti se non c'è gzinflate lo considererei un bug...

Puoi provare ad ovviare così: apri Subs-Packages.php e cerca il codice
// This function sorta needs gzinflate!
if (!function_exists('gzinflate'))
fatal_lang_error('package_no_zlib', 'critical');

quindi rimpiazzalo con:
// This function sorta needs gzinflate!
if (!function_exists('gzinflate'))
return false;

gzinflate dovrebbe essere standard in php, quindi non saprei il motivo per cui non funziona...
Se poi "prima" funzionava ed ora no, mi fa pensare ad un qualcosa cambiato dall'host...a meno che tu non abbia fatto delle modifiche recentemente.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Vittorio

Emanuele GRAZIE. "Sembra" adesso vada bene.

emanuele

Il problema è che sembra soltanto, io cercherei di capire perché non funziona. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Vittorio

il "sembra" era solo per scaramanzia.... 8) ;D :D


Funziona perchè ho fatto come hai detto tu cioè questo:


Puoi provare ad ovviare così:

apri Subs-Packages.php e cerca il codice rimpiazzato con questo:

// This function sorta needs gzinflate!
   if (!function_exists('gzinflate'))
      return false;

Il perchè non funzionasse più...questo non so dirtelo..

auguroni.

emanuele

Invece il "sembra" è corretto, perché ti sembra che funzioni, ma in verità ha problemi, quindi io ti consiglierei di non ignorare il problema ma indagare il perché non funziona.
Comunque è solo un mio consiglio, liberissimo di ignorarlo. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: