• Welcome to Simple Machines Community Forum. Please login or sign up.
December 05, 2021, 08:03:28 PM

News:

Wondering if this will always be free?  See why free is better.


Aggiornamento Forum smf 1.1.10

Started by fabiolore, November 21, 2011, 05:27:24 PM

Previous topic - Next topic

fabiolore

November 21, 2011, 05:27:24 PM Last Edit: November 22, 2011, 06:10:55 AM by Darknico
Ciao a tutti , ho un problema con il mio forum . Ho installata al momento la versione 1.1.10 e se entro nel pannello di sistema mi dice che è vecchia e che posso procedere all'aggiornamento cliccando su un pulsante . Se ci clicco non mi si aggiorna. Allora ho provveduto all'aggiornamento manuale scaricando dal sito la versione 2.0 e copiando tutto il contenuto del file dentro la cartella serve sul server ftp sostituendo i file attuali con i nuovi e installando l'ultima versione clicca miosito/forum/update.php mi carica l'installazione e tutto quando ma non procede inquanto mi chidere alcune cartelle contenenti due file il file settings.php e settings_bak che io sul mio pc non  ho . COme posso procedere all'aggiornamento del sito vist che mi sta dando grandi problemi?

Grazie Fabio

emanuele

Ciao e benvenuto!

Prima di tutto, naturalmente prima di procedere all'aggiornamento hai fatto un backup, vero?
Settings.php dovrebbe trovarsi nella directory del forum (e quindi quella dove hai caricato i file dell'upgrade)...ora mi viene il dubbio che tu abbia cancellato i file vecchi prima di caricare quelli nuovi...possibile?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

fabiolore

Ciao , grazie per avermi risposto . Allora ho salvato tutta la cartella forum prima di provvedere ad aggiornare i file nuovi  infatti ora ho rimesso quello vecchio . Praticamente ora me mi guidi parto da 0 ad aggiornare .

emanuele

In teoria è sufficiente prendere il pacchetto "large upgrade", decomprimerlo e caricarlo in modo da sovrascrivere tutti i file di SMF; quindi apri /forum/upgrade.php ed il gioco è fatto.

L'importante è che non cancelli niente.
Il dubbio che mi è venuto prima, infatti, è che tu abbia cancellato la directory del forum e caricato quella del "large upgrade", in questo caso upgrade.php non troverebbe i file di configurazione (Settings.php) e  non sarebbe in grado di procedere.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

fabiolore

Allora , io ho scaricato il large update  scompattato tutto in una cartella sovrascrtitto tutti i file tramite filezilla e quando vado ad installare mi dice questo


come devo procedere ?

Grazie

emanuele

Ahhhh...ok, ma questo non è quello che hai scritto prima! :P

Tranquillo, il problema è che quei file non sono scrivibili, quindi quel che devi fare è accedere via ftp e cambiare i permessi almeno di Settings.php (ma già che ci sei cambia anche l'altro) a 644 (mi sembra), se questo non dovesse funzionare prova 755.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

fabiolore

Puoi essere un po piu dettagliato su come cambiare i permessi ? NOn sono molto pratico te ne sarei davvero grato .

Grazie  :D

Darknico

apri il tuo client ftp, non so se magari usi filezilla o altro, vai in quei file, tasto destro, cambia permessi (o CHMOD) e imposta 777
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Si uso filezilla, ho modificato i permessi ma mi da sempre lo stesso errore ... come procedo ?

emanuele

Vedo che il server è windos, non sono molto pratico a tal proposito, cambia qualcosa nei permessi?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Darknico

Quote from: emanuele on November 22, 2011, 05:53:59 AM
Vedo che il server è windos, non sono molto pratico a tal proposito, cambia qualcosa nei permessi?

eh si, non esistono! xD
I CHMOD sono solo di SO GNU/Linux
Piciu io che non me ne sono accorto...

@fabiolore hai hosting su Aruba??
Se si, hai messo SMF dentro la folder "Public" ?

EDIT: ho verificato, sei su aruba
Sposta tutto il contenuto di smf sotto la folder "Public", è l'unica cartella pubblica che ti permette di installare smf...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Si ho su aruba e dentro la cartella public c'è una cartella del forum e all'interno ci sono anche i file setting

Darknico

Sicuro che è tutto li dentro?
Allora forse si è persa i permessi, so che dal pannello di Aruba puoi ripristinare i permessi di quella folder, dai un occhiata..
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Quindi visto che non sono molto pratico , devo copiare tutto il contenuto dello zip scaricato il large update all'interno della cartella forum presente nella cartella public?

Darknico

si, ma lo hai già fatto no?

hai letto che ho detto qui?
Quote from: Darknico on November 22, 2011, 05:59:58 AM
Allora forse si è persa i permessi, so che dal pannello di Aruba puoi ripristinare i permessi di quella folder, dai un occhiata..
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Allora io avevo copiato i file del nuovo forum dentro la cartella forum non dentro la cartella public/forum .

Darknico

deve essere TUTTO dentro la cartella public, quindi avrai qualcosa tipo public/forum
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Se io volessi cambiare quelle cartelle che mi chiede  il percorso D:.... come si potrebbe fare visto che mi chiede quello pure se faccio la stessa cosa dalal cartella public

Darknico

non ho capito nulla...
cmq, da quanto ne so, non puoi cambiare la cartella public, ma la cartelle dentro si
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Allora  , io ho due cartelle con scritto forum una dentro miosito/forum l'altra dentro miosito/public/forum . Nono sono per niente pratico di queste cose per cui mi affido completamente a voi . Io ho provato a copiare il contenuto del file zip con il forum 2.0 dentro entrambe le cartelle . Nel primo caso all'interno della cartella miosito/forum la foto con su scritto l'errore l'ho postato ora ho provato a fare la stessa cosa con miosito/publuc/forum e mi esce questo :


Darknico

Deve essere TUTTO dentro la cartella public

Hai un forum gia funzionante o no?
Perchè se non hai nulla fai prima a cancellare tutto e fare un install DENTRO la cartella public...sta venendo un paciocco sta cosa...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Il forum è funzionante solamente che devo aggiornarlo visto che ho milioni di contatti spam che si registrano al forum , non cpisco perche ho queste due cartelle , perche mi chiede quel percorso locale dei file setting .

Darknico

Io non ho idea di cosa hai fatto, ma so che su aruba windows deve stare tutto dentro la cartella public
quindi, prendi il large upgrade, carica il contenuto dentro la cartella public/forum, poi lancia l'upgrade da li
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


emanuele

Beh, puoi provare a fare quello che ti dice il messaggio d'errore e modificare il tuo percorso (edit Settings.php) con inetpub in minuscolo (tanto windows se ne frega delle maiuscole/minuscole).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

fabiolore

Se apro il file setting.php mi li dentro c'è scritto l'indirizzo che mi chiede il famoso d e sarebbe cosi:

########## Directories/Files ##########
# Note: These directories do not have to be changed unless you move things.
$boarddir = 'D:\\Inetpub\\webs\\ti89it\\public\\forum';      # The absolute path to the forum's folder. (not just '.'!)
$sourcedir = 'D:\\Inetpub\\webs\\ti89it\\public\\forum/Sources';      # Path to the Sources directory.

ma se io volessi cambiare quelal directory visto che non ce l'ho sul pc come faccio a cambiarla e finalmente riuscire ad installare il forum nuovo ?

Darknico

Quote from: fabiolore on November 22, 2011, 09:06:39 AM
ma se io volessi cambiare quelal directory visto che non ce l'ho sul pc

Che centra il tuo pc??
Quello è il path del server ed è già giusto così!
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Scusa te l'ho detto che sono ignorante in materia , non lo sapevo .... comuqnue mi chiede sempre quelel cartelle per installare anceh se faccio partire l'installazione dalla cartella public

Darknico

io non so che stai facendo, ma non c'è nulla sotto /public/forum/upgrade.php
e secondo me non hai mai messo il contenuto del large_upgrade in quella cartella..
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Si l'ho messo mi dava l'errore che ho postato e ora o risistemato il forum vecchio , se guardi piu dietro ho messo una foto con l'errore che mi da se carico da public

Darknico

Ora che dovresti riavere tutto ok, carica il contenuto di un large_upgrade in quella cartella e vediamo un po'...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)



fabiolore

Caricato tutto e mi da il solito messaggio di errore :


Darknico

famo una cosa: scarica il repair setting
http://download.simplemachines.org/?tools

ficcalo dentro la cartella /public/forum, lancialo e sistema i link con quello che ti suggerisce (basta cliccare sul suggerimento sotto le text-box), poi rilancia l'upgrade...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Allora , io non so perche capitano tutte a me . Ho inserito il repair setting dentro la cartella forum  l'ho lanciato e mi diceva questo :

Settings.php cannot be written to by your webserver. Please modify the permissions on this file to allow write access.

Allora tramite filezilla sono rientrato dentro la cartella forum ho trovao il file setting.php tasto destro del mouse permessi file e a posto delle xxx o messo 777 e mi ha selezioanto tutti i permessi . Rilancio il repair setting e mi rida la stessa cosa che non posso salvare perche devo impostare i permessi . Io i permessi li imposto non è che devo modificare i permessi del Mysql ? perche in tal caso non so proprio come si fa .

Grazie

emanuele

In quale cartella forum hai messo il repair_settings?
Se quella in public allora hai probabilmente qualche problema con i permessi, dal pannello di controllo di aruba (come ha detto Darknico) puoi ripristinare i permessi correttamente (adesso non so dirti di preciso dove questo comando si trovi...), prova un po' a fare così. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Darknico

Io non so che hai fatto ma il tuo forum è morto al momento..
è inutile che imposti 777, su windows non esistono!
Se è dentro la cartella public, e c'era perchè l'ho visto, è un problema di aruba, ripristina i permessi dal pannello..

P.S. ovviamente reimposta il forum funzionante...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fabiolore

Ragazzi finalmente ci sono riuscito , ho installato la versione 2.0.1 .L'ho installato nella cartella miosito/forum e non nella cartella miosito/public/forum ho solamente dovuto modificare i perfessi di scrittura per la cartella forum dal pannello di controllo di aruba. Vi ringrazio per l'aiuto mi avete fatto capire un minimo come funziona visto che partivo da 0 .
Qual'ora volessi installare un'antispam visto che sono sotto attacco come faccio ?

Grazie Fabio

emanuele

Per prima cosa ti consiglierei di provare con le una o più "domande di verifica", vai in admin > configurazione > sicurezza e moderazione > anti-spam
Vai alla fine della pagina e puoi inserire delle domande che verranno poste a chi si cerca di registrarsi. Di solito sono piuttosto efficaci, sconsiglio però domande di matematica (troppo facili per un computer). ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

fabiolore

Attualmente ho l'ultima versione del forum la 2.0.1 , ho messo che per poter scrivere sul forum bisogna avere l'autorizzazione dell'amministratore . Per il forum attualmente è strapieno di spam e vorrei dare una belal ripulita salvando i messaggio buoni. COnosci un buon metodo e anche ababstanza rapido ?

Grazie Fabio

emanuele

Sto rivedendo un mio mod per introdurre qualcosa che possa essere d'aiuto in questa situazione, appena ho fatto ti faccio sapere! :P


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele

Il mod l'ho preparato, ma non ho potuto provarlo moltissimo e siccome riguarda la cancellazione di dati, preferisco essere sicuro di cosa fa... ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: