Advertisement:

Author Topic: Ohara YouTube Embed  (Read 201574 times)

Offline lucske

  • Semi-Newbie
  • *
  • Posts: 27
Re: Ohara YouTube Embed
« Reply #560 on: June 20, 2016, 01:02:44 PM »
Yes, it happens with all video's
Even video's like movietrailers give the same result.
If you can watch again now i put a trailermovie in the same topic as imagine...
So any movie from youtube results in partial viewing...
No other youtube mod is installed...

Thanks

Luc
« Last Edit: June 20, 2016, 01:15:49 PM by lucske »

Offline golimaar

  • Semi-Newbie
  • *
  • Posts: 21
Re: Ohara YouTube Embed
« Reply #561 on: June 20, 2016, 01:54:53 PM »
I am trying to install ohara youtube code, but i am getting an the following error.

You cannot download or install new packages because the Packages directory or one of the files in it are not writable!

Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,584
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Ohara YouTube Embed
« Reply #562 on: June 21, 2016, 02:15:13 PM »
Yes, it happens with all video's
Even video's like movietrailers give the same result.
If you can watch again now i put a trailermovie in the same topic as imagine...
So any movie from youtube results in partial viewing...
No other youtube mod is installed...

Thanks

Luc

How are you embeding the links?

Do you have any other youtube related script/mod/etc?
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline themavesite

  • Jr. Member
  • **
  • Posts: 183
Re: Ohara YouTube Embed
« Reply #563 on: June 28, 2016, 02:45:46 PM »
GIFV's suddenly aren't displayed any more, posts are blank for me :/
Example: http://forums.themavesite.com/index.php?topic=31946.new#new
TMS Forums
Since 2008 and still going strong! Join today! http://forums.themavesite.com/index.php

Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,584
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Ohara YouTube Embed
« Reply #564 on: June 29, 2016, 01:38:16 PM »
I just tested the mod and it works just fine : missallsunday.com/test/index.php?topic=12.0

how are you embedding it?  whats the url you're trying to use?
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline themavesite

  • Jr. Member
  • **
  • Posts: 183
Re: Ohara YouTube Embed
« Reply #565 on: June 29, 2016, 02:02:34 PM »
I just tested the mod and it works just fine : missallsunday.com/test/index.php?topic=12.0

how are you embedding it?  whats the url you're trying to use?

http://i.imgur.com/srjx6wP.gifv

Just like that, the url.
What could be wrong?
TMS Forums
Since 2008 and still going strong! Join today! http://forums.themavesite.com/index.php

Offline themavesite

  • Jr. Member
  • **
  • Posts: 183
Re: Ohara YouTube Embed
« Reply #566 on: June 30, 2016, 01:43:38 AM »
I just tested the mod and it works just fine : missallsunday.com/test/index.php?topic=12.0

how are you embedding it?  whats the url you're trying to use?

http://i.imgur.com/srjx6wP.gifv

Just like that, the url.
What could be wrong?

You can even right click the blank post and select "view video", but the gifvs don't display themselves :/ All white

http://forums.themavesite.com/index.php?topic=31946

http://forums.themavesite.com/index.php?topic=1593.new#new -> Only one gifv on this page works..
TMS Forums
Since 2008 and still going strong! Join today! http://forums.themavesite.com/index.php

Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,584
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Ohara YouTube Embed
« Reply #567 on: July 01, 2016, 09:41:48 AM »
Yeah, it seems the mod is correctly parsing the gifv but for some reason it isn't displayed by the browser, I have no idea why.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline themavesite

  • Jr. Member
  • **
  • Posts: 183
Re: Ohara YouTube Embed
« Reply #568 on: July 02, 2016, 01:52:09 PM »
Yeah, it seems the mod is correctly parsing the gifv but for some reason it isn't displayed by the browser, I have no idea why.
So what do I do now? :|
TMS Forums
Since 2008 and still going strong! Join today! http://forums.themavesite.com/index.php

Offline Ninja ZX-10RR

  • SMF Hero
  • ******
  • Posts: 2,155
  • Gender: Male
  • Sniper Legends
    • Flavio93Zena on Facebook
    • Virtual Interactive Games Entertainment Forum
Re: Ohara YouTube Embed
« Reply #569 on: July 02, 2016, 02:10:42 PM »
Quote
http://i.imgur.com/B9jtcKt.gifv Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/XBS7kaV.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/pWuVUn7.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/xbg5ivQ.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/IFEbJaE.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/BLqj1nc.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/2tS7WAS.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/mG6BofC.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/nBrxkAi.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
http://i.imgur.com/qOSi48F.webm Failed to load resource: the server responded with a status of 404 (Unknown Error)
When you click those, they redirect to a .gifv file, just like the one that actually displays on the site.
Not sure why it throws a 404 on most of those, though, the link is correct ._.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.
♥ Jess ♥

STOP EDITING MY PROFILE

Offline bob799

  • Semi-Newbie
  • *
  • Posts: 13
Re: Ohara YouTube Embed
« Reply #570 on: July 05, 2016, 10:59:11 AM »
Basically I have a problem when embeding youtube videos. It is only displaying a black screen and no video is playing or coming up? When I try vimeo it is fine the vimeo video displays and plays but with long black borders either side of it. Attached image below.



I do not get this problem with any other theme such as default or any others and I have installed this mod properly for my custom theme.

My theme details are as follows.

Theme name: Bright
Author: Pipee
Theme type: responsive bootstrap

I purchased it from smftricks.com

It only seems to be a problem with that theme? I have contacted the theme author but not heard anything back yet. Can you help?

Offline bob799

  • Semi-Newbie
  • *
  • Posts: 13
Re: Ohara YouTube Embed
« Reply #571 on: July 06, 2016, 05:19:34 AM »
I discovered that this mod is definately not compatible with some themes.

The following is the code below is what I see in firefox from the other themes that work with this mod.

<div id="oh_OOgpT5rEKIU" class="oharaEmbed youtube" style="width: 480px; height: 270px; background-image: url("//i.ytimg.com/vi/OOgpT5rEKIU/hqdefault.jpg"); background-size: cover;">

The code below is what is being projected on my theme where it does not work.

<div style="width: 480px; height: 270px;" id="oh_OOgpT5rEKIU" class="oharaEmbed youtube"></div>

Anyone that can fix this for the Bright theme? as I have had no replies yet.

Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,584
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Ohara YouTube Embed
« Reply #572 on: July 06, 2016, 09:52:56 AM »
This mod is compatible with all themes, unfortunately, there are external factors that can cause issues.

If you take a look at past support issues, 99% of them are related to external js scripts preventing this mod to work properly. Your case is the same, theres a conflict somewhere in that theme's js files.

It could be several things:

A js issue.
An old jquery version.
A theme or a mod wrongly loading jquery without checking if it has been already loaded before.
A mod overwriting the $context var used by this mod to inject the needed js and css files.

I have no control over what other mod or theme authors do.

Will need to take a look at a link to a page with an embedded video with the problematic theme on.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline bob799

  • Semi-Newbie
  • *
  • Posts: 13
Re: Ohara YouTube Embed
« Reply #573 on: July 06, 2016, 10:51:13 AM »
No worries I will just remove the mod. I have no free time to sort it out as I run a very busy, business. Will probably pay one of my technicians to have a look in a couple of weeks when it is quieter.

Thank you anyway.

Offline coltp45

  • Semi-Newbie
  • *
  • Posts: 73
    • Futbol Argento
Re: Ohara YouTube Embed
« Reply #574 on: July 15, 2016, 02:53:14 PM »
Hi Suki i have the same problem with the videos image. 



Before update the mod the videos shows great but after update to the last version no matters the width and height I see the same. 

The portal have one video.
http://www.futbol-argento.com.ar/index.php


Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,584
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Ohara YouTube Embed
« Reply #575 on: July 17, 2016, 10:17:17 AM »
Ca you post  alink to a specific post where this is happening?
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline coltp45

  • Semi-Newbie
  • *
  • Posts: 73
    • Futbol Argento
Re: Ohara YouTube Embed
« Reply #576 on: July 18, 2016, 11:43:24 AM »
Ca you post  alink to a specific post where this is happening?

http://www.futbol-argento.com.ar/index.php/topic,74.1950.html

But the problem is in all the forum.

Offline Rock Lee

  • Native Language Support Specialist
  • SMF Hero
  • *
  • Posts: 3,111
  • Gender: Male
  • I also speak english :D
    • BomberCode.Oficial on Facebook
    • RockLee-BC on GitHub
    • @Bomber_Code on Twitter
    • Bomber Code ~ La nueva era del conocimiento
Re: Ohara YouTube Embed
« Reply #577 on: July 18, 2016, 08:54:24 PM »
time updated to the new version mod did not give me problems now suddenly black screen appears me, but you hear background ... Changing the zoom with ctrl and + makes video appears smooth :/


Regards!

Edit:



Although I'm not sure if it is modifying itself... "Failed to load resource: the server responded with a status of 404 (Not Found)" It is my theme, part of youtube but it never repair that part out the other 3 not (It will bring some kind of problem if I use an old version of mod?)
« Last Edit: July 18, 2016, 09:05:57 PM by Rock Lee »
¡Regresando como cual Fenix! ~ Bomber Code © 2018
Ayudas - Aportes - Tutoriales - Y mucho mas!!!


Ayudame via PayPal

Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,584
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Ohara YouTube Embed
« Reply #578 on: July 19, 2016, 12:20:51 PM »
@coltp45, @Rock Lee  theres seems to be an issue with non-responsive themes, can you replace your /Themes/default/scripts/ohyoutube.min.js file with the one I'm attaching to see if the changes I made fixes this issues?

Be sure to clean your browsers cache or do a hard refresh (Control + F5)
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline coltp45

  • Semi-Newbie
  • *
  • Posts: 73
    • Futbol Argento
Re: Ohara YouTube Embed
« Reply #579 on: July 19, 2016, 07:36:03 PM »
Done Suki.

Works perfect now.
Thanks.