• Welcome to Simple Machines Community Forum. Please login or sign up.
October 17, 2021, 12:57:46 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Error when trying to upgrade 1.1.15 to 1.1.16

Started by topthumb, December 23, 2011, 01:45:19 AM

Previous topic - Next topic

TDNY

Quote from: K@ on December 23, 2011, 08:02:07 AM
Actually, on this occasion, let's say "To Hell with it!"

Zip attached.

If anyone wants to give me any grief about it, let 'em. :)

Thanks for the help K@ your .zip file worked perfectly.


bsd43

Quote from: SleePy on December 23, 2011, 01:24:10 PM
Does the following tag.gz file work better?

Still doesn't work. The zip file did.

ferrix

Agreed. K@ zip file worked.  You saved Christmas!

Trammell

Quote from: Geek on December 23, 2011, 06:59:29 AM
Quote from: Illori on December 23, 2011, 06:02:59 AM
well it installs fine on my 1.1.15 forum without issues so there is no reason for it to not install on your forum.

Comments like that lead me to believe support forums like this aren't needed.

Sorry, that was a very silly answer you gave.

Cheers!



Many of that person's responses, in both threads, are useless and condescending. That's not really new in the SMF world, though.

Rather than debate that nonsense, though, I'll suggest the following fixes:

1. Looking up IP addresses under North America has not worked for months, perhaps years. Please fix ASAP. It's silly for this not to function for this long.

2. There is still no decent obstacle to spambots flooding the site with regs. This has been a problem for years. Again, it's silly for this to be a problem for this long. I know other people who have SMF forums, and they have the same problem. Please fix ASAP.

I'm sure there are other things, but those will suffice. Your response to this message should not be one of the following:

1. "This is free software."

2. "Learn PHP and create your own forum."

3. "We're trying our best."

In short, limit your response to solutions only. Being condescending and useless in return will only prompt similar responses.

Have a nice day. And remember, if you're a techie, you don't have to be nice to people. But it might help.

Trammell

Back to the issue at hand:

It takes very little time to cut and paste the updated code into the proper places. It does take time to find the "array" section -- it's near the bottom of that file.

The other issues, though, such as non-functional IP searches for North America and the constant influx of bot registration, still need to be addressed. Those have gone on for years, and it's silly those problems are unresolved.

foghorn

Same keeps happening to me and has never happened before. With all these people having the same problem, can't you guys fix the issue? Also, not everyone uses PC, how about some instructions for Mac users, as well as PC users, please/

kat

Quote from: TDNY on December 23, 2011, 05:23:10 PM
Quote from: K@ on December 23, 2011, 08:02:07 AM
Actually, on this occasion, let's say "To Hell with it!"

Zip attached.

If anyone wants to give me any grief about it, let 'em. :)

Thanks for the help K@ your .zip file worked perfectly.



I have no idea what made me think to try it, to be honest.

Call it a flash of inspiration. :)

I believe the tar/gz is being worked on and it's causing some scratching of heads, unfortunately. :(

kat

Can you cut Illori a bit of slack, please?

This is just as frustrating, for us, as it is for you. :(

This is causing us some serious headaches and, as you might expect, post quantity is having to take presidence over quality, at the moment. :(

egil222

Just for the record ....   I had the same issue with the error message on  Linux server, running 1.15 and using the automated updating system failed with the error message about the archive being corrupt of incompatible but the zip that K@ uploaded did the trick.

Thanks K@ your assistance was far more helpful (and friendly) than the official support was.

Hope everyone has a great holiday!

Illori

there is no such thing as "official" support. and if someone cant duplicate the issue they give the advice they can, which is most likely [even confirmed by developers] it is a server side issue.

halpi

I had the same problem as everyone else. Except -- the first time I tried to install from the link in my Admin panel, my AVG AV caught two trojans trying to install themselves into my computer.

Everything I tried came up without good results including trying to unzip and rezip the files.

I finally downloaded the zip file from this thread, uploaded it successfully, and applied the mod.

Success!!

Thank you!

Pat

kichu

K@ ... :) Downloaded your file .. Uploaded in Packages , It Worked ! Thank you :D


Biology Forums

Quote from: Geek on December 23, 2011, 06:59:29 AM
Quote from: Illori on December 23, 2011, 06:02:59 AM
well it installs fine on my 1.1.15 forum without issues so there is no reason for it to not install on your forum.

Comments like that lead me to believe support forums like this aren't needed.

Sorry, that was a very silly answer you gave.

Cheers!

** append **

THIS is an answer:
http://www.simplemachines.org/community/index.php?topic=463103.msg3233948#msg3233948

Agreed.

cqdx

Thanks to all, the instructions from Argonaut and  zip file from K@ done the job with no further headaches.

Merry Christmas / Happy Holidays or just Happy New Day to everyone

Trammell

Quote from: Illori on December 24, 2011, 09:57:05 AM
there is no such thing as "official" support. and if someone cant duplicate the issue they give the advice they can, which is most likely [even confirmed by developers] it is a server side issue.

Debating semantics now, eh?

You know what the person means. Or I hope you do.

kat

Oh, please. Can we stop this sniping?

A) It's Christmas.

B) Everybody has different ways of doing things. Just because others don't do things your way, that doesn't make their way wrong.

Can we get a bit of the Christmas spirit going, please?

Pretty please?

EL34

Same error here except the upgrade went perfectly on my Windows server and I get the error on my Linux server.

Both forums are set up exactly the same

I will just wait until it works properly in the admin panel
Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

Trammell

Quote from: EL34 on December 24, 2011, 07:31:34 PM
Same error here except the upgrade went perfectly on my Windows server and I get the error on my Linux server.

Both forums are set up exactly the same

I will just wait until it works properly in the admin panel

You don't have to. Others say the zip solution worked. For me, once I saw there was very little code to update, I just did some copying and pasting. Not very efficient, but when the provided update doesn't work and the early responses are not all that helpful, it was time for Plan C.

That definitely works better than insisting repeatedly it has to be user error or a server problem. Others' results might vary.

Just remember: Techies don't have to be nice. But it probably helps if they are.

EL34

Quotewell it installs fine on my 1.1.15 forum without issues so there is no reason for it to not install on your forum

Thats' sad my man, you probably should change your title to something more appropriate




Anywho,
I finally found K's zip file and it installed fine on my linux box forum
To save others some time, it's in reply #13

Funny thing is, the 1.1.15 update was a tar.gz on the linux box and it installed fine

The tar.gz had no problems on my windows box forum, so that one went just fine.
Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

Advertisement: