Advertisement:

Author Topic: Member Group Icons  (Read 5190 times)

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Member Group Icons
« on: January 07, 2012, 08:28:27 PM »
Hi,

So I've been researching because I'm sure I can't be the first person with this problem, but I can't find anything really helpful. Basically the member group icons aren't showing up anywhere.  The default stars aren't even showing, however I've uploaded my own images for most of the groups. I'd like them to be in the post profiles like they should.

If it helps, this topic describes the same problem: http://www.simplemachines.org/community/index.php?topic=326672.0
However, the solution didn't work for me because not even the default images are working.

I have the Display.template.php file in my custom theme where it should be and the images are saved both to the default's images directory and my custom theme's images directory.

Also, I'm using version 2.0.1 but was planning to upgrade to the newest one tonight, probably.   My site is here: http://infinity.cyanfire.net .

P.S. I just saw another topic where it seemed to suggest that with the 2.0.2 update you can't have member group icons? Please let me know if that's the case because if so I won't update yet.


Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #1 on: January 08, 2012, 02:44:50 AM »
Ask in the Member Group Icons MODs support topic, since it has posted updates for these fixes.

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #2 on: January 08, 2012, 03:45:04 PM »
Sorry, I'm probably blind, but I'm not very familiar with this forum and can't find that. Is there any chance I can be linked to it?


Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #4 on: January 09, 2012, 12:05:39 AM »
Oh, I see what you guys are referring to.

I've actually tried that mod even though it's not actually what I'm looking for. I thought it might override whatever was wrong, but it doesn't seem compatible with our theme and I truly didn't expect it to work anyway because it wasn't made to do what I need, since what I need is something that comes standard with SMF.

Anyway, what I'm actually talking about are the member group icons that, by default, show under your name in emails and on your posts.  The default setting is those stars and you can set how many of them you want for each group.  However, those aren't showing up at all.     

It's not a modification though, it's just the default of the software. 

If there is still somewhere else I should look, I'd love a link there. :/  I'm mostly just confused right now.

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #5 on: January 09, 2012, 01:09:44 AM »
You named your Topic Member Group icons .... so it was natural for us to assume thats what you were referring to.

Is it not showing on a custom theme?  Check to see if they show on the SMF Default theme.  If so, then it's probably becvause you have to copy the images for those post/member group icons to the custom themes images folder.

Offline CYBERSMOKE

  • Semi-Newbie
  • *
  • Posts: 43
  • Gender: Male
    • CaRd3rS
Re: Member Group Icons
« Reply #6 on: January 09, 2012, 02:38:30 AM »
Well i fynk dis is de third similar case coming tru today
can u pls search de topics i fynk on page 3/4 ur answers may be there
HTTP:// CARD3RS.COM

That's watsup

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #7 on: January 09, 2012, 03:17:16 AM »
hcf, that's understandable. I had seen a topic that was called Member Group Avatars so I actually thought I was differentiating myself. haha

Now, I'm sure I'm going to make myself look totally silly, but checking the default theme was the first thing I wanted to try doing, but when I go to Manage & Install and change my theme it doesn't work. It doesn't work to change it to the other theme I have on there either. I've looked, but don't see anywhere else to change the current theme, so I don't know why it's not working.   Sorry to change the subject to yet another help issue. 

Cybersmoke - I had already looked through them, but on your word I looked again at the past 5 pages and there aren't any topics related to this. There are topics about avatars and icons and member groups, but none that address my issue.


Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #8 on: January 09, 2012, 03:37:09 AM »
but when I go to Manage & Install and change my theme it doesn't work. It doesn't work to change it to the other theme I have on there either. I've looked, but don't see anywhere else to change the current theme, so I don't know why it's not working.   Sorry to change the subject to yet another help issue. 

Ummmm.  Change your theme by goping to your profile.  Profile > Forum Profile > Look & Layout  >  ( change theme)

pick the theme that says "SMF Default Theme"  , and check to see if those icons appear

Well i fynk dis is de third similar case coming tru today
can u pls search de topics i fynk on page 3/4 ur answers may be there

 ???


« Last Edit: January 09, 2012, 03:40:39 AM by hcfwesker »

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #9 on: January 09, 2012, 04:31:26 AM »
Well that was a lot easier so thank you. lol And yes, they show up on the default theme, just not on mine.

I have the images saved to both the default and the custom themes images folders and they still aren't showing up on the custom theme. The different lines (personal avatar, ranks, etc.) aren't in the same orders either. I'm not sure if that is significant or not.

I just checked the third theme we have uploaded, which is just a random premade. Once I save the file there, it works on that one.

It definitely seems to be something with the code for our custom theme. The problem is I have no idea what to fix in our code.

???

*laughs*
« Last Edit: January 09, 2012, 04:35:08 AM by Tarissa »

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #10 on: January 09, 2012, 05:18:37 AM »
Try this.   Download the Display.template.php file from your custom theme and attach here just so I can check it out.

ALSO ... The Display.template.php file  in your custom theme, rename it to DisplayX.template.php file and just see how it makes it look on the posted messages page.   If you don't like it, you can always rename it back to Display.template.php file , I'm just curious
« Last Edit: January 09, 2012, 06:03:43 AM by hcfwesker »

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #11 on: January 09, 2012, 02:23:38 PM »
Changing the name to DisplayX does make the member group icon show, but it also takes the message background off which I can't have because my forum background makes the text impossible to see.

I've attached the file.  :D

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #12 on: January 09, 2012, 03:17:35 PM »
Someone did some kind of editing to the file, cause you can see where it should be, but was partially removed.  Unless the theme author left the codes header there so it could be manually put back in.  I really don't know, but in that file, here's the fix for it.

custom theme's Display.template.php

Find
Code: [Select]
// Show the member's primary group (like 'Administrator') if they have one.

Replace with
Code: [Select]
// Show the member's primary group (like 'Administrator') if they have one.
if (!empty($message['member']['group']))
echo '
<li class="membergroup">', $message['member']['group'], '</li>';

// Don't show these things for guests.
if (!$message['member']['is_guest'])
{
// Show the post group if and only if they have no other group or the option is on, and they are in a post group.
if ((empty($settings['hide_post_group']) || $message['member']['group'] == '') && $message['member']['post_group'] != '')
echo '
<li class="postgroup">', $message['member']['post_group'], '</li>';
echo '
<li class="stars">', $message['member']['group_stars'], '</li>';


Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #13 on: January 09, 2012, 06:39:02 PM »
Thank you for working on that. 

When I put that code in, I get an error when trying to access any threads. I attached a screenshot.

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #14 on: January 09, 2012, 07:35:30 PM »
Sorry, you never mentioned it was for the Core theme :P

Try replacing with this code instead.

Code: [Select]
// Show the member's primary group (like 'Administrator') if they have one.
if (isset($message['member']['group']) && $message['member']['group'] != '')
echo '
<li>', $message['member']['group'], '</li>';

// Don't show these things for guests.
if (!$message['member']['is_guest'])
{
// Show the post group if and only if they have no other group or the option is on, and they are in a post group.
if ((empty($settings['hide_post_group']) || $message['member']['group'] == '') && $message['member']['post_group'] != '')
echo '
<li>', $message['member']['post_group'], '</li>';
echo '
<li>', $message['member']['group_stars'], '</li>';

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #15 on: January 09, 2012, 07:49:05 PM »
Sorry about that.

I get the same Template Parse Error, but this time on line 943.

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #16 on: January 09, 2012, 08:09:12 PM »
That's exactly how that portion of the code looks on the Core theme.  That's really all I can do.  Perhaps someone has edited something there before they either shouldn't have or didn't know what they were doing, because part of the code I'm giving you was there, and part was missing.  so someone did some kind of file editing there.

If it's possible, list me all the MOds you have installed.  And be 100% it's the Core theme this is happening on.


Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #17 on: January 09, 2012, 08:23:11 PM »
At the time I didn't have any mods installed, but today I just installed a bunch.   It's behaving the same as it was though, so its not the mods. 

We may have broken it somehow. I don't know what we did though. lol  We are both familiar to coding, but brand new to SMF, and I know very little about programming. If you still need the mod list let me know.  Or even if you could direct me to the files that would affect that area maybe we can figure out what we broke. lol  Everything else works fine. It's only that one thing that's not working ><

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #18 on: January 10, 2012, 12:04:27 AM »
I need to know what MODs you have installed.  LIST THEM lol

So I can rewrite a fresh displaytemplate file with the MODs you have installed edited in the file, and see if that works.  It would be easier for me than to go through the entire file to see where someone messed up.


ACTUALLY ... if you only have a few MOds installed, uninstall them, then go ahead and upgrade to 2.0.2  ... I promise that will solve the issue.  Then reinstall the MODs you had.

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #19 on: January 10, 2012, 01:15:42 PM »
lol actually I already did upgrade before I installed the mods. xD I'll PM you the mods.

Do you hate me yet?? *feels like such a pain*   :-[

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #20 on: January 10, 2012, 05:14:35 PM »
You needed to install a fresh Display.template.php on the CORE theme before installing the MODs.  I didnt realize you were only on 2.0.1 , I thought you were on a lower version and would have required the "large" update package which would have installed all fresh files.

Offline Tarissa

  • Semi-Newbie
  • *
  • Posts: 41
Re: Member Group Icons
« Reply #21 on: January 10, 2012, 06:41:20 PM »
It worked! I didn't have to delete the mods though. I just replaced my display.template file with a fresh one and then added back a couple of the codes we'd altered.  It's back now.

Thanks so much for your help!

Offline hcfwesker

  • SMF Hero
  • ******
  • Posts: 2,213
  • Gender: Male
  • SMF 2.0.4
Re: Member Group Icons
« Reply #22 on: January 10, 2012, 07:32:27 PM »
Very nice.  Yeah, only edits you need to make for those added MODs would be anything edited in that one file. :)  Glad it's all sorted.

Offline Zurascape

  • Newbie
  • *
  • Posts: 8
Re: Member Group Icons
« Reply #23 on: June 15, 2013, 03:57:19 PM »
Hey guys, I was wondering, I am only seeing my icon in the "users online" block, everywhere else I can not see it, but i have all the "hide" boxes unchecked.. so yea, please help,

thanks :D

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 59,297
  • Gender: Male
    • Kindred-999 on GitHub
Re: Member Group Icons
« Reply #24 on: June 15, 2013, 07:43:31 PM »
ummm...

1- this thread is a year and a half old
2- this thread is marked as solved.
3- please open your own thread and clearly explain your problem (however, do note that admins can always see all users, whether they are marked invisible or not)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.