Advertisement:

Author Topic: Error on New Post  (Read 5087 times)

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Error on New Post
« on: January 08, 2012, 04:56:18 PM »
When someone makes a new topic.  They receive the following error:  The website encountered an error while retrieving http://<MY WEBSITE>/forums/index.php?action=post2;start=0;board=104. It may be down for maintenance or configured incorrectly.

It does create the post.

I'm not sure where to look.

kat

  • Guest
Re: Error on New Post
« Reply #1 on: January 08, 2012, 04:58:28 PM »
Anything in your error logs?

Tried "Repair stuff", in Admin>Forum Maintenance?

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #2 on: January 08, 2012, 05:20:40 PM »
Anything in your error logs?

Tried "Repair stuff", in Admin>Forum Maintenance?

Tried repair stuff.

Nothing in error log.

kat

  • Guest
Re: Error on New Post
« Reply #3 on: January 09, 2012, 07:06:11 AM »
Might be best to give your host the exact error-message and see what they say.

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #4 on: February 26, 2012, 04:01:32 PM »
Might be best to give your host the exact error-message and see what they say.

I am the host.. I have not been able to track it down.

kat

  • Guest
Re: Error on New Post
« Reply #5 on: February 26, 2012, 04:08:27 PM »
Ah... You never told us that. :P

I really don't have a clue, then, I'm afraid.

Sorry, mate. :(

Let's hope someone else does.

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #6 on: February 26, 2012, 04:38:58 PM »
Ah... You never told us that. :P

I really don't have a clue, then, I'm afraid.

Sorry, mate. :(

Let's hope someone else does.

Thanks...  After a bit more research I found an error message that says:  8: Undefined index: can_quote

kat

  • Guest
Re: Error on New Post
« Reply #7 on: February 26, 2012, 04:48:19 PM »
Yuk.

I doubt that'll affect new posts, though.

I could be wrong, of course.

Can you create that index? (Sorry, I'm not good with database stuff, I'm afraid).

Offline pushkardua

  • Semi-Newbie
  • *
  • Posts: 67
Re: Error on New Post
« Reply #8 on: February 26, 2012, 04:52:17 PM »
whats the latest mod you applied??

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,442
Re: Error on New Post
« Reply #9 on: February 26, 2012, 04:53:00 PM »
well it might help to know what file is causing the error, as that can help us determine if that error is causing the error on posting, which an error on quoting may not.

also it is not a database index, it is a file/php error

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #10 on: February 26, 2012, 04:56:31 PM »
whats the latest mod you applied??

I've uninstalled the mods, still there.  SO I re-installed them.. still there.

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #11 on: February 26, 2012, 04:58:19 PM »
well it might help to know what file is causing the error, as that can help us determine if that error is causing the error on posting, which an error on quoting may not.

also it is not a database index, it is a file/php error

The referenced file in the error log is:  Post.template.php  I have attached it.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,442
Re: Error on New Post
« Reply #12 on: February 26, 2012, 05:01:47 PM »
8: Undefined index: can_quote

is that the full error message? is there eval after it?

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #13 on: February 26, 2012, 05:03:06 PM »
8: Undefined index: can_quote

is that the full error message? is there eval after it?

Yes.

/home/***/public_html/***/forums/Themes/default/Post.template.php (main sub template - eval?)

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,442
Re: Error on New Post
« Reply #14 on: February 26, 2012, 05:04:13 PM »
Admin -> Server Settings -> Disable evaluation of templates
Then post any new error messages without eval in them

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #15 on: February 26, 2012, 05:50:12 PM »
I am not finding any error reference in SMF, or on the server.  Any else place I can look on the server (it is running apache)

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,697
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Error on New Post
« Reply #16 on: March 10, 2012, 01:14:14 PM »
When someone makes a new topic.  They receive the following error:  The website encountered an error while retrieving http://<MY WEBSITE>/forums/index.php?action=post2;start=0;board=104. It may be down for maintenance or configured incorrectly.

It does create the post.

I'm not sure where to look.
Does this happen to everyone? Do you get the same error when you try to post?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.
  Fooling around with an i7 990X @ 3,47Ghz / 12Gb / Win 10 x64 / 3840x2160


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #17 on: March 10, 2012, 02:38:07 PM »
Yes, and yes.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,697
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Error on New Post
« Reply #18 on: March 10, 2012, 02:39:00 PM »
You already noted you have checked your error log, but just to make sure - have you checked the server error log in addition to the SMF log?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.
  Fooling around with an i7 990X @ 3,47Ghz / 12Gb / Win 10 x64 / 3840x2160


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline indytycoon

  • Semi-Newbie
  • *
  • Posts: 14
Re: Error on New Post
« Reply #19 on: March 10, 2012, 02:41:58 PM »
I did, but I can look again.  Anything in particular might throw a flag?