• Welcome to Simple Machines Community Forum. Please login or sign up.

FancyBox 4 SMF

Started by Bugo, January 12, 2012, 04:28:36 PM

Previous topic - Next topic

Bugo

Quote from: gevv on February 19, 2021, 12:00:26 PM
FancyBox does not work when activated minimize the css and javascript files
I need details.

Quote from: gorbi on February 19, 2021, 01:45:20 PM
Fancybox does not work on smartphone
Try to install Responsive Curve


gorbi


Bugo

What ideas do you need? I'm not guessing from screenshots. I have the mod works.

gorbi

It works perfectly for me on the desktop version of the forum, but sometimes it does not work correctly on the mobile version. The size of the displayed picture is larger than the smartphone screen.

shadav

Quote from: gorbi on February 23, 2021, 06:12:22 AM
It works perfectly for me on the desktop version of the forum, but sometimes it does not work correctly on the mobile version. The size of the displayed picture is larger than the smartphone screen.

Quote from: Bugo on February 20, 2021, 05:24:15 AM
Try to install Responsive Curve

did you try to install the responsive curve?
Which theme are you using? Is the theme responsive?
does this do the same thing on any other themes?

gevv

Quote from: gorbi on February 23, 2021, 06:12:22 AM
It works perfectly for me on the desktop version of the forum, but sometimes it does not work correctly on the mobile version. The size of the displayed picture is larger than the smartphone screen.

+1   yes i am using a mobile compatible theme, there is this problem. There is a problem with external  images  (many)

+ pictures with external image  have incorrect alt tag  (alt="" {width}{height}="") 

fancybox (2.1 rc3)

<a href="https://ibb.co/HrrWjZv" class="bbc_link" title="" target="_blank"><img src="https://i.ibb.co/vJJ7S95/on-off-buton4eec311019eeada4.jpg" alt="" {width}{height}=""></a>


without fancybox

<a href="https://ibb.co/HrrWjZv" class="bbc_link" target="_blank" rel="noopener" style="border: 0px none;"><img src="https://i.ibb.co/vJJ7S95/on-off-buton4eec311019eeada4.jpg" alt="" title="" class="bbc_img" loading="lazy"></a>




                        
ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

Bugo

Paste the BBCode you are using.

gorbi

BBcode for attached image?

gevv

ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

gevv

[img]https://www.resimyukle.org/images/2021/03/11/41fbd2d00dbb69656bab848d9e231849.jpg[/img]
ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

Bugo

Unfortunately, I could not reproduce this issue on my test forum. Can you provide a link to your forum where I can see it?
Did you change any attachment settings on your forum?

woolly bugger

I'm having issues with 2.1RC4, after instilling the mod the images in a post are no longer displayed at all, instead you see this...


" class="fancybox" title="" data-fancybox="topic">" alt="">



Bugo

Did you install the latest version from Github? Test with it.

woolly bugger

Quote from: Bugo on August 02, 2021, 10:35:37 PM
Did you install the latest version from Github? Test with it.

github version of SMF two days ago...

Fancy Box from here, not github...

MazziBig

Quote from: woolly bugger on August 02, 2021, 10:30:22 AM'm having issues with 2.1RC4, after instilling the mod the images in a post are no longer displayed at all, instead you see this...
Quote from: Bugo on August 02, 2021, 10:35:37 PMDid you install the latest version from Github? Test with it.
FancyBox v0.8 not correct working with GitHub version of SMF 2.1RC after hxxp:github.com/SimpleMachines/SMF2.1/commit/0c441522a04571cfbe6832871a580d86f6df6b10#diff-6abd038855dcfe48a9c579b068758effd5314f6a0f4f4438a310305a9c14ae00 [nonactive]

Bugo

Thanks for your report. I will fix this issue in the near version.

woolly bugger

Hey Thanks for the Fancybox update!

I've installed it on my SMF 2.1 RC4 forum.

and it is working fine but I have a question about the display of the images and attachments that are now showing up @ 150 pixels wide x 113 or whatever to maintain correct aspect ratio...

I would like the images to remain the set size of up to 800 pixels and not have the image resized the thread.


Images are hidden from guest on my board...


Bugo

Wait for v1.0, I will add some new settings for attach tag and sizes.

woolly bugger

Quote from: Bugo on October 24, 2021, 09:17:05 PMWait for v1.0, I will add some new settings for attach tag and sizes.

Thanks, I really like this mod! 5 Stars!

Advertisement: