• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 04:59:17 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


SA Knowledge Base

Started by SMFHacks.com Team, January 20, 2012, 06:14:12 PM

Previous topic - Next topic

SA™

same file
try this
find

'default' => 'title DESC',
'reverse' => 'title',


replace with

'default' => 'title ',
'reverse' => 'title DESC',
http://samods.github.io/SAChatBar/

Xbox Live: smokerthecheese 360 or xbone
My Work
Piano Movers / Delivery service
QuoteMy allies are dead.
I'm 'bout to be too.
Zombies are chasing me.
F*** it, I'm screwed -___-

MrMike

Then insert an ORDER clause that reads 'ORDER BY title ASC' or modify the query to include the 'ASC' part.

Quote from: kevin.michiels on May 17, 2013, 08:33:40 AM
Lol, when i do that query, it gives me from "z to a" instead of "a to z" :p

Arantor

MrMike: What SA is saying is exactly that. He uses the GenericList system in SMF which accepts parameters rather than complete queries. It already has an ORDER clause in it and he posted the instructions to change that definition.

Or perhaps changing the default_sort_dir directive as well as the default_sort_col directive. GenericLists are complex beasts.
No good deed goes unpunished
All helpful urges should be circumvented

kevin.michiels

Quote from: SA™ on May 17, 2013, 09:51:20 AM
same file
try this
find

'default' => 'title DESC',
'reverse' => 'title',


replace with

'default' => 'title ',
'reverse' => 'title DESC',


This worked like a charm !
Many Many thanks, all u guys !! really appreciated :p
You'll probably see me again here in some time for some other requests hehe xD
Thanks !

Draffi

Please, can somebody help?

Is there a way, to show picture inside the text - not only at the end ?

I mean Inline Pictures...

Kindred

did you try using the img bbcode tag?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

kevin.michiels

Is it possible to pin one specific article at the top ?
Like you have a sticky topic ?

I know there is featured article, but thats just displayed at the main page.. I want one article in a sub category be placed at the top.. pinned..

Hope you guys can help me out ? ;)

Kindred

I do not believe this mod allows sticky topics
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

vbgamer45

No sticky articles/topics at this time.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

gerbil

many thanks for this mod its exactly what i have been looking for

i just need to learn how to work the permissions as i can only get the KB button in the menu when logged in as an admin.

Im sure i will get this soon though. in addition im using simple portal and together im sure will give me the tools i need to expand info

i had tried other things but for what i want it looks just the job.

ive been using smf for about 18 months and starting to get the hang of it  ;D

regards

gerbil

elf_fu

I'm having a small problem after installation where users (Chrome, Firefox, IE, AOL) visit a KB page, and the page is blank. Members have to refresh to make it work. No errors or issues when installed.

Does anyone have any idea what may contribute to this/a mod that might have made this happen? And how I might fix it?

SMF 2.0.5
SA Knowledge Base 1.0.2a

GR

vbgamer45

Quote from: elf_fu on September 13, 2013, 03:43:56 AM
I'm having a small problem after installation where users (Chrome, Firefox, IE, AOL) visit a KB page, and the page is blank. Members have to refresh to make it work. No errors or issues when installed.

Does anyone have any idea what may contribute to this/a mod that might have made this happen? And how I might fix it?

SMF 2.0.5
SA Knowledge Base 1.0.2a
Does it happen to guests to? Or only members. Also check your forum's error log for related errors
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

elf_fu

Hi vbgamer! Please forgive me for taking so long to reply to you. First, thanks for the response!

Second: here's the odd thing, now that I am using a different theme: Back n' Black, I don't seem to be having this issue. I am using that theme for Halloween, usually the default is Argentum 2 Enhanced. I turned on Error reporting after your suggestion and have let it run a while and do not seem to find any errors pertaining to Knowledge Base right now.

I am stumped then, as to what would be the error in another theme that might have been causing this.

GR

swt4ajp

Hey Guys

I have installed the SA Knowledge Base mod on a test community (running the latest smf 2.0.6)
I had no issues with installing the mod and going to the settings, Where I have the issue is creating a category.

It gives me the following error

Field 'count' doesn't have a default value
File: %LocalFolderRemoved%\Sources\KB\KBSubs.php
Line: 206

The only thing I can see on line 206 is      );

Every other setting I can change and use

Please help

taurus

Hi there
i just translated the SA mod to Portuguese PT non UTF8 version. Do you want the file ?

Regards

Bruno36

Hello! when I click in the Item menu I have an error message: Access Denied
http://www.scooter-chinois-4t.com/board/articles/
Bruno36 the French
SMF 2.0.9

margarett

Could be just a permissions issue, could be Pretty-URLs related.
Try to go to Pretty URLs configuration and add the action "articles" to the list of ignored actions.
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

never_1007

Hi SA,

I'm also getting this when I tried adding a category:

Field 'count' doesn't have a default value
File: %root%\Sources\KB\KBSubs.php
Line: 206

Please help.


emanuele

Yes swt4ajp and never_1007, there are probably several of these problems.
I think the only reliable fix is to fix the installer like this:
https://github.com/emanuele45/SA_Knowledge_Base/commit/1a30e423f13600ac590aba8359234b4ce32116f1

I run also into a:
Field 'thumbnail' doesn't have a default value
File: /KB/KBEdit_Add.php
Line: 777  <= The line value is not representative of the real place the error is occurring.

INSERT INTO smf_kb_attachments(`id_article`, `filename`, `date`, `filesize`)
VALUES
(7, '1393167191-mockup--screen2.jpg', '1393167191', '591085')

while trying t use the attachments.
To fix that, I did instead:
https://github.com/emanuele45/SA_Knowledge_Base/commit/beb2de3ebb12aab33f5b3f1673527d4abdf9e129


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

oroedel

smf 2.0.7 attachements doesn´t work!? Clicking on attechments, nothing happened. No error, simply nothing...

Advertisement: