Advertisement:

Author Topic: Posts exists but are NOT Displayed  (Read 3167 times)

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Posts exists but are NOT Displayed
« on: January 26, 2012, 04:36:42 AM »
Hi all.

A strange thing occurred to my forum.

Although the posts exists, these are not displayed.
I assumed that the posts exists since when I try to edit one, then inside the editor the code of the posts is displayed properly.

In other words everything seems to be correct except the fact that the  posts cannot be displayed.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #1 on: January 26, 2012, 05:10:46 AM »
Do the posts contain any accented letters? Got a link we can look at?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #2 on: January 26, 2012, 05:20:33 AM »
here is the link

http://macphalanx.dyndns.org [nofollow]

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #3 on: January 26, 2012, 05:22:53 AM »
I was hoping for a link directly to a topic where it was happening, but never mind.

So, when did this start happening?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #4 on: January 26, 2012, 05:25:24 AM »
I think it started to happen when i uninstalled SimplePortal but I am not really sure..

The strange thing is that the post do exists.
The display of the posts in view mode has something.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #5 on: January 26, 2012, 05:26:17 AM »
Quote
The strange thing is that the post do exists.
The display of the posts in view mode has something.

Yes, we established this already.

Quote
I think it started to happen when i uninstalled SimplePortal but I am not really sure..

When was it last working?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #6 on: January 26, 2012, 05:30:26 AM »
I am sure it was last working before I uninstalled SimplePortal.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #7 on: January 26, 2012, 05:35:43 AM »
Hrm, not sure why uninstalling SP would cause that to occur.

Do you have access to phpMyAdmin?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #8 on: January 26, 2012, 05:36:44 AM »
Sure I do

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #9 on: January 26, 2012, 05:52:58 AM »
Then take a look at the database and let me know what collation is being used for the tables, most importantly for smf_messages.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #10 on: January 26, 2012, 05:55:12 AM »
   utf8_general_ci

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #11 on: January 26, 2012, 06:00:54 AM »
OK, so I'm now a bit confused since that looks like it should be right.

If you use the default theme does it work?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #12 on: January 26, 2012, 06:06:04 AM »
no..

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #13 on: January 26, 2012, 06:15:47 AM »
OK... if you look at the smf_messages table directly, what are the listed collations for each column?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #14 on: January 26, 2012, 06:23:16 AM »
1    id_msg    int(10)       UNSIGNED    No    None    AUTO_INCREMENT
2    id_topic    mediumint(8)       UNSIGNED    No    0       
3    id_board    smallint(5)       UNSIGNED    No    0       
4    poster_time    int(10)       UNSIGNED    No    0    
5    id_member    mediumint(8)       UNSIGNED    No    0
6    id_msg_modified    int(10)       UNSIGNED    No    0
7    subject    varchar(255)    utf8_general_ci       
8    poster_name    varchar(255)    utf8_general_ci       No       
9    poster_email    varchar(255)    utf8_general_ci       No          
10    poster_ip    varchar(255)    utf8_general_ci       No          
11    smileys_enabled    tinyint(4)          No    1       
12    modified_time    int(10)       UNSIGNED    No    0       
13    modified_name    varchar(255)    utf8_general_ci       No
14    body    text    utf8_general_ci       No    None    
15    icon    varchar(16)    utf8_general_ci       No    xx       
16    approved    tinyint(3)          No    1       

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #15 on: January 26, 2012, 06:26:19 AM »
I don't get it. I see absolutely no reason why that shouldn't be working as expected.

Mind you, now SimplePortal is partly installed, partly not installed (and the forum is unavailable as a consequence since it can't find the Portal template) so going further is going to be tricky.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #16 on: January 26, 2012, 06:32:04 AM »
I can see where it is going..

Therefore I must admit to myself to consider the topic closed and removed.

I will make a full backup from a previous (a lot outdated) version.

Thanks a lot for your patience and help.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #17 on: January 26, 2012, 06:49:48 AM »
Try restoring a backup of the *files*. I'm not sure the database is damaged at this point - you can use the 'large upgrade' package to refresh all the files without altering the DB.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #18 on: January 26, 2012, 11:19:07 AM »
I restored the files.

However a message that notifies for an error in database appears.

Is anything I should to do to find a clue why is this happening?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,795
    • StoryBB/StoryBB on GitHub
Re: Posts exists but are NOT Displayed
« Reply #19 on: January 26, 2012, 11:22:05 AM »
Look in the error log? Without knowing what the database error is, it's impossible to debug
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline deb8

  • Semi-Newbie
  • *
  • Posts: 12
Re: Posts exists but are NOT Displayed
« Reply #20 on: January 26, 2012, 11:40:42 AM »
these are the latest entries in the error log. hope they help

(4739, 1327593778, 0, '83.235.191.63', '?http://macphalanx.dyndns.org/', 'Σφάλμα βάσης δεδομένων: Unknown column ''spb.allowed_groups'' in ''field list''<br /><br />\r<br />      SELECT\r<br />         spb.id_block, spb.label, spb.type, spb.col, spb.row, spb.state,\r<br />         spb.force_view, spb.allowed_groups, spb.permission_type, spb.display,\r<br />         spb.display_custom, spb.style, spp.variable, spp.value\r<br />      FROM smf_sp_blocks AS spb\r<br />         LEFT JOIN smf_sp_parameters AS spp ON (spp.id_block = spb.id_block)\r<br />      WHERE spb.state = 1\r<br />      ORDER BY spb.col, spb.row', '12dc7aa42b7c80aafb7b4bd1d64d004a', 'database', '/users/deb8/www/macphalanx/Sources/Subs-Portal.php', 346),
(4740, 1327593778, 0, '83.235.191.63', '?http://macphalanx.dyndns.org/', '8: Undefined index: sitemap', '12dc7aa42b7c80aafb7b4bd1d64d004a', 'undefined_vars', '/users/deb8/www/macphalanx/Themes/default/Errors.template.php (body_below sub template - eval?)', 280);