No "Unread Posts" or "Show Unread Posts Since Last Visit" & Can't Update

Started by flamechica, February 06, 2012, 11:58:29 AM

Previous topic - Next topic



I have a couple things I need help with.

First off, every once in awhile (it doesn't happen all the time, but seems to be more frequent lately), people will have posted new topics or replied to posts and when someone (doesn't seem to matter who, it even happens to me) comes on the forum afterwards & clicks on "Show unread posts since last visit", nothing shows up even though there are new posts. Even if you click on the "Show all unread posts" that comes up on the screen when no posts show up after clicking on "Show unread posts since last visit" nothing comes up. The only way I know how to tell that there are new posts is to go to the board index page and scan down the page looking to the little icons that are highlighted next to each board name. This is kind of a pain and not to mention, some of the people on my forum aren't very computer savvy, so they don't understand me when I tell them to do this instead if it's not working. I am running SMF 1.1.15 because I can't update to the newest version, but that will be explained below, because that is another issue as well. My forum is heavily modded, but I haven't added any mods in a long time and this just seemed to happen out of the blue.

So, as I said, I am running SMF 1.1.15, recently, I noticed I was running 1.1.12 and I started doing the updates. I got to 1.1.15 and was unable to update any further because it keeps telling me that the last package is corrupt or not valid. I have tried 2 different ways now, one is from the pink error message you get in your admin panel telling you that you are running an older version of SMF (which is how I upgraded from 1.1.12-1.1.14) and then when that didn't work, I went HERE and downloaded the upgrade and uploaded it to the package manager and I got the same error. Any ideas?


For the update, there's a problem with the tar.gz file. The easiest way to upgrade to 1.1.16 is to download the zipped version of the patch from this post an install it through the package manager.

I will see if I can push some people to get that update notice fixed so it uses the zip archive instead.
Michael Eshom
Christian Metal Fans


So, I did do what you said to update, but does anyone have any idea why I am missing new posts? I haven't added any mods in quite some time. This problem just happened out of the blue & it seems to be getting more & more frequent. It's quite annoying actually.


OK, so you were able to upgrade to 1.1.16?  You mention that your forum is heavily modded which makes it quite difficult to troubleshoot the problem.  I guess we should start with a list of the mods you have installed and see if any of those may have altered this function.  Unfortunately if you can's pinpoint when this started to occur, it is going to be quite difficult to determine what the cause is.
Jim "JimM" Moore
Former Support Specialist


Yes, I was able to update to 1.1.6  No, unfortunately, I am not able to pinpoint when it started to happen, but I haven't added in mods in probably over a year & this hasn't been going on that long...probably 2-3months. I think it has something to do with one of the updates...maybe an update & a mod conflicting. Not really sure.


1. Enhanced PM Warning Message 1.0
2. Advanced Contact Form 1.1
3. Member Color Link 3.0.7
4. Post_and_Change_as_Alternate_User 1.0
5. Hide Info Center from Guests 1.0
6. SMF 1.0.20 / 1.1.12 Update
7. Hide "Logged" & IP Image 1.0
8. SMF Staff Page 1.6
9. simplemp 3.2
10. Message for your guests 0.1
11. Google Analytics Code 1.1
12. SMF 1.1.15 Update 1.0
13. Avatar Under Membergroups Rank 1.3.KD
14. Admin Notepad 1.0
15. AllCaps Notifier 1.0
16. Hide Signatures for Guests 1.1
17. SMF 1.0.19 / 1.1.11 Update
18. Welcome Topic Mod 2.1
19. SMF 1.0.21 / 1.1.13 Update
20. Aeva Media 1.4a
21. SMF 1.1.14 Update
22. Random_Quote 1.1
23. Restrict Email Providers on Registration 1.2
24. Member Awards 1.1.2
25. Add Honey Pot to Track IP 1.1
26. Custom Profile Field Mod 3.2
27. SMF 1.0.22/ 1.1.16 Update
28. EmailFlash 2.0
29. lost login in post 1.0
30. SMF 1.0.17 / 1.1.9 / 2.0 RC1 Update
31. Bookmarks 2.2.1
32. LogModAccountEdits 1.9
33. Anti-Spam Verification Questions 1.02
34. SimplePortal 2.3.2
35. Global Headers Footers 2.0
36. Colorize Post 1.2
37. phpBB3_Login_Fix 1.0
38. Simple Theme Changer 1.0
39. Stop Spammer 2.3.7
40. Custom Field on Posting 1.0
41. SMF Logo Clickable 1.0
42. Color & BgColor BBCode Bar 3.3.1
43. SMF Gallery Lite 3.0.1
44. SMF Arcade 2.0.18
45. BK-SMF News Stay Mod 1.5

It just occurred to me to see if there was anything showing up in my error log and all I get is a white screen when I try to access that...


In your admincp what do your get when you look at the detailed version information?  Does it all show current?
Jim "JimM" Moore
Former Support Specialist


SMF FileYour VersionCurrent Version
SMF PackageSMF 1.1.16SMF 1.1.16
Default Templates1.
Language Files1.


Those look ok.  I don't see any of those mods that would affect the problem that you mention.  I would think that you getting a white screen while trying to access your error log is something you will need to fix as soon as possible.  You might want to make sure the Errors.template.php file doesn't have an issue as well as the Sources/Errors.php file.  Compare your files with clean files from the large upgrade or the full install package.  The only differences you should find would be ones that some of your mods would have done.
Jim "JimM" Moore
Former Support Specialist


I am having the same problem running 2.0.2  And it never works for me!  I have never been able to see any "unread" posts.  I am not sure what to do.  Any ideas?


Any update on this flamechica?  Were you able to compare the files?

@AReaCCHS - Please post your issue in the 2.x support forums.  The issue may be similar however we like to keep the topics in the correct forum and we want to provide the best support we can to each person individually.
Jim "JimM" Moore
Former Support Specialist