News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

[Theme]Windows XP (1.1rc1 & 1.0.5)

Started by 061, August 25, 2005, 05:15:06 AM

Previous topic - Next topic

Klozi

Quote from: Deil on September 07, 2005, 03:32:51 PM
Quote from: Klozi on September 07, 2005, 02:47:13 PM
Very nice, but I think, it needs some time to be loaded completly.  :D

depends on your connection speed, loads quick for me,

My connection is not the problem, cause I checked e.g. that page, and it takes more than 8 seconds to load that simple page. For this page, he needs only 1 second.
I think, you have loaded the stuff into your temp dirs, and because that it's not a problem for you.

Elmacik

#61
theme package was a bit over of 300 KB, now its over 600 :-\
its improving :)

i am still waiting for the psd stuff :-\

latest review: still too many errors (old ones are fixed, these are new)


Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: table_pading_t
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 110

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: table_pading_b
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 115

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: table_pading_r
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 120

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: table_pading_l
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 125

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xp_home
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 131

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: swap_home
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 137

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: swap_home2
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 138

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xp_columns
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 144

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: the_divider
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 145

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xpdisplay_pic
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 150

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xpdisplay_pic1
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 152

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xpdisplay_pic2
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 153

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xpdisplay_pic3
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 154

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xpdisplay_pic4
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 156

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: shout_position_t
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 161

Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: shout_position_r
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 166

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: float_shout
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 172

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: embed_shout
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 177

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xp_menu_1
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 182

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xp_menu_3
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 186

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xp_menu_4
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 191

Home of Elmacik

Elmacik

#62
by the way, why the custom links are removed form the start menu?
and how can i make my threads look like txt files just as in you demo?
and why are there no characters set as default? (i mean merlin and others.. nothing seems by default)
edit: rover is default but doesnt show up
Home of Elmacik

Chris Cromer

Why is there a music option in the menu? I don't have a music mod installed.

Quoteand how can i make my threads look like txt files just as in you demo?
The threads are showing as text files for me.
Chris Cromer

"I was here, here I was, was I here, sure I was" - The little voice in my head.

Elmacik

Home of Elmacik

Chris Cromer

Found the option that turns it on. It's called "Show the messages in grid view" and it's in the current theme's settings in the admin center when you are in that theme.
Chris Cromer

"I was here, here I was, was I here, sure I was" - The little voice in my head.

061

#66
strange i am not getting any error  :-\
is any one else getting the same stufff....
i am not sure why u are getting them...i will do another check for these..thanks


Quote from: elmacik on September 08, 2005, 06:06:20 PM
by the way, why the custom links are removed form the start menu?
and how can i make my threads look like txt files just as in you demo?

should be there in current theme area

Quoteand why are there no characters set as default? (i mean merlin and others.. nothing seems by default)
edit: rover is default but doesnt show up
Quote from: Chris Cromer on September 08, 2005, 06:42:52 PM
Why is there a music option in the menu? I don't have a music mod installed.

Quoteand how can i make my threads look like txt files just as in you demo?
The threads are showing as text files for me.

sorry actually i am not at my place..so i never tested it on my local server...will fix the pakage...

@ Chris Cromer

find  in index.template.php

// Music Database mod
if (allowedTo('mdbview'))
echo '
<a href="', $scripturl, '?action=music">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/music.gif" alt="Music" style="margin: 0px 0;" border="0" />' : 'Music'), '</a>', $context['menu_separator'];

// if (allowedTo(array('mdbadd','mdbmodify','mdbdelete')))
// echo '
// <a href="', $scripturl, '?action=musicadmin">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/music_admin.gif" alt="Music Admin" style="margin: 0px 0;" border="0" />' : 'Music Admin'), '</a>', $context['menu_separator'];




either remove it or comment the 1st part



Quote from: Klozi on September 08, 2005, 11:45:31 AM
Quote from: Deil on September 07, 2005, 03:32:51 PM
Quote from: Klozi on September 07, 2005, 02:47:13 PM
Very nice, but I think, it needs some time to be loaded completly.  :D

depends on your connection speed, loads quick for me,

My connection is not the problem, cause I checked e.g. that page, and it takes more than 8 seconds to load that simple page. For this page, he needs only 1 second.
I think, you have loaded the stuff into your temp dirs, and because that it's not a problem for you.

thats then not a theme thing...thats my server

Klozi

Quotethats then not a theme thing...thats my server

Okay, then is your server slow. I think, to slow for a good preview.

Elmacik

well, as you see, the errors are related with the theme and i have no other themes and no mods installed and smf is new, gives the errors only when i activate the theme.

something wrong with grid view:  when i DEACTIVATE the grid view for threads, they show in grids.. when i ACTIVATE "show messages in grid view"  then it viewed as txt files. i think a very little code mistake :)

my suggestions are still alive.. lol
if you can make the windows movable, that would be great and start menu should collapse when we mouse click on anywhere of the forum out of start menu.. (wouldnt be really good? )

also background problem is still the same. (blue empty band at the right side)

note: i know we want too much things :D
Home of Elmacik

J. Williams

#69
It would look better if the you on quick links had the 1st letter captalized to make it fit in

Found a little tiny error,user online arrow image is set to /Themes/WindowsXP_1_1b3/images/Xperience/leftbox_bu.gif
When it should be /Themes/WindowsXP_1_1b3/images/xperience/leftbox_bu.gif

Fixed the error

Go into boardindex.template.php & search for leftbox_bu & you'll find a capital x
Joshua Jon Williams
Back in Action.

DMS_Shaun

God, I cant wait to see this on 1.0.5.  I have it on my test 1.1 beta site, but my main site is 1.0.5 cause it has so many packages, etc.  Im about to pee my pants.  Hurry!  If you make it within 1 week, I'll paypal you $20.00

Chris Cromer

#71
I just thought of something that would make this theme even better. Make a special menu action that causes a blue screen of death. ;D

Edit: Or better yet, make an option in the users profile and in the admin center that allows it so when it's on you can have the blue screen of death popup after certain periods of time of use.
Chris Cromer

"I was here, here I was, was I here, sure I was" - The little voice in my head.

Oldiesmann

To make it so that the language strings for the theme settings show up properly in other themes:

Copy languages/xperience.english.php to Themes/default/languages

Modify Settings.template.php as follows:

Find
function template_options()
{
global $context, $settings, $options, $scripturl, $txt;


Add after that
loadLanguage('xperience');

Find
function template_settings()
{
global $context, $settings, $options, $scripturl, $txt;


Add after that
loadLanguage('xperience');

http://smf.oldiesmann.us/index.php?theme=26 (yes, I've already got 26 themes on that board :P)

Quote from: Chris Cromer on September 09, 2005, 08:13:36 PM
I just thought of something that would make this theme even better. Make a special menu action that causes a blue screen of death. ;D

Edit: Or better yet, make an option in the users profile and in the admin center that allows it so when it's on you can have the blue screen of death popup after certain periods of time of use.

lol
Michael Eshom
Christian Metal Fans

charlottezweb


Uexplode

Hey! This one looks extremly sweet!!!  :D
Hope to see the final soon.

Rock On Man!
Never straight and narrow
I won't keep in time
Tend to burn the arrow
Out of the line
********************
www.tuvebrink.se
********************

J. Williams

You guys can't expect the final to just appear,you've got like for example 5+ stages before final release
Joshua Jon Williams
Back in Action.

061

#76
Quote from: elmacik on September 08, 2005, 05:05:50 PM
latest review: still too many errors (old ones are fixed, these are new)


Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: table_pading_t
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 110

   Elmacik   September 09, 2005, 12:55:14 am 
127.0.0.1     39642b01a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index:
-----------------------------------
-----------------------------------
------------------------------------
a6d60c992cda903fb34ab0a6 
http://localhost/forum/index.php?action=theme;sa=settings;th=2;sesc 
8: Undefined index: xp_menu_4
File: G:\PHP\xampp\htdocs\forum\Themes\WindowsXP_1_1b3\Settings.template.php (eval?)
Line: 191




from Oldiesmann modification above i figured its xperience.eng.php that is the problem...well if i got that right...i think its better to simply remove it ...
try this one and see if errors occur,
just moved all language strings to settings.eng.php, thats the only thing i could figure out... i couldn't test it since i have no errors in my log to check for :-\...

Quote from: Oldiesmann on September 09, 2005, 08:24:00 PM
To make it so that the language strings for the theme settings show up properly in other themes:

sorry i didn't get that... and why loadLanguage('xperience'); should be included in lower level when i had already included that in index.template.php...thing complicating for me here  :)

Quote from: elmacik on September 09, 2005, 10:11:05 AM
something wrong with grid view:  when i DEACTIVATE the grid view for threads, they show in grids.. when i ACTIVATE "show messages in grid view"  then it viewed as txt files. i think a very little code mistake :)

my suggestions are still alive.. lol
if you can make the windows movable, that would be great and start menu should collapse when we mouse click on anywhere of the forum out of start menu.. (wouldnt be really good? )

also background problem is still the same. (blue empty band at the right side)

note: i know we want too much things :D


grid was for icons (grid view) (linear view) errr...oky i think i got that wrong  :P
changed to
"Show the messages as icons"

i found a drag script but i wont work for FF...searching for more
i will ask unknown abt that menu collapsing thing...but 1st i think its error thing to get rid of  :)



Quote from: scs on September 09, 2005, 11:30:22 AM
It would look better if the you on quick links had the 1st letter captalized to make it fit in

Found a little tiny error,user online arrow image is set to /Themes/WindowsXP_1_1b3/images/Xperience/leftbox_bu.gif
When it should be /Themes/WindowsXP_1_1b3/images/xperience/leftbox_bu.gif

Fixed the error

Go into boardindex.template.php & search for leftbox_bu & you'll find a capital x

yeah i fixed that already...

Quote from: DMS_Shaun on September 09, 2005, 08:10:03 PM
God, I cant wait to see this on 1.0.5.  I have it on my test 1.1 beta site, but my main site is 1.0.5 cause it has so many packages, etc.  Im about to pee my pants.  Hurry!  If you make it within 1 week, I'll paypal you $20.00

no need for that  :)...will get back today if things go fine for me i will give 1.0.5 at this same time tomorrow...i dont think it will take more than few hours.

Quote from: Chris Cromer on September 09, 2005, 08:13:36 PM
I just thought of something that would make this theme even better. Make a special menu action that causes a blue screen of death. ;D

Edit: Or better yet, make an option in the users profile and in the admin center that allows it so when it's on you can have the blue screen of death popup after certain periods of time of use.

:D also why not make an error screen that pops up every 5/6 seconds telling users they are on something like windows  :P


Quote from: charlottezweb on September 10, 2005, 11:59:54 AM
SIMPLY AMAZING.
Quote from: Uexplode on September 10, 2005, 06:10:16 PM
Hey! This one looks extremly sweet!!!  :D
Hope to see the final soon.

Rock On Man!
thanks a lot and  i think scs is right...i dont think i will be able to give final one early...not only becoz it requires more stuff to work on but also the time factor...my exams are nearing and its now getting tough for me to find more spare time... :(

J. Williams

#77
Instead of normal smf topic icons,how about you use tiny discs?
Joshua Jon Williams
Back in Action.

061

#78
Dont dl the new one. I just realized that the language strings for rest of forum should be in different language file than settings.Eng.Php  i will update the zip later.

061

err my server isnt working...
can someone attach these in 1st post
thanks

download updated pakage for 1.1b3
http://www.geocities.com/windowsxp_r1/WindowsXP_11b3.zip

download for 1.0.5
http://www.geocities.com/windowsxp_r1/WindowsXP_105.zip

Quote from: scs on September 11, 2005, 07:41:41 AM
Instead of normal smf topic icons,how about you use tiny discs?
will look nice but making them from scratch will take time...are there any already made ones in the graphics section?...lemme check

Advertisement: