SFM 2.0.2 Blank White Page

Started by T3CHN0, March 24, 2012, 01:37:52 PM

Previous topic - Next topic

T3CHN0

/index.php?action=admin;area=modsettings

Under Configuration
Admin >> Configuration      ""Any of the following""

Core Features
Features and Options
Security and Moderation
Languages
Modification Settings

I get a blank white page from all the above...
The rest of my forum works fine, I have no error's in my forum logs

And the only 2 error's I get in my Blue Hosting error logs is

[24-Mar-2012 10:22:27] PHP Fatal error:  Cannot redeclare modifybirthdaypostsettings() (previously declared in /home6/greensf2/public_html/green420/Sources/ManageSettings.php:2352) in /home6/greensf2/public_html/green420/Sources/ManageSettings.php on line 2445

[24-Mar-2012 10:22:33] PHP Fatal error:  Cannot redeclare scheduled_birthday_posts() (previously declared in /home6/greensf2/public_html/green420/Sources/ScheduledTasks.php:1864) in /home6/greensf2/public_html/green420/Sources/ScheduledTasks.php on line 2281


Any Idea's what I need to do?

No rush to fix it as of yet but there are settings I would like to change in Modification Settings that I can't get get into
If I can just fix Modification Settings for now, the rest can wait to another time

Kermit

Those error messages seem to be due to a modification

http://custom.simplemachines.org/mods/index.php?action=parse;mod=2026;attach=136953;smf_version=2.0_RC3

from that link you can check your codes manually,apparently some codes were added double or more,so you need to remove double added codes
My Mods
Please don't PM/mail me for support,unless i invite you
Formerly known as Duncan85
Quote
"Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe."

A. Einstein

T3CHN0

Yes the 2 Birthday mod errors are related and OK I will go over the install tomorrow and remove any double ups IF ANY.
the mod installed once and worked so I don't see how, "But will look all the same".

However I don't think the 2 errors from my blue host logs are related to my problem, was just having a look and there are
no related errors to my problems in either blue hosting or from the forum logs.

Thank you

MrPhil

Quote from: T3CHN0 on March 24, 2012, 01:53:17 PM
However I don't think the 2 errors from my blue host logs are related to my problem, was just having a look and there are no related errors to my problems in either blue hosting or from the forum logs.
Say what? Those two errors are everything to do with the white screen of death. They are fatal PHP errors, due to a mod being installed twice, and defining certain functions twice. You can use an editor to remove the duplicate versions of these two functions. There may be other problems lurking due to the double install, but there's no telling what will happen if you try to uninstall the mod twice -- it may still leave behind stuff.

Advertisement: